Пользовательского поиска

● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

EXCEL

  • Занятие 1. Электронная таблица
    • Понятие электронной таблицы
      • Упражнение 1. Книга Excel
      • Упражнение 2. Ввод данных
    • Форматирование листа Excel
      • Упражнение 3. Оформление ячеек
      • Упражнение 4. Стиль
      • Упражнение 5. Формат чисел
      • Упражнение 6. Добавление строк и столбцов
      • Упражнение 7. Размеры ячеек и их замораживание
    • Контрольное упражнение
    • Подведение итогов
  • Занятие 2. Формулы и функции
    • Вычисления в Excel
      • Упражнение 1. Ввод формул
      • Упражнение 2. Функции
      • Упражнение 3. Диапазон ячеек
    • Формулы
      • Упражнение 4. Копирование формуя
      • Упражнение 5. Поиск ошибок
      • Упражнение 6. Применение функций
    • Контрольное упражнение
    • Подведение итогов
  • Занятие 3. Графики и диаграммы
    • Добавление диаграммы
      • Упражнение 1. Мастер диаграмм Excel
      • Упражнение 2. Выбор типа диаграммы
    • Форматирование диаграммы
      • Упражнение 3. Подписи рядов данных
      • Упражнение 4. Форматирование текста
      • Упражнение 5. Добавление данных другого листа
      • Упражнение 6. Объемная диаграмма
      • Упражнение 7. Ряды данных
    • Контрольное упражнение
    • Подведение итогов
  • Занятие 4. Подготовка листов Excel к печати
    • Компоновка страниц
      • Упражнение 1. Ориентация и масштаб страницы
      • Упражнение 2. Настройка полей
      • Упражнение 3. Добавление колонтитулов
    • Сортировка и фильтрация
      • Упражнение 4. Сортировка данных
      • Упражнение 5. Фильтрация
    • Выбор печатаемых объектов
      • Упражнение 6. Разбиение на страницы
      • Упражнение 7. Скрытие строк и столбцов
      • Упражнение 8. Заголовки строк и столбцов
      • Упражнение 9. Задание диапазона ячеек
      • Упражнение 10. Настройка диаграмм
    • Контрольное упражнение
    • Подведение итогов


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Занятие №2

Формулы и функции

ТЕМА ЗАНЯТИЯ

С помощью формул и функций можно выполнять математическую и статистическую обработку данных листа Excel. На этом занятии вы научитесь:

  • вводить формулы;

  • пользоваться стандартными функциями;

  • ссылаться на диапазон ячеек;

  • выполнять сложные вычисления;

  • копировать формулы;

  • исправлять ошибки в формулах.

Вам, наверное, не раз приходилось подсчитывать сумму или среднее значение столбцов или строк таблиц. Excel может выполнять с данными ячеек листа те же вычисления, которые выполняются с помощью калькулятора. Формулы и функции Ехсе1 способны обрабатывать величины как конкретных ячеек таблицы, так и целых блоков (например, строк или столбцов). Формулы Excel могут быть очень сложны, а результат их вычислений, в свою очередь, можно использовать в других расчетах. Неоспоримым преимуществом электронной таблицы является то, что при изменении данных листа результаты вычислений моментально обновляются.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Вычисления в Excel

Все вычисления в Excel выполняются с помощью формул, которые можно вводить в любые ячейки листа. Если содержимое ячейки начинается со знака равенства (=), Excel полагает, что вслед за этим знаком идет формула, и пытается выполнить указанную операцию. Когда это удается, в ячейку с такой формулой выводится результат расчета. Если что-то не так, появляется сообщение об ошибке. Сама формула отображается в ячейке только в том случае, когда ячейка находится в режиме редактирования текста (то есть после двойного щелчка на ней). Если ячейка просто выделена, то ее формула выводится в строке формулы в верхней части окна Excel.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 1. Ввод формул

Самым простым способом задания формулы является ее непосредственный ввод в строку формул. У этого варианта есть лишь один недостаток — вы должны помнить правила построения формул Excel, названия встроенных функций и методы ссылок на ячейки листа.

  1. Откройте фaйл Электронная таблица.xls, созданный на предыдущем занятии. В этой рабочей книге есть лист Формулы, измененный в контрольном упражнении предыдущего занятия. Раскройте его. Первые семь строк листа должны выглядеть так, как показано па рис. 10.1, остальные ячейки будут пусты. Если это не соответствует действительности, отредактируйте лист.

  2. Щелкните на ячейке В10 и введите формулу =(СЗ-ВЗ)/ВЗ*100.

Знак равенства указывает программе Excel, что ячейка содержит формулу. СЗ и ВЗ — это ссылки на содержимое соответствующих ячеек. Если предположить, что таблица содержит объем продаж продукции различным клиентам, то (СЗ-ВЗ) — это прирост продаж для фирмы Фантом с января по февраль. Разделив полученную величину на ВЗ (продажи за январь), получаем относительный прирост продаж за месяц. Результат умножается на 100, что дает прирост в процентах. Как видите, в ячейки можно вводить простые, арифметические выражения со знаками +, -, *, / и скобками, определяющими последовательность выполнения операций.

В упражнении 2 предыдущего занятия вы изучили прием автозаполнения ячеек последовательными названиями месяцев и числами. Давайте воспользуемся тем же приемом для добавления однотипных формул.

Рис. 10.1. Ввод формулы

  3. Щелкните на ячейке В10 и перетащите угловой маркер выделения вправо, чтобы оказались охваченными ячейки с В10 по F10.

Примечание

Чтобы результат выводился в процентах, не обязательно умножать его на 100, достаточно сменить формат данных, выделив ячейку и щелкнув на кнопке Процентный формат панели инструментов Форматирование.

На первый взгляд кажется, что в ячейки C10:F10 должна дублироваться формула ячейки В 10, но это не так. Excel поддерживает механизм относительных ссылок на ячейки. Когда формула переносится на одну клетку вправо, точно так же смещаются все ссылки этой формулы (это верно и для смещения формулы в любых других направлениях на любое число клеток). То есть в ячейке С11 появится формула =(D3-C3)/C3*100, в ячейке D10 - формула =(E3-D3)/D3*100 и т. д. Чтобы проверить это, щелкните на каждой ячейке и изучите содержимое строки фор-•мул. В итоге ячейки строки 10 будут содержать относительный прирост продаж компании Фантом по месяцам.

  4. Выделите строки с третьей по седьмую.

  5. Щелчком на кнопке Вырезать (Cut) панели инструментов Стандартная (Standard) вырежьте их содержимое.

  6. Щелкните на ячейке А2 правой кнопкой мыши и выберите в контекстном меню команду Вставить. Данные таблицы переместятся вверх на одну строку. Теперь снова изучите формулы ячеек строки 10.

При смещении ячеек с данными с помощью операций вырезания и вставки ссылки на эти ячейки в имеющихся формулах модифицируются так, что в обновленной таблице в расчетах принимают участие те ячейки, в которые были перемещены исходные данные.

Примечание

Если необходимо, чтобы знак равенства в начале текста ячейки не воспринимался как индикатор формулы, а интерпретировался как символ, поставьте перед ним одинарную кавычку (').


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 2. функции

Excel поддерживает множество стандартных математических функций, которые можно вставлять в формулы. С тремя из них — СУММ (SUM), СРЗНАЧ (AVERAGE) и СЧЕТ (COUNT) — вы познакомились на предыдущем занятии. Чтобы научиться работать с другими функциями, выполните следующие шаги.

  1. Щелкните на ячейке Н8 и введите текст Максимум. Нажмите клавишу Tab.

  2. Щелкните на кнопке Вставка функции (Paste Function) панели инструментов Стандартная. Откроется окно диалога, показанное на рис. 10.2. Чтобы найти нужную функцию, можно кратко описать желаемую процедуру в текстовом поле Поиск функции (Search for a function) или же выбрать ее категорию в списке категорию: (Select a Category) этого окна диалога, а затем пролистать список Выберите функцию (Select a Function Name). Выделив имя одной из функций, вы увидите ее описание в нижней части окна диалога. Excel делит все функции на следующие категории:

    • Финансовые (Financial) — функции для расчета амортизации имущества, стоимости основных фондов, нормы прибыли, величины выплат на основной капитал и других финансовых показателей;
    • Дата и время (Date & Time) — операции прямого и обратного преобразования даты и времени в текстовые строки. Функции этой группы перечислены в табл. 10.1;

Рис. 10.2. Вставка функции

ТАБЛИЦА 10.1. Функции обработки даты и времени
Функция | Описание
ДАТА(DATE) | Возвращает дату в формате Excel
ДАТАЗНАЧ(DATEVALUE) | Преобразует дату из текстового формата в код Excel
ДЕНЬ(DAY) | День месяца заданной даты
ДНЕЙ360 (DAYS360) | Вычисляет количество дней между двумя датами на основе З60-дневного года
ЧАС (HOUR) | Час времени, заданного аргументом
.МИНУТЫ (MINUTE) | Минута времени, заданного аргументом
МЕСЯЦ (MONTH) | Номер месяца заданной даты
J-ДАТА (NOW) | Текущая дата и время в числовом формате
СЕКУНДЫ (SECOND) | Секунда времени, заданного аргументом
ВРЕМЯ (TIME) | Преобразует время дня в дробное число от 0 до 1
ВРЕМЗНАЧ (TIMEVALUE) | Преобразует время из текстового формата в дату в числовом формате
ДЕНЬ (TODAY) | Текущая дата в числовом формате
ДЕНЬНЕД (WEEKDAY) | Номер дня недели заданной даты
ГОД(YEAR) | Год заданной даты

    • Математические (Math & Trig) — математические и тригонометрические функции, некоторые из них приведены в табл. 10.2;

ТАБЛИЦА 10.2. Математические и тригонометрические функции
Функция | Описание
COS, SIN, TAN, | Тригонометрические функции
ACOS, ASIN, ATAN, ATAN2 | Обратные тригонометрические функции
COSH, SINH, TANH | Гиперболические функции
ACOSH, ASINH, ATANH | Обратные гиперболические функции
LN, LOG, LOG10 | Натуральный логарифм, логарифмы по основанию 2 и 10
EXP | Экспонента
НЕЧЕТ (EVEN), OKPyiTI(ROUND), ОКРУГЛВВЕРХ (ROUNDUP), ОКРУГЛВНИЗ (ROUNDDOWN), 4ETH(ODD) | Функции округления
ABS | Модуль (абсолютное значение)'числа
ГРАДУСЫ (DEGREES), | Преобразование радиан в градусы
РАДИАНЫ (RADIANS) | Преобразование градусов в радианы

ЦЕЛОЕ (INT) | Целая часть числа
ОСТАТ (MOD) | Остаток от деления
ПИ(Р1) | Число пи
СТЕПЕНЬ (POWER) | Возведение в степень
ПРОИЗВЕЛ (PRODUCT) | Произведение ряда чисел
СЛЧИС (RAND) | Возвращает случайное число
РИМСКОЕ (ROMAN) | Преобразование арабского числа в римское
КОРЕНЬ (SQRT) | Квадратный корень
СУММ (SUM) | Сумма ряда чисел
СУММ КВ (SUMSQ) | Сумма квадратов ряда чисел
ОТБР (TRUNC) | Отбрасывает дробную часть

ТАБЛИЦА 10.3. Статистические функции
Функция | Описание
СРОТКЛ(AVEDEV) | Среднее абсолютное значение отклонения от среднего
СРЗНАЧ (AVERAGE), СРЗНАЧА(AVERAGEA) | Среднее арифметическое аргументов
СЧЕТ (COUNT), СЧЕТЗ (COUNTA), СЧИТАТЬ ПУСТОТЫ (COUNT-BLANK), СЧЕТЕСЛИ (COUNTIF) | Количество чисел в списке аргументов
КБЛДРОТКЛ (DEVSQ.) | Сумма квадратов отклонении от среднего но выборке
CFFEOM (GEOMEAN) | Среднее геометрическое набора положительных чисел
МАКС (МАХ), МАКСА (МАХА) | Максимальное значение списка аргументов
МИН (M1N), МИНА (MINA) | Минимальное значение списка аргументов
ДИСП (STDEV), ДИСПА (STDEVA), | Функции расчета дисперсии
ДИСПР (STDEVP), ДИСПРА (STDEVPA) СТАНДОТ-КЛОН (VAR), СТАНДОТКЛОНА (VARA), СТАНДОТКЛОНП (VARP), СТАНДОТКЛОНПА (VARPA) | Стандартное отклонение по выборке

    • Статистические (Statistical) — функции для расчета среднего значения, дисперсии, статистических распределений и других вероятностных характеристик. Некоторые статистические функции перечислены в табл. 10.3;
    • Ссылки и массивы (Lookup & Reference) — операции преобразования ссылки на ячейку в число, расчета ссылок на основе числовых аргументов, вычисления числа строк и столбцов диапазона и других параметров, связанных с адресацией ячеек листа Excel;
    • Работа с базой данных (Database) — функции формирования выборки из базы данных и расчета статистических параметров величин, расположенных в базе данных;
    • Текстовые (Text) — функции для работы с текстовыми строками. Часть этих функций перечислена в табл.-10.4.

ТАБЛИЦА 10.4. Текстовые функции
Функция | Описание
СИМВОЛ (CHAR) | Возвращает символ с заданным кодом
ПЕЧСЙМВ (CLEAN) | Удаляет из строки все непечатаемые символы
КОДСИМВ (CODE) | Код первого символа строки
СЦЕПИТЬ(CONCATENATE) | Объединяет две текстовые строки
СОВПАД (EXACT) | Проверяет идентичность двух строк
ЛЕВСИМВ (LEFT) | Возвращает несколько левых символов строки
ДЛСТР (LEN) | Количество символов в строке
СТРОЧН (LOWER) | Делает все буквы текста строчными
ПРОПНАЧ(PROPER) | Делает первую букву прописной, а остальные — строчными
ПОВТОР(REPT) | Повторяет текст заданное число раз
ПРАВСИМВ (RIGHT) | Возвращает несколько Правых символов и роки
Т, ТЕКСТ(TEXT), ФИКСИРОВАННЫЙ (FIXED) | Преобразует число в текст
СЖПРОБЕЛЫ (TRIM) | Удаляет лишние (двойные) пробелы
ПРОПИСН (UPPER) | Делает все буквы прописными
ЗНАЧЕН (VALUE) | Преобразует текстовый аргумент в число

    • Логические (Logical) — шесть функций для работы с данными логического типа, то есть величинами или условиями, принимающими значение Истина или Ложь. Эти функции перечислены в табл. 10.5;
    • Проверка свойств и значений (Information) — функции проверки типа данных аргумента, режима форматирования ячейки, типа сгенерированной ошибки и других специальных условий.

ТАБЛИЦА 10.5. Логические функции
Функция | Описание
И (AND) | Логическое умножение
ЛОЖЬ (FALSE) | Возвращает ложное значение
ЕСЛИ (IF) | Возвращает одно значение, если условие истинно, и другое, если условие ложно
НЕ (NOT) | Логическое отрицание
ИЛИ (OR) | Логическое сложение
ИСТИНА (TRUE) | Возвращает истинное значение

В списке Категория (Function Category) есть также пункты Рекомендуемый перечень (Recommended), Полный алфавитный перечень (All) и 10 недавно использовавшихся (Most Recently Used), которые выводят соответственно список всех функций и 10 функций, применявшихся последними.

  3. Выберите в списке Категория окна диалога вставки функций (см. рис. 10.2) пункт Статистические.

  4. Выберите в списке Функция (Function Name) пункт МАКС.

  5. Щелкните на кнопке ОК. Откроется окно ввода диапазона ячеек, показанное на рис. 10.3.

Рис. 10.3. Окно ввода аргументов

Некоторые функции, например SIN, имеют только один аргумент, поскольку нельзя вычислить синус сразу двух чисел. Однако многие функции, подобные МАКС, способны обрабатывать практически неограниченные массивы данных. Такие функции могут воспринимать до 30 аргументов, каждый из которых является числом или ссылкой на одну или несколько ячеек.

Примечание

В качестве аргументов могут выступать также арифметические выражения и другие функции, возвращающие значения нужного типа.

С помощью функции МАКС вы сейчас найдете максимальный уровень продаж за один месяц для компаний Фантом, РИФ и Викинг.

Рис. 10.4. Выбор ячеек для первого аргумента

  6. Щелкните на кнопке в правой части поля Число 1 (Number 1). Окно диалога свернется в строку, открывая доступ к ячейкам листа.

  7. Выделите все числовые ячейки строки Фантом. Обозначение соответствующего диапазона ячеек появится в строке свернутого окна диалога ввода аргументов (рис. 10.4).

  8. Щелкните на кнопке строки аргумента. На экране снова развернется окно ввода аргументов.

  9. Щелкните на кнопке в правой части поля Число 2 (Number 2).

  10. Выделите ячейки B4:G4 и снова щелкните на кнопке строки ввода аргумента. Поскольку вы ввели уже два аргумента, Excel автоматически добавит поле ввода третьего.

  11. Введите в поле Ч и ел о 3 (Number 3), как показано на рис. 10.5, текст B6:G6. Это диапазон нужных ячеек строки Викинг. В окне диалога правее полей с аргументами демонстрируются их реальные значения. Ниже списка чисел отображается результат вычислений.

Рис. 10.5. Три диапазона ячеек в качестве аргументов функции МАХ

  12. Щелкните на кнопке ОК. В ячейке 18 появится максимальное число из диапазона, записанного в строках 2,4 и 6. Сама формула появится в строке формул в верхней части окна Excel. Щелкните в этой строке. Три аргумента функции МАКС, задающие три диапазона ячеек, будут выделены разными цветами, а соответствующие группы ячеек листа Excel окажутся обведенными рамками соответствующих цветов, как показано на рис. 10.6.

Рис. 10.6. Группы ячеек, выступающие в качестве аргументов формулы

Примечание

Если вы хорошо знакомы с синтаксисом функций и формул Excel, то можете просто вводить формулы в ячейки, как это делалось на предыдущем занятии, не пользуясь окнами диалога выбора функции и ввода аргументов.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 3. Диапазон ячеек

Для ссылки на данные ячеек листа в Excel используются имена клеток, состоящие из буквы столбца (или двух букв, если столбцов больше 26) и номера строки. Так как многие функции могут воспринимать в качестве аргументов целые массивы данных, нужно выучить правила ссылок на такие массивы.

  1. Щелкните на ячейке Н9 и введите текст Сумма. Затем нажмите клавишу Tab.

  2. Введите символы =СУММ () (=SUM ()). Эта формула вычисляет сумму всех величин, указанных в скобках в качестве аргумента.

  3. Щелкните в строке формул и поместите курсор между двумя скобками.

  4. Введите в скобки текст В: В.

  5. Щелкните на кнопке Ввод слева от строки формул. В ячейке 19 появится сумма всех ячеек столбца В, так как символы В:В обозначают все ячейки столбца В.

  6. Снова щелкните в строке формул. В таблице окажется выделенной та группа ячеек, которые описываются аргументом В: В, как показано на рис. 10.7.

  7. Повторите шаги с 3-го по 6-й, поочередно вводя в скобки формул значения из первого столбца табл. 10.6. Изучите, какие диапазоны ячеек соответствуют указанным условным обозначениям. Немного потренировавшись, вы сможете указывать в качестве аргумента 4>ункции любые группы ячеек листа. , Если в разных формулах часто приходится ссылаться на одну и ту же группу ячеек, особенно если в группу входят разрозненные ячейки из разных областей листа, ей удобно присвоить специальное имя.

  8. Протаскиванием мыши выделите ячейки B3:G3.

  9. Нажмите клавишу Ctrl и протащите указатель мыши по ячейкам B5:G5.

Рис. 10.7. Столбец В в качестве аргумента функции

ТАБЛИЦА 10.6 .Способы ссылки на группы ячеек
Обозначение | Группа ячеек
F3 | Ячейка на пересечении столбца F и строки-3
Е10:Е20 | Ячейки с 10-й по 20-ю в столбце Е
В15:Е15 | Ячейки с В по Е в строке 15
5:5 | Все ячейки строки 5
5:10 | Все ячейки строк с 5-й по 10-ю
В:В | Все ячейки столбца В
B:J | Все ячейки столбцов c B no J
А10:Е20 | Прямоугольная область пересечения строк с 10-й по 20-ю и столбцов с А по Е

  10. Введите в поле Имя (Name Box) слово Строки, как показано на рис. 10.8.

  11. Нажмите клавишу Enter.

  12. Щелкните на ячейке 19, введите формулу =СУММ(Строки) (=SUМ(Строки)) и нажмите клавишу Enter. В ячейке 19 появится сумма двенадцати ячеек строк Зи5.

  13. Щелкните на стрелке раскрывающегося списка Имя (Name Box).

Рис. 10.8. Именованная группа ячеек

  14. Выберите пункт Строки. Окажутся выделенными ячейки диапазона Строки. Таблица может содержать несколько именованных диапазонов ячеек. Такие именованные диапазоны значительно упрощают формулы, делая их более наглядными.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Формулы

Формулы Excel чрезвычайно многогранны и заслуживают того, чтобы написать о них отдельную книгу. Чтобы лучше изучить формулы, пользуйтесь справочной системой Excel, дающей исчерпывающую информацию обо всех функциях и правилах построения формул.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 4. Копирование формул

Иногда требуется провести одинаковые расчеты с разными группами ячеек. В такой ситуации можно сэкономить время и скопировать формулы, так как Excel поддерживает относительную адресацию ячеек. В строке 10 нашего примера уже есть формулы, рассчитывающие относительный прирост продаж по месяцам для клиента Фантом. Давайте скопируем их, чтобы получить таблицу прироста продаж для всех клиентов.

  1. Щелкните на любой непустой ячейке в строке 10. Вы увидите, что выбранная формула ссылается на ячейки строки 2.

  2. Выделите диапазон B10:F10.

  3. Нажатием клавиш Ctrl+C скопируйте ячейки.

  4. Щелкните на ячейке В11, а затем на кнопке Вставить панели инструментов Стандартная. Появится еще одна строка ячеек с формулами. Щелкните на любой из них и взгляните в строку формул. Вы увидите, что формулы новых ячеек ссылаются на данные строки 3, как показано на рис. 10.9.

  5. Щелкните на ячейке В 12 и нажмите клавиши Ctrl+V, чтобы вставить еще одну строку. Формулы этой строки уже будут ссылаться на данные строки 4. Таким образом, номера ячеек данных изменяются ровно на столько клеток, на сколько смещается вставляемая формула.

Рис. 10.9. Копирование формул

Примечание

Обратите внимание, что вырезание ячеек с формулами с последующей их вставкой в другое место листа никак не изменяет ссылки на данные.

  6. Вставьте тот же самый фрагмент в ячейки В13 и В14.

  7. Скопируйте заголовки строк из ячеек А2:А6 в ячейки А10:А14.

Примечание

Обычно Excel формирует относительные ссылки на ячейки. Но иногда нужно сослаться в формуле на клетку с константой, которая не должна меняться при копировании формулы в другую ячейку или при перемещении исходных данных. В этом случае пользуйтесь абсолютными ссылками, которые отличаются от относительных наличием символа $ перед буквой столбца, номером строки или перед обеими этими характеристиками, например $Е$15. В такой ссылке не изменяется та часть, перед которой стоит знак $. Например, копируя формулу =СУММ($В$2:$0$6) (=SUM($B$2:$G$6)) в другую ячейку, вы получите тот же самый результат, что и в исходной клетке формулы.

Операция суммирования строк или столбцов — одна из наиболее распространенных. Чтобы создать формулы сумм строк или столбцов, не нужно даже копировать ячейки, Excel предлагает еще более быстрый способ.

  8. Выделите группу ячеек 12:16.

  9. Щелкните на кнопке Автосумма (AutoSum) панели инструментов Стандартная.

  10. Осталось только ввести в ячейку II заголовок Итого, и столбец общей суммы продаж для всех пяти клиентов готов (рис. 10.10).

Примечание

Обратите внимание на значок вставки, появляющийся в правом нижнем углу вставленного фрагмента. Благодаря ему легко выбрать вариант вставки — хотите ли вы вставить число из копируемой ячейки или абсолютную либо относительную ссылки, нужно ли сохранять формат исходной ячейки и т. д.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 5. Поиск ошибок

По мере изучения формул и функций Excel вы, конечно же, будете делать ошибки. Это может быть неверно заданный диапазон ячеек, неправильное имя функции или просто пропущенная скобка. Excel зафиксирует ошибку и в случае неверного типа аргумента, если, к примеру, в ячейке вместо ожидаемой числовой величины оказалась текстовая.

Рис. 10.10. Автосумма

  1. ЩелкнитенаячейкеШивведитеформулу СРЗНАЧ B11:F11 (AVERAGE B11:F11).

  2. Нажмите клавишу Enter. В ячейке появится сообщение #ИМЯ (#NAME), которое \ указывает на ошибку в имени функции. Слева от него находится маленький значок помощника, содержащий раскрывающийся список, в котором приводятся возможные способы устранения ошибки. . В табл. 10.7 приведен список сообщений об ошибках, которые можно встретить в ячейках при работе с формулами.

  3. Чтобы исправить формулу, двойным щелчком на ячейке 111 перейдите в режим редактирования формулы.

Примечание

Инструмент автокоррекции формул сам исправляет наиболее очевидные ошибки. Например, если в рассматриваемой формуле вы забудете ввести только закрывающую скобку, программа сама добавит ее.

ТАБЛИЦА 10.7. Сообщения об ошибках в формулах
Сообщение | Описание ошибки
##### | Ширина ячейки недостаточна для отображения результата вычисления или отрицательный результат вычислении в ячейке, отформатированной как данные типа даты или времени
#ЗНАЧ (#VALUE!) | Неверный тип аргумента или операнда. Например, указание в качестве аргумента ячейки с текстом, когда требуется число
#ДЕЛ/0(#01У/0!) | Деление на 0
#ИМЯ (#NAME!) | Excel не может распознать текст, введенный в формулу, например неверное имя функции
#Н/Д (#N/A) | Данные ячейки одного из аргументов формулы в данный момент недоступны
*#ССЫЛКА (#REF!) | Неверная ссылка на ячейку
#ЧИСЛО(#МиМ!) | Невозможно вычислить результат формулы, либо он слишком велик или мал для корректного отображения в ячейке
#ПУСТО (#NULL!) | Результат поиска пересечения двух непересекающихся областей, то есть неверная ссылка

  4. Измените содержимое ячейки так, чтобы получилась формула СРЗНАЧ (В 11:F11) (AVERAGE(B11:F11)).


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 6. Применение функций

До сих пор вы пользовались только функциями СУММ, СРЗНАЧ, СЧЕТ и МАКС. Давайте рассмотрим на примере некоторые функции из разряда текстовых и логических, а также функции работы с датой и временем. Результат всех вычислений, которые будут выполнены в этом упражнении.

  1. В листе Формулы выделите и скопируйте ячейки Bl:Gl.

  2. Разверните лист ЛистЗ (Sheet3).

  3. Щелкните правой кнопкой мыши на ячейке А1 и выберите в контекстном меню команду Вставить.

  4. Введите в ячейку A3 формулу =ЛЕВСИМВ(А1 ;3) (=LEFT(A1; 3)). Эта формула возвращает три левых символа ячейки А1.

  5. Перетащите угловой маркер выделения вправо, чтобы рамка охватила ячейки A3:F3. Теперь в третью строку выводятся сокращенные варианты названий месяцев из ячеек первой строки.

  6. Щелкните наячейкеНЗ и введите формулу =СЦЕПИТЬ(ВЗ ;D3) (CONCATENATE (ВЗ ; D3)). В ячейке НЗ появится объединение строк Фев и Апр.

  7. В ячейку А8 введите формулу =ТДАТА () (=NOW ()) и нажмите клавишу Enter. В ней тут же появятся текущие дата и время.

  8. Введите
     в ячейки с В8 по В13 формулы = ГОД (А8) (=YEAR(A8)), =МЕСЯЦ(А8) (=MONTH
     (А8)),=ДЕНЬ(А8)(=DAY(А8)),=ЧАС(А8)(=HOUR(A8)),=МИНУТЫ(А8) (=MINUTE(A8))
     и =СЕКУНДЫ(А8) (=SECOND (A8)). В этих ячейках появятся по отдельности все
     шесть компонентов текущих даты и времени.

  9. Дважды щелкните на ячейке А8, чтобы перевести ее в режим редактирования.

  10. Щелкните на кнопке Ввод, расположенной слева от строки формул. Эта операция приведет к обновлению значения в ячейке А8, что повлияет и на числа ячеек В8:В13.

Теперь давайте выполним логическую операцию.

  11. ВведитевячейкуА4формулу=ЕСЛИ(АЗ="Фев"; "Да"; "Нет") (=IF(АЗ="Фев"; " Да "; " Н е т ")). Эта операция сравнивает значение ячейки A3 с текстовой строкой Фев. В случае равенства выводится текст второго аргумента — Да. В случае неравенства выводится текст третьего аргумента — Нет. Так как в ячейке A3 присутствует текст Янв, то результатом этой операции будет значение Нет.

  12. Растяните маркер ячейки А4 вправо, чтобы рамка охватила диапазон A4:F4. Теперь формулы строки 4 проверяют ячейки строки 3 на совпадение их содержимого со строкой Фев. Как видите, слово Да появилось только в столбце В.

Знаки, которые используются в Excel для сравнения величин, перечислены в табл. 10.8. Обратите внимание, что текстовые строки, выступающие в качестве аргументов функций, должны заключаться в двойные кавычки.

Примечание

Текстовые строки равны, если попарно совпадают все их символы, в противном случае строки не равны. Одна текстовая строка больше другой, если в ней код первого символа, несовпадающего в обеих строках, больше кода того же символа во второй строке.

ТАБЛИЦА 10.8. Знаки сравнения
Знак | Значение
= | Равно
> | Больше
< | Меньше
>= | Больше или равно
<= | Меньше или равно
<> | Не равно


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Контрольное упражнение

  1. В файле электронная таблица .xls раскройте лист Календарь, созданный в контрольном упражнении предыдущего занятия

  2. Щелкните в ячейке G3, введите формулу, вычисляющую среднее значение чисел строки 3 календаря, и нажмите клавишу Enter.

  3. В ячейку НЗ выведите целую часть этого среднего значения.

    • С помощью какой функции выделяется целая часть числа ?

  4. Продублируйте две полученные формулы во всех строках календаря.

    • Как продублировать формулы двух ячеек в нескольких строках?

  5. В ячейке Gil сосчитайте сумму средних значений, а в ячейке Н11 с помощью функции ПРОИЗВЕД произведение целых частей средних значений.

  6. В ячейке F11 с помощью функции СУМ М подсчитайте сумму всех ячеек третьей и четвертой строк листа Excel.

    • Как задать в качестве аргумента функции две строки листа ?

  7. Скопируйте содержимое ячейки F11.

  8. Щелкните на ячейке F13 и вставьте в нее формулу из буфера обмена.

    • Сумму каких ячеек подсчитывает вставленная формула?


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Подведение итогов

С помощью упражнений этого занятия вы научились вводить формулы, пользоваться функциями, копировать формулы, находить и исправлять ошибки. Вы узнали о механизме относительной адресации ячеек и изучили некоторые функции, работающие с текстовыми строками и величинами типа даты и времени.

Чтобы наглядно представить результаты вычислений, их нужно оформить в виде диаграммы или графика. Именно этому способу отображения данных Excel и посвящено следующее занятие.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Занятие №3

Графики и диаграммы

ТЕМА ЗАНЯТИЯ

На этом занятии изучаются приемы построения диаграмм, иллюстрирующих данные листа Excel. Вы познакомитесь с некоторыми компонентами и операциями, которые перечислены ниже:

  • мастер диаграмм Excel;

  • выбор типа диаграммы;

  • подписи маркеров данных;

  • форматирование текста;

  • совмещение данных разных листов;

  • объемная диаграмма;

  • ряды данных.

Модуль диаграмм приложения Excel автоматически генерирует диаграммы, отображающие данные листа в графической форме. Вам остается только выбрать нужный диапазон ячеек и указать тип диаграммы, а затем оформить полученный графический объект по своему вкусу.

Диаграммы Excel во многом похожи на аналогичные объекты, создаваемые модулем Microsoft Graph XP, о котором рассказывалось на занятии 7. Graph поддерживает те же типы диаграмм, что и Excel. В обоих этих модулях используются одинаковые приемы форматирования. Однако модуль диаграмм Excel не имеет отдельной таблицы данных, так как исходная информация считывается прямо с листа Excel. Панели инструментов диаграмм в Excel и Graph немного отличаются. Кроме того, в диаграмму Excel можно одновременно вставлять данные с разных листов.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Добавление диаграммы

Давайте продолжим работать с файлом Электронная таблица.хls. Откройте его в Excel и разверните лист Клиенты. В упражнениях этого занятия будет добавлена и отформатирована диаграмма, представляющая данные этого листа в графической форме.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 1. Мастер диаграмм Excel

Для создания диаграммы проще всего воспользоваться соответствующим мастером. Вы уже познакомились с ним на занятии 2. В этом упражнении подробно описываются все окна диалога мастера создания диаграмм.

Рис. 11.1. Выбор типа диаграммы

Рис. 11.2. Задание источника данных

  1. Чтобы указать мастеру диаграмм источник данных, выделите прямоугольную область ячеек A1:G7.

Примечание

Исходные числовые данные для диаграммы следует выделять вместе со строкой и столбцом заголовков таблицы, чтобы соответствующие названия автоматически появлялись в легенде и на оси категорий диаграммы.

  2. Выберите команду Вставка > Диаграмма (Insert > Chart). Откроется первое окно диалога мастера диаграмм, показанное на рис. 11.1, в котором нужно указать тип диаграммы, задающий ее оформление, и конфигурацию элементов, отображающих данные.

  3. В списке Тип (Chart Type) выберите пункт Линейчатая (Bar) или другую подходящую категорию.

  4. В разделе Вид (Chart Sub-type) щелкните на левом верхнем квадрате, задающем подтип Линейчатая диаграмма (Clustered Bar).

  5. Чтобы не выходя из окна мастера оценить будущий вид диаграммы, нажмите мышью кнопку Просмотр результата (Press And Hold To View Sample). В окне диалога вместо списка подтипов появится внешний вид будущей диаграммы. Отпустите кнопку мыши, и окно диалога вернется в прежнее состояние.

  6. Щелкяите на кнопке Далее (Next).

Второе окно диалога мастера, показанное на рис. 11.2, позволяет выбрать или скорректировать источник данных. Поскольку при запуске мастера в листе уже был выделен некоторый диапазон данных, он автоматически выбирается в качестве источника данных. Обратите внимание, что будущая диаграмма, общий вид которой отображается в окне диалога, содержит лишний ряд данных, появившийся из-за наличия в выделенной области пустой строки 2.

  7. Чтобы скорректировать источник данных, щелкните на кнопке, расположенной в правой части поля Диапазон (Data Range). Окно мастера свернется в одну строку, открыв доступ к листу Excel.

  8. Выделите ячейки Al:Gl.

  9. Нажмите клавишу Ctrl и, не отпуская ее, протащите мышь из ячейки A3 в ячейку G7. Эта операция добавит к выделению вторую группу ячеек, как показано на рис. 11.3.

Рис. 11.3. Скорректированный источник данных

  10. Щелкните на кнопке мастера диаграмм, чтобы вновь развернуть его окно диалога. Теперь в поле Диапазон появится формула =Клиенты!$А$1:$6$1; Клиенты! $А$3 :$G$7, которая с помощью абсолютных ссылок задает две области данных из листа Клиенты. Немного потренировавшись, можно научиться вручную вводить формулы источников данных любых конфигураций.

  11. 11. Переключатель Ряды в (Series In) позволяет группировать ряды данных по строкам или столбцам таблицы. Чтобы по вертикальной оси диаграммы выводились названия месяцев года, выберите положение строках (Rows) этого переключателя.

  12. Для перехода к окну диалога параметров диаграммы, показанному на рис. 11.4, щелкните на кнопке Далее.

Рис. 11.4. Настройка параметров диаграммы

Вкладка Ряд (Series) второго окна мастера диаграмм открывает доступ к инструментам, позволяющим гибко перестраивать источник данных, добавляя и удаляя ряды данных и задавая ячейки с заголовками строк и столбцов таблицы.

  13. Введите в поле Название диаграммы (Chart Title) текст Активность клиентов.

  14. В поля Ось Х (категорий) (Category (X) Axis) и Ось Y (значений) (Value (Y) Axis) введите названия осей (см. рис. 11.4).

  15. При необходимости с помощью других вкладок этого окна диалога настройте оси, линии сетки, легенду, подписи данных и режим отображения таблицы данных. Затем щелкните на кнопке Далее, чтобы перейти к четвертому окну мастера (рис. 11.5), определяющему местоположение будущей диаграммы.

  16. Чтобы поместить диаграмму на отдельный лист, выберите положение переключателя в отдельном (As New Sheet).

Рис. 11.5. Выбор расположения диаграммы

Рис. 11.6. Готовая диаграмма на отдельном листе

  17. В текстовое поле имени нового листа введите название Диаграмма.

  18. Щелкните на кнопке Готово (Finish). Результат показан на рис. 11.6.

Примечание

При размещении диаграммы на отдельном листе программа задает ей размер, равный площади окна документа Excel. Если при изменении , размеров окна масштаб диаграммы не меняется, выберите команду Сервис > Параметры и установите флажок Масштабировать диаграмму по размеру окна (Chart Sizes With Window Frame). В противном случае размеры диаграммы будут сохраняться неизменными (если считать в пикселах экрана компьютера).


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 2. Выбор типа диаграммы

Для лучшего отражения той или иной природы данных следует подобрать соответствующий тип диаграммы. Его, так же как и любые другие параметры, заданные при работе с мастером диаграмм, всегда можно сменить позже в процессе форматирования документа.

  1. Чтобы выбрать другой тип диаграммы, выполните команду Диаграмма > Тип диаграммы (Chart > Chart Type). Откроется окно диалога, похожее на первое окно мастера диаграмм.

  2. Если вы не нашли подходящего типа в списке вкладки Стандартные (Standard Types), щелкните на вкладке Нестандартные (Custom Types). Откроется дополнительный список типов диаграмм, показанный на рис. 11.7.

Примечание

Если вы красиво отформатировали диаграмму и хотите записать ее в качестве именованного типа, чтобы пользоваться им в дальнейшем в качестве шаблона для создания других подобных диаграмм, выберите команду Диаграмма > Тип диаграммы и раскройте вкладку Нестандартные, затем выберите положение Дополнительные (User-defined) переключателя Вывести (Select from) и щелкните на кнопке Добавить. Введите в открывшемся окне диалога имя и описание типа, затем щелкните на кнопке ОК. Теперь новый тип, формат которого подобен оформлению текущей диаграммы, будет появляться на вкладке Нестандартные окна диалога Тип диаграммы (Chart Type).

Рис. 11.7. Дополнительные типы диаграмм

  3. В списке Тип выберите пункт Вырезанные сектора (Pie Explosion).

  4. Щелкните на кнопке ОК.

Рис. 11.8. Настройка источника данных

  5. Диаграмма выбранного типа может отображать только один ряд (строку) данных, поэтому давайте сменим источник данных и воспользуемся выбранным типом для представления итоговых данных листа Клиенты. Выберите команду Диаграмма > Исходные данные (Chart > Source Data).

  6. Замените содержимое поля Диапазон на =Клиенты!$А$9:$С$9, что заставит Excel воспользоваться данными ячеек A9:G9 листа Клиенты. (Знак «$» задает абсолютную адресацию ячеек.)

Рис. 11.9. Выбор ячеек с подписями категорий

  7. Чтобы указать программе ячейки с названиями столбцов, раскройте вкладку Ряд, показанную на рис. 11.8.

Рис. 11.10. Диаграмма с вырезанными секторами

  8. Щелкните на кнопке поля Подписи оси Х (Category Labels). Это поле определяет группу ячеек, в которой находятся подписи делений оси Х (категорий).

  9. Щелкните на корешке листа Клиенты.

  10. Выделите группу ячеек Bl:Gl (рис. 11.9), содержащих заголовки столбцов.

  11. В окне диалога щелкните на кнопке, расположенной в правой части поля ввода.

  12. Щелкните па кнопке ОК.

  13. Затем щелкните па корешке листа Диаграмма. Теперь диаграмма будет вы глядеть примерно так, как показано на рис. 11.10. Заметьте, что с помощью довольно несложных действий можно полностью изменить практически все элементы диаграммы.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Форматирование диаграммы

Если лист Excel в основном служит только рабочим полем, а его оформление не играет особой роли, то диаграммы предназначены для облегчения восприятия числовых данных, поэтому на их внешний вид следует обращать особое внимание. Правильное форматирование диаграммы выделяет существенные данные и приглушает менее важные. С помощью искусно построенной диаграммы можно даже завуалировать нежелательную для вас информацию и, акцентировав внимание на достижениях, скрыть результаты мелких просчетов. В упражнениях этого раздела выполняется преобразование диаграммы, созданной в упражнении 1. На ее примере вы научитесь некоторым операциям, которые затем будете применять в повседневной работе. Диаграммы Excel и Microsoft Graph устроены похожим образом, поэтому здесь не рассматриваются приемы форматирования, описанные ранее на занятии 7 па примере диаграммы Microsoft Graph.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 3. Подписи рядов данных

Любая диаграмма состоит из элементов, к которым относятся такие объекты, как область построения диаграммы, оси, координатная сетка, маркеры данных, заголовки. Щелчком мыши можно выделить любой элемент, а щелчком правой кнопки — раскрыть его контекстное меню. Кроме набора стандартных элементов, которые практически всегда присутствуют на диаграмме, Excel позволяет добавлять разные дополнительные компоненты, усиливающие наглядность диаграммы и повышающие ее информативность. К таким вспомогательным элементам относятся подписи рядов данных.

  1. Щелкните правой кнопкой мыши на любом секторе диаграммы и выберите в контекстном меню команду Формат рядов данных (Format Data Series).

  2. Раскройте вкладку Подписи данных (Data Labels), показанную на рис. 11.11. В разделе Включить в подписи (Label contains) можно установить один или несколько флажков, чтобы определить, что именно будет содержаться в подписи:

    • имена рядов (Series Name);
    • имена категорий (Category Name) — название соответствующей отметки оси X;
    • значения (Show Value) — числа источника данных;
    • доли (Show Percentage) —процентная доля данного элемента данных в общем объеме;
    • размеры пузырьков (Show Bubble Sizes) — численное значение диаметра пузырька (доступно только для диаграмм типа Пузырьковые (Bubble)).

Рис. 11.11. Настройка подписей данных

Так как секторные диаграммы не имеют осей, на них автоматически добавляются подписи данных, показывающие соответствие сектора тому или иному столбцу (строке) данных. В рассматриваемом примере подписями данных являются названия категорий Январь, Февраль и т..д.

  3. Чтобы добавить к названиям категорий процентную долю сектора каждого .месяца в общем объеме продаж, установите флажки на пунктах имена категорий и доли.

  4. Сбросьте флажок Линии выноски (Show Leader Lines). Этот флажок выводит линии, связывающие подписи с соответствующими маркерами данных, но в данной ситуации и без них понятно, какому сектору соответствует та или иная надпись, а линии лишь загромождают диаграмму.

  5. Щелкните на кнопке ОК. Теперь рядом с названиями месяцев появятся числа, характеризующие долю, занимаемую соответствующим сектором в целом круге и выраженную в процентах.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 4. Форматирование текста

В верхней части диаграммы присутствует заголовок Итого, но он слишком мелкий и сливается с фоном, так как окрашен в темный цвет. Сам текст заголовка непонятен и скорее запутывает, чем разъясняет смысл диаграммы. Давайте исправим эти недочеты.

  1. Щелкните на слове Итого правой кнопкой мыши и выберите в контекстном меню команду Формат заголовка диаграммы (Format Chart Title).

  2. Раскройте вкладку Шрифт. В списке Размер (Size) выберите число 20, а в раскрывающемся списке Цвет (Color) — белый цвет. Щелкните на кнопке ОК.

Надпись Итого сменит цвет и останется выделенной (то есть будет окружена габаритным прямоугольником с маркерами).

  3. Чтобы перейти в режим редактирования надписи, щелкните на ней. Габаритный прямоугольник исчезнет, а вместо него появится текстовый курсор.

  4. Сотрите старую надпись и введите текст Продажи по месяцам.

  5. Чтобы завершить редактирование текстового элемента, щелкните мышью за его пределами.

Примечание

С помощью операций, описанных в шагах 1-5, можно изменить любую надпись, присутствующую на диаграмме.

  6. Шрифт подписей рядов данных, видимо, тоже не удовлетворит вас. Дважды щелкните на надписи Январь 17%.

  7. На вкладке Шрифт открывшегося окна диалога установите белый цвет и подходящий размер шрифта.

  8. Раскройте вкладку Число (Numbers). С ее помощью можно настроить формат численных значений подписей рядов данных. Здесь доступны те же самые варианты, которые обсуждались на предыдущем занятии при форматировании чисел ячеек листа.

  9. Чтобы вывести долю каждого сектора в виде дроби, выберите в списке Числовые форматы (Category) пункт Дробный (Fraction). В появившемся списке Тип (Type) щелкните на пункте Сотыми долями (As Hundredths). Затем щелкните на кнопке ОК.

Обратите внимание, что при форматировании одной подписи синхронно меняются и другие подписи того же ряда данных. Однако подписи данных можно модифицировать и по отдельности. Давайте выделим курсивом подпись сектора Июнь (поскольку это итоговая величина для полугодия). Чтобы выполнить задуманное, нужно сначала выделить элемент в группе подписей.

  10. Щелкните на тексте Июнь 15/100, чтобы вокруг него появился габаритный прямоугольник с надписями. (При этом предполагается, что группа подписей данных диаграммы уже была выделена. Если это не так, щелчком выделите все подписи, затем немного подождите и повторным щелчком выделите указанный текст.)

  11. Выберите команду Формат > Выделенные подписи данных (Format > Selected Data Labels). На вкладке Шрифт открывшегося окна диалога выберите в списке Начертание (Font Style) пункт Полужирный курсив (Bold Italic). В списке Размер щелкните на числе 22, а в раскрывающейся палитре Цвет выберите желтый квадрат.

Примечание

Если подпись обведена габаритным прямоугольником, то двойной щелчок на ней не приведет к раскрытию окна параметров, а переключит текст в режим редактирования с одновременным выделением того слова, на котором был выполнен щелчок.

  12. Щелкните на кнопке ОК. Выполненное форматирование повлияет только на выбранную подпись.

  13. Переместите указатель на рамку габаритного прямоугольника, нажмите кнопку мыши и перетащите рамку вправо и чуть вверх. Подобным перетаскиванием можно перемещать любые надписи диаграммы.

  14. Чтобы снять выделение подписи, щелкните за пределами габаритного прямоугольника. Теперь диаграмма будет выглядеть примерно так, как показано на рис. 11.12.

Рис. 11.12. Форматирование подписей


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 5. Добавление данных другого листа

Диаграмма Excel может отображать данные сразу нескольких листов. (Именно по этой причине в начале ссылок на источник данных необходимо ставить название листа.) Такая возможность значительно расширяет область применения диаграмм. Например, на одном листе Excel может располагаться таблица расходов со строкой итога, а на другом — аналогичная таблица доходов. Итоговые строки двух таких листов легко выводятся на одну диаграмму. Чтобы добавить в диаграмму предыдущего упражнения данные другого листа, выполните следующие шаги (продолжая работать с листом Диаграмма).

  1. Выберите команду Диаграмма > Добавить данные (Chart > Add Data). Откроется окно диалога Новые данные (Add Data).

  2. Разверните лист Формулы. Обратите внимание, что корешок листа Диаграмма остался светлым, что символизирует смысловую связь выполняемой операции с диаграммой.

  3. Щелкните на ячейке ВЗ .

  4. Нажмите клавишу Shift и, не отпуская ее, щелкните на ячейке G3, чтобы выделить строку ячеек, заголовки столбцов которых соответствуют подписям секторов диаграммы.

  5. Щелкните на кнопке ОК окна диалога Новые данные.

  6. В появившемся окне диалога Специальная вставка (Paste Special) щелкните на кнопке 0К подтвердив выбранные по умолчанию значения параметров. Excel автоматически вернет вас на лист Диаграмма. На первый взгляд кажется, что ничего не изменилось, но это не так. Новые данные не видны, потому что диаграммы секторного типа способны отображать только один ряд данных. Чтобы увидеть добавленные значения, требуется изменить тип диаграммы.

  7. Щелкните правой кнопкой мыши в свободной области диаграммы и выберите в контекстном меню команду Тип диаграммы (Chart Type).

  8. В списке Тип вкладки Стандартные выберите пункт Цилиндрическая (Cylinder).

  9. В разделе Вид щелкните на нижнем левом квадрате (при этом должна появиться подпись Объемный вариант гистограммы со столбцами в виде цилиндров (3-D Column With A Cylindrical Shape)). Затем щелкните на кнопке ОК.

В результате такого преобразования секторы круговой диаграммы превратятся в высокие столбцы. Сзади каждого такого столбца появятся столбцы пониже. Они демонстрируют данные листа Формулы. Заметьте, что диаграмма приобрела третье измерение — глубину. Теперь давайте приведем все элементы обновленной диаграммы к надлежащему виду.

  10. Щелкните правой кнопкой мыши в пустой области диаграммы и выберите в контекстном меню команду Формат области диаграммы (Format Chart Area).

Примечание

Обратите внимание, что при перемещении указателя мыши по окну диаграммы возникает всплывающая подсказка, показывающая, на каком элементе диаграммы в данный момент находится указатель. Это помогает пользователю активизировать нужный элемент диаграммы.

  11. На вкладке В ид открывшегося окна диалога выберите положение Прозрачная (None) переключателя Заливка (Area). Затем щелкните на кнопке ОК. Это приведет к исчезновению темного фона диаграммы, и вы увидите черные линии и подписи осей, появившихся в результате смены типа диаграммы. Заметьте, что объемная диаграмма обладает не двумя, а тремя осями.

  12. Щелчком на крупной надписи Июнь выделите все подписи данных и нажмите клавишу Delete, чтобы удалить их. В новом варианте диаграммы они нам не понадобятся. Аналогичным образом удалите подписи второго ряда данных и заголовок диаграммы.

  13. Дважды щелкните на одной из подписей меток вертикальной оси. С помощью вкладки Шрифт окна диалога Формат оси (Format Axis) настройте размер чисел, чтобы они хорошо смотрелись на экране. Проделайте ту же операцию с подписями горизонтальной оси и оси глубины. В результате диаграмма должна стать примерно такой, как показано на рис. 11.14.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 6. Объемная диаграмма

Тип диаграммы, выбранный в предыдущем упражнении, относится к группе объемных типов, которые имеют третье измерение и отображаются в определенной проекции. Такие диаграммы имеют дополнительный набор параметров, задающих тип и наклон проекции, а также угол перспективы.

  1. Выберите команду Диаграмма > Объемный вид (Chart > 3-D View). Откроется окно диалога, показанное на рис. 11.13.

  2. Щелкните три раза на кнопке со стрелкой вверх, чтобы в поле Возвышение (Elevation) появилось число 40. Этот параметр определяет угол взгляда на диаграмму в вертикальной плоскости, перпендикулярной экрану компьютера.

Рис. 11.13. Параметры объемного вида

Примечание

Объемный вид доступен для тех типов диаграмм, в которых ряды данных выводятся объемными маркерами типа цилиндров или пирамид. Наличие третьей оси координат при этом не обязательно.

  3. Щелкните два раза на кнопке поворота по часовой стрелке или введите в поле Поворот (Rotation) число 30 и нажмите клавишу Tab. Этот параметр задает угол поворота диаграммы вокруг вертикальной оси.

По мере изменения величин в окне диалога в области просмотра будет вращаться схематический образец диаграммы, показывающий ее ориентацию.

  4. Щелкните на кнопке Применить (Apply). Диаграмма повернется в соответствии с выполненными изменениями и станет такой, как показано на рис. 11.14, но окно диалога не закроется. Чтобы изучить новое положеии'е диаграммы, сдвиньте окно диалога в сторону, перетащив его за заголовок. Если новый вариант оформления вам не подходит, скорректируйте углы поворота и вновь щелкните на кнопке Применить.

Рис. 11.14. Диаграмма под новым углом зрения

  5. Добившись нужной ориентации, щелкните на кнопке ОК. Объемные диаграммы можно отображать в двух режимах — в изометрии и перспективе.

Рис. 11.15. Диаграмма в режиме перспективы

  6. Чтобы перейти в режим перспективы, сбросьте флажок Изометрия (Right Angle Axes). В окне диалога Формат трехмерной проекции (3-D View) появятся еще одно поле и две кнопки.

  7. Введите в поле Перспектива (Perspective) число 60 и щелкните на кнопке ОК. Перспектива существенно исказит параллельность линий диаграммы (рис. 11.15).


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 7. Ряды данных

Ряды данных — это столбцы, линейки, точки, пузырьки или другие маркеры, отображающие численные значения ячеек таблицы. Каждой строке или столбцу источника данных соответствует отдельный ряд данных, маркеры которого имеют одинаковый цвет. В зависимости от типа диаграммы вы можете менять цвет, форму и другие параметры рядов данных. Давайте модифицируем форму маркеров, относящихся к данным листа Формулы, и немного раздвинем ряды данных.

  1. Дважды щелкните на/маркере дальнего ряда данных.

  2. На вкладке фигура (Shape) открывшегося окна диалога (рис. 11.16) выберите третий вариант формы.

  3. Разверните вкладку Параметры (Options). .

  4. Увеличьте до 300 число в счетчике Глубина диаграммы (Chart Depth), чтобы раздвинуть ряды данных.

  5. Введите в счетчик Глубина зазора (Gap Depth) число 500, чтобы скорректировать форму цилиндров, сечение которых после предыдущего шага стало овальным.

В данном варианте расположения маркеров данных передние, более высокие столбцы заслоняют задние, более низкие. Это мешает восприятию информации. Следует переставить местами ряды данных.

  6. Раскройте вкладку Порядок рядов (Series Order).

  7. В одноименном списке щелкните на пункте Итого, а затем на кнопке Вниз (Move Down), чтобы переместить выделенный ряд данных ниже ряда S2.

Рис. 11.16. Выбор формы маркеров данных

Рис. 11.17. Изменение названий рядов данных

  8. Щелкните на кнопке ОК.

Остается исправить подписи третьей оси координат. Эта ось появилась в результате выбора типа диаграммы. Подпись Итого соответствует названию строки данных листа Клиенты. Подпись второго ряда данных была сгенерирована автоматически, так как выделенные ячейки данных листа Формулы не содержали названия строки. Для модификации элементов осей требуется изменить источник данных.

Рис. 11.18. Результат форматирования диаграммы

  9. Выберите команду Диаграмма > Исходные данные.

  10. В открывшемся окне диалога раскройте вкладку Ряд, показанную на рис. 11.17.

  11. В списке Ряд (Series) щелкните на пункте Итого.

  12. Протащите мыть в поле Имя (Name), чтобы выделить его содержимое.

  13. Замените формулу Клиенты!$А$9 этого поля текстом Продажи по месяцам.

  14. Щелкните на пункте Ряд2 (SeriesZ) списка Ряд.

  15. Введите в поле Имя текст Диалог, соответствующий названию строки данных листа Формулы, и щелкните на кнопке ОК. Окончательный вид диаграммы показан на рис. 11.18.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Контрольное упражнение

Чтобы попрактиковаться в работе с диаграммами, постройте еще одну, воспользовавшись данными файла Электронная таблица.xls.

  1. Раскройте вкладку Клиенты.

  2. Выполните команду Вставка > Диаграмма.

  3. Выберите диаграмму типа Лепестковая (Radar).

  4. В качестве источника данных укажите диапазон ячеек B3:G7.

    • Как задать заголовки рядов данных?

  5. На вкладке Заголовки (Titles) третьего окна мастера введите название диа граммы.

  6. С помощью вкладки Легенда (Legend) расположите легенду слева от диа граммы.

  7. Поместите диаграмму на лист Клиенты в качестве нового объекта.

  8. Масштабируйте диаграмму, максимально увеличив ее размеры в пределах объекта.

    • Как изменить размеры диаграммы?

  9. Смените цвет фона диаграммы на светло-зеленый.

  10. Выберите команду Диаграмма > Исходные данные.

  11. На вкладке Ряд щелкните в поле Подписи оси Х (Category (X) Axis Labels) и вы берите на листе Клиенты диапазон ячеек B1:G1.

  12. Отформатируйте шрифт текста легенды и подписи осей так, чтобы они хо рошо читались.

  13. Запишите полученную диаграмму в качестве одной из диаграмм пользова тельского типа.

    • Как внести диаграмму в список пользовательских типов?

  14. Закройте файл без сохранения выполненных изменений.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Подведение итогов

Теперь вы умеете не только вводить данные в таблицы Excel и выполнять необходимые расчеты, но и отображать результаты вычислений в виде диаграмм. На занятии были рассмотрены: мастер диаграмм, способы задания источника данных, приемы форматирования текста и рядов данных. Вы познакомились с методикой смены типа диаграммы и приемами настройки объемных диаграмм.

Чтобы завершить изучение Excel, перейдите к следующему занятию, на котором рассматриваются способы печати листов с данными и диаграммами.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Занятие №4

Подготовка листов Excel к печати

ТЕМА ЗАНЯТИЯ

Вы уже умеете размещать в ячейках Excel числовые данные, выполнять расчеты и оформлять результаты в виде диаграмм. Осталось научиться распечатывать полученные документы. На занятии рассматриваются следующие операции, помогающие подготовить листы Excel к печати:

  • ориентация страницы;

  • настройка полей;

  • добавление колонтитулов;

  • сортировка данных;

  • фильтрация;

  • отображение заголовков строк и столбцов на всех страницах;

  • скрытие ячеек и листов;

  • разбиение на страницы.

Чтобы быстро распечатать лист Excel, достаточно щелкнуть на кнопке Печать (Print) панели инструментов Стандартная. Однако результат этой операции, скорее всего, не удовлетворит вас. Он хорош для вывода черновиков, но совершенно не подходит для печати чистовых документов, которые должны быть хорошо оформлены и не терпят присутствия излишней информации. Поэтому перед окончательной печатью листов Excel нужно настроить масштаб и поля страниц, отсортировать данные таблиц, выделить диапазон печатаемых ячеек, указать способ расположения таблиц и диаграмм и выполнить некоторые другие операции.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Компоновка страниц

В целом настройка параметров печати в Excel похожа на аналогичную операцию в Word. Но листы Excel имеют свою специфику. Удобно, чтобы табличные данные листа помещались на одной странице, поэтому требуется настройка масштаба печати. Широкие листы принято выводить в альбомной ориентации, а длинные таблицы — в портретной. Если в Word параметры страницы, как правило, назначаются сразу всему документу, то в Excel они настраиваются отдельно для каждого листа.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 1. Ориентация и масштаб страницы

Давайте продолжим работу с файлом Электронная таблица.х1s и распечатаем некоторые из ее листов. В этом упражнении выполняется первый этап подготовки к печати — настройка ориентации страницы и масштаба выводимого листа.

  1. Откройте файл Электронная таблица.xls.

  2. Разверните лист Формулы, щелкнув на его корешке.

В таблице этого листа есть столбцы только для первых шести месяцев. Давайте расширим таблицу так, чтобы в ней разместились данные для всех 12 месяцев года. Это позволит научиться печатать широкие таблицы, не помещающиеся на лист целиком.

  3. Выделите ячейки B1:G14 и нажатием клавиш Ctrl+C скопируйте их в буфер обмена.

  4. Выберите команду Вставка > Скопированные ячейки (Insert > Copied Cells), чтобы дублировать ячейки, выделенные на шаге 3.

  5. В открывшемся окне диалога выберите положение переключателя Диапазон со сдвигом вправо (Shift Cells Right), а затем щелкните на кнопке ОК. Ячейки, выделенные на шаге 3, будут дублированы с добавлением новых столбцов.

  6. Теперь следует скорректировать заголовки столбцов. Для этого щелкните на ячейке В1 и протащите маркер нижнего левого угла рамки вправо, чтобы рамка охватила диапазон В1:М1. Excel автоматически сгенерирует последовательность названий месяцев.

  7. В столбце G остались пустые ячейки. Чтобы заполнить их соответствующими формулами расчета прироста продаж, выделите группу F10:Fl4, скопируйте ее, щелкните на ячейке G10 правой кнопкой мыши и выберите команду Вставить. Тенерь лист будет выглядеть так, как показано на рис. 12.1.

Рис. 12.1. Обновленный лист Формулы

  8. Выберите команду Файл > Параметры страницы (File > Print Setup).

  9. Разверните в открывшемся окне диалога вкладку Страница (Page), показанную на рис. 12.2.

Рис. 12.2. Настройка ориентации страницы и масштаба

Рис. 12.3. Таблица в масштабе 100 %

  10. Выберите положение переключателя альбомная (Landscape).

  11. Чтобы увидеть предполагаемое размещение чисел на странице, щелкните на кнопке Просмотр (Print Preview). Если выбран стандартный размер бумаги 4юрмата А4, то окажется, что на страницу не влезают все столбцы (рис. 12.3).

  12. Нажмите клавишу Page Down и вы увидите, что ячейки крайнего правого столбца перенесены на вторую страницу. Это неудобно. Следует изменить масштаб, чтобы все столбцы таблицы по ширине вписывались в одну страницу.

Примечание

В полученной таблице данные столбцов H-L повторяют числа столбцов B-G. Если хотите, измените величины в некоторых ячейках. В упражнениях этого занятия конкретные числовые значения ячеек несущественны.

  13. Щелкните на кнопке Страница (Setup) панели инструментов, чтобы вернуться в окно диалога Параметры страницы (Page Setup).

Раздел Масштаб (Scaling) этого окна диалога позволяет уменьшать или увеличивать печатаемые объекты. С помощью счетчика установить (Adjust To) можно выбрать любой масштаб, рассчитываемый в процентах от исходного размера страницы. (Не забудьте при этом выбрать соответствующее положение переключателя.) Можно поступить и по-другому. Excel умеет сам подгонять размер таблицы под площадь страницы.

Примечание

Счетчики, расположенные в строке Разместить..., позволяют указать инструменту автоматического масштабирования, какое число страниц должна занимать таблица по ширине и высоте.

  14. Выберите положение переключателя Разместить... (Fit To) и оставьте в обоих счетчиках, соответствующих этому положению, числа 1.

  15. Щелкните на кнопке ОК. Теперь вся таблица помещается на одну страницу. Если вы снова щелкнете на кнопке Страница, то увидите в счетчике установить величину 96%. Это тот масштаб, который был выбран программой Excel для печати листа Формулы. При необходимости можете скорректировать его.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 2. Настройка полей

Поля формируют пустую рамку вокруг информативной области страницы. Уменьшая их, можно немного увеличить размер печатаемой таблицы.

  1. Снова щелкните на кнопке Страница.

  2. В окне диалога Параметры страницы раскройте вкладку Поля (Margins), показанную на рис. 12.4.

Рис. 12.4. Настройка полей

  3. Уменьшите значение счетчика левое (Left) до 1 см.

  4. Точно так же, до 1 см, уменьшите значение счетчика правое (Right).

  5. Таблица листа Формулы невелика по высоте. Давайте напечатаем ее посередине страницы. Для этого установите флажок вертикально (Vertically).

  6. Щелкните на кнопке ОК.

Ширина области печати увеличилась. Если снова посмотреть на вкладку Страница окна диалога Параметры страницы, то можно заметить, что режим автоматической настройки размеров сразу же увеличил масштаб, подогнав таблицу под новый размер области печати.

  7. Щелчком на кнопке Закрыть (Close) выйдите из режима предварительного просмотра.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 3. Добавление колонтитулов

Колонтитулы позволяют добавлять в нижнюю и верхнюю часть страниц заголовки и описания, дублирующиеся на всех страницах. Если таблица длинная, в колонтитуле удобно разместить ее название, номера страниц, название файла документа и листа, на котором размещена таблица.

  1. Выберите команду Вид > Колонтитулы (View > Header And Footer). Откроется вкладка Колонтитулы (Header/Footer) окна диалога Параметры страницы, показанная на рис. 12.5. В раскрывающихся списках Верхний колонтитул (Header) и Нижний колонтитул (Footer) можно выбрать один из стандартных вариантов оформления колонтитулов.

Рис. 12.5. Настройка колонтитулов

  2. Раскройте список Верхний колонтитул и выберите пункт Формулы; Страница 1 (Формулы; Page 1). Этот вариант добавляет в верхнюю часть каждой страницы название листа с исходными данными и порядковый номер страницы. В верхней части вкладки Колонтитулы появится пример оформления верхнего колонтитула.

Примечание

Если нужно, чтобы нумерация страниц начиналась не с единицы, введите номер для первой страницы в поле Номер первой страницы (First Page Number) вкладки Страница того же окна диалога.

Если стандартные схемы компоновки колонтитулов вас не устраивают, воспользуйтесь кнопками, расположенными в средней части окна диалога.

  3. Чтобы настроить нижний колонтитул, щелкните на кнопке Создать нижний колонтитул (Custom Footer). Открывшееся окно диалога (рис. 12.6) имеет три списка и несколько кнопок. С помощью этих кнопок можно размещать различные объекты в списках, задающих содержимое левого края колонтитула, его центральной части и правого края.

  4. Щелкните в списке Слева (Left Section).

Рис. 12.6. форматирование колонтитула

  5. Щелкните в центральной части окна на четвертой справа кнопке. В списке появится ссылка &[Файл] (&[File]), генерирующая названия файла документа.

  6. Введите перед ней текст Имя файла:.

  7. Щелкните в списке Справа (Right Section) и введите текст Время создания :.

  8. Щелкните на кнопке с календарем, поместив в колонтитул ссылку на дату &[Дата] (&[Date]).

  9. Нажмите клавишу Пробел и щелкните на кнопке с циферблатом часов, кото рая добавляет ссылку на время печати документа &[Время] (&[Time]).

  10. Закройте окно диалога щелчком на кнопке ОК.

Примечание

Высота нижнего и верхнего колонтитулов настраивается на вкладке Поля окна диалога Параметры страницы.

Теперь в нижний колонтитул будет выводиться имя файла таблицы, а также дата и время печати файла с соответствующими подписями. Если вы хотите увидеть страницу с добавленными колонтитулами, выберите команду Файл > Предварительный просмотр (File > Print Preview).


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Сортировка и фильтрация

Сортировка позволяет упорядочить строки таблицы в порядке возрастания или убывания данных одного или нескольких столбцов таблицы. Фильтрация дает возможность временно убрать из таблицы ненужные строки, не стирая их.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 4. Сортировка данных

Сортировать данные приходится не только при печати документа. Размещение строк таблицы в порядке возрастания одного из параметров помогает искать нужные записи. Печать чистового варианта документа — подходящий момент для того, чтобы упорядочить данные, если они вводились в спешке и оказались расположенными не должным образом. Давайте рассортируем клиентов в верхней таблице листа в порядке увеличения продаж в апреле месяце.

  1. Щелкните на любой ячейке столбца Апрель верхней таблицы.

  2. Щелкните на кнопке Сортировка по возрастанию (Sort Ascending) панели инструментов Стандартная. Расстановка строк поменяется так, что числа в столбце Апрель будут увеличиваться сверху вниз (рис. 12.7).

Рис. 12.7. Таблица упорядочена по возрастанию продаж в апреле

Сравните заголовки строк верхней таблицы с заголовками нижней и вы увидите, что переставлены строки целиком, а не только ячейки столбца Апрель. (Раньше порядок заголовков в двух таблицах совпадал.) Для сортировки таблицы по убыванию следует щелкнуть на кнопке Сортировка по убыванию (Sort Descending).

Объемы продаж клиентам РИФ и Викинг в апреле совпадают (они равны 11000). Если таких совпадающих значений много, приходится дополнительно упорядочивать таблицу по второму признаку. Например, алфавитный список покупателей следует упорядочить сначала по столбцу с фамилиями, а затем по столбцу с именами, чтобы информация о людях с одинаковыми фамилиями располагалась по ал4)авиту имен. Чтобы дополнительно упорядочить таблицу по возрастанию, продаж в мае (при условии равенства продаж в апреле), выполните следующие действия.

  3. Выберите команду Данные > Сортировка (Data > Sort). Откроется окно диалога, показанное на рис. 12.8. В разделе Сортировать по (Sort By) уже введено условие сортировки по возрастанию значений столбца Апрель, которое было назначено на шаге 2.

Рис. 12.8. Настройка условия сортировки

  4. В раскрывающемся списке Затем по (Then By) выберите столбец Май.

  5. Оставьте выбранным положение переключателя по возрастанию (Ascending).

  6. Щелкните на кнопке ОК. Теперь строки клиентов Викинг и РИФ поменяются местами, поскольку числа 4000 и 12000 располагаются по возрастанию.

Примечание

Обратите внимание, что при сортировке номера строк не меняются, то есть перемещаются сами данные. Поэтому выполненную операцию сортировки нельзя отключить. Для возврата прежнего расположения строк можно лишь воспользоваться стандартной командой отмены операции. После сохранения файла вернуть прежний порядок строк невозможно.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 5. Фильтрация

При печати больших таблиц бывает удобно урезать их путем фильтрации интересующих вас строк. Предположим, что вам понадобилась информация только по трем клиентам, которые в мае имели максимальные объемы сделок. Чтобы выбрать соответствующие строки с помощью автофильтра, выполните следующие шаги.

  1. Щелкните в любой ячейке верхней таблицы листа Формулы.

  2. Выберите команду Данные > Фильтр > Автофильтр (Data > Filter > AutoFilter). В ячейках первой строки таблицы появятся кнопки раскрывающихся списков, обеспечивающих фильтрацию по любому из столбцов (рис. 12.9).

  3. Щелкните на кнопке со стрелкой в ячейке F1 столбца Май.

  4. Выберите в раскрывшемся списке пункт Первые 10... (Top 10...). Откроется окно диалога настройки условия фильтрации, показанное на рис. 12.10.

Фильтры типа Первые 10... позволяют выделить несколько строк с максимальными или минимальными значениями в одном из столбцов таблицы. Левый список окна диалога автофильтра позволяет указать, нужно ли фильтровать максимальные или минимальные значения параметра. Правый список задает единицы измерения (строки таблицы или процент от общего числа строк) для счетчика, расположенного посередине, который задает количество или процентную долю оставляемые строк таблицы.

Рис. 12.9 . Список автофильтра

  5. Введите в счетчик окна диалога автофильтра число 3.

  6. Щелкните на кнопке ОК.

В верхней таблице листа останутся только три строки, имеющие максимальные числа в столбце Май. Обратите внимание, что исчезнувшие строки 2 и 5 не пропали. Они просто скрыты с экрана, о чем говорит отсутствие номеров этих строк. Excel позволяет фильтровать данные сразу по нескольким столбцам. Давайте выделим тех клиентов, которые входили в тройку ведущих по объему сделок как в мае, так и в июне.

  7. Щелкните на стрелке раскрывающегося списка ячейки G1 и выберите пункт Первые 10....

  8. Введите в счетчик открывшегося окна диалога число 3 и щелкните на кнопке ОК. Теперь в таблице останутся только два клиента — Диалог и РИФ.

Рис. 12.10. Окно диалога автофильтра

Примечание

Для отмены фильтрации только по одному из столбцов раскройте список в его первой ячейке и выберите пункт Все (АН). Пункт Условие... (Custom...) этого же списка позволяет настраивать более сложные условия фильтрации. Другие пункты списка оставляют в таблице только те строки, в которых ячейка данного столбца содержит величину, выбранную в этом списке автофильтра.

Стрелки тех списков автофильтра, в которых назначена фильтрация, выделяются синим цветом, чтобы пользователь не забыл о назначенных условиях отображения строк.

  9. Чтобы отменить фильтрацию, выберите команду Данные > Фильтр > Отобразить все (Data > Filter > Show All). На лист вернутся все пять исходных строк таблицы.

  10. Чтобы отключить автофильтр, повторно выберите команду Данные > Фильтрация > Автофильтр (Data > Filter > AutoFilter).


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Выбор печатаемых объектов

Кроме фильтров есть и другие способы уменьшить печатаемую область. Непосредственно перед печатью листа можно настроить режим печати заголовков столбцов, скрыть ненужные строки и столбцы, задать диапазон печатаемых ячеек и указать способ разбиения листа Excel на страницы.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 6. Разбиение на страницы

При печати больших листов программа сама разбивает их на страницы. Однако такое автоматическое деление может вам не подойти. Лист Формулы фактически содержит две отдельные таблицы, которые при печати располагаются на одной странице. Давайте вставим линию разделения страниц, чтобы эти таблицы печатались на двух отдельных листах бумаги.

  1. Выберите команду Вид > Разметка страницы (View > Page Break Preview). Excel переключится в другой режим просмотра, в котором синие линии показывают границы страниц.

  2. Чтобы иметь возможность ручной настройки страниц, следует отключить режим автоматического масштабирования таблицы. Для этого выберите команду Файл > Параметры страницы и на вкладке Страница открывшегося окна диалога выберите положение переключателя Установить. Затем щелкните на кнопке ОК.

  3. Щелкните на ячейке D7.

  4. Выберите команду Вставка > Разрыв страницы (Insert > Page Break). На листе появятся две новые линии деления на страницы. Одна слева от выделенной ячейки, а вторая — сверху. Теперь лист будет печататься на четырех страницах.

Рис. 12.11. Режим разметки страницы

  5. Чтобы просмотреть полученный вариант деления на страницы, щелкните на кнопке Предварительный просмотр (Print Preview) панели инструментов Стандартная. Затем для перехода по страницам пользуйтесь клавишами Page Up и Page Down.

  6. Щелчком на кнопке Закрыть вернитесь в режим разметки страницы.

В наши планы не входило деление на четыре страницы. Вертикальная синяя линия лишняя, ее нужно убрать.

  7. Поместите указатель на границу столбцов С и D, чтобы его значок превратился в двунаправленную стрелку."

  8. Нажмите кнопку мыши и перетащите линию раздела страниц влево за пределы листа. Подобным перетаскиванием границ можно не только убирать линии раздела, но и перемещать их по листу Excel, изменяя конфигурацию страниц.

Теперь лист разделен на две страницы по горизонтали, как показано на рис. 12.11. Чтобы оценить полученный вариант разбиения листа, снова воспользуйтесь режимом предварительного просмотра.

Примечание

Чтобы убрать все установленные разрывы страниц, щелкните в Пределах листа правой кнопкой мыши и выберите в контекстном меню команду Сброс разрывов страниц (Reset All Page Breaks).

  9. С помощью команды Вид > Обычный (View > Normal) вернитесь в обычный режим.

Обратите внимание, что теперь в листе появились пунктирные линии между парами строк 6—7 и 14—15. Эти линии соответствуют настроенным границам страниц.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение7. Скрытие строк и столбцов

Скрывать определенные ячейки можно не только с помощью фильтрации. Программа позволяет вручную указывать те столбцы и строки, которые временно нужно сделать невидимыми. Столбцы N и 0 листа Формулы содержат не слишком важную информацию, их не нужно печатать. Скрыв их, вы сможете немного увеличить масштаб печати. Необходимый результат достигается с помощью следующих операций.

  1. Протащите указатель мыши по кнопкам столбцов N и 0, чтобы выделить эти столбцы.

  2. Выберите команду Формат > Столбец > Скрыть (Format > Column > Hide).

Выделенные столбцы временно исчезнут. Подобным способом можно скрыть и ненужные строки.

Примечание

Чтобы вернуть скрытые столбцы или строки, выполните соответственно команды Формат > Столбец > Отобразить (Format > Column > Unhide) или Формат ^ Строка > Отобразить (Format » Row > Unhide).

  3. Щелчком на кнопке Предварительный просмотр (Preview) панели инструментов выведите на экран предполагаемый вид первой страницы.

  4. Щелкните на кнопке Страница. Затем па вкладке Страница открывшегося окна диалога подберите значение счетчика Установить так, чтобы по ширине столбцы листа занимали все пространство страницы. По всей видимости подходящим будет значение 115%.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 8. Заголовки строк и столбцов

При печати листа на нескольких страницах заголовки столбцов или строк видны не на каждой из них. В нашем примере на второй странице нет названий месяцев. В такой ситуации полезно дублировать заголовки. Для этого выполните следующие шаги.

  1. Выберите команду Файл > Параметры страницы.

  2. Разверните вкладку Лист (Sheet).

  3. Щелкните на кнопке в правой части поля сквозные строки (Rows To Repeat At Top), чтобы свернуть окно диалога и открыть доступ к ячейкам листа.

  4. Щелчком на кнопке первой строки листа выделите ее.

  5. Повторно щелкните на кнопке окна диалога, чтобы развернуть его до прежних размеров (рис. 12.12).

Рис. 12.12. Настройка автоповтора заголовков

Поле сквозные столбцы (Columns To Repeat At Left) вкладки Лист того же окна диалога дает возможность указать столбцы заголовков, которые должны повторяться в левой части каждой страницы. Флажки раздела Печать (Print) этой вкладки добавляют линии раздела ячеек, нумерацию ячеек, включают режимы черно-белой и черновой печати. В разделе Последовательность вывода страниц (Page Order) можно указать способ сортировки страниц при печати многостраничных таблиц.

  6. Щелкните на кнопке ОК. Теперь названия месяцев будут выводиться на обеих страницах.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 9. Задание диапазона ячеек

Чтобы распечатать только часть таблицы, не обязательно фильтровать ее или скрывать строки и столбцы. Можно просто указать диапазон тех ячеек, которые должны быть напечатаны. Обратите внимание, что на втором листе между заголовками столбцов и числами таблицы имеется большой пропуск. Давайте устраним его, исключив из диапазона печати пустые строки 7—9.

  1. Выделите строки с 1 по 6.

  2. Нажмите клавишу Ctrl и протащите указатель по кнопкам строк 10—14, чтобы добавить их к имеющемуся выделению, как показано на рис. 12.13.

  3. Выберите команду Файл > Область печати > Задать (File > Print Area >Set Print Area). Теперь будут печататься только выделенные строки. Проверьте это в режиме предварительного просмотра.

Рис. 12.13. Задание диапазона печати

Примечание

Если после выполнения шага 3 вы раскроете вкладку Лист окна диалога Параметры страницы, то увидите в поле Выводить на печать диапазон (Print Area) ссылку 1:6;10:14, которая соответствует строкам, выделенным на шагах 1 и 2. То есть диапазон печати можно задавать и с помощью этого поля окна диалога Параметры страницы. Для сброса установленного диапазона печати достаточно выбрать команду Файл > Область печати > Убрать (File > Print Area > Clear Print Area).

Выполненные операции завершают настройку параметров печати листа Формулы. Но кроме таблицы нужно распечатать диаграмму, представляющую данные в графической форме. В следующем упражнении вы настроите параметры листа Диаграмма и распечатаете ее вместе с таблицей исходных данных.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 10. Настройка диаграмм

Листы, целиком занятые диаграммами, имеют те же параметры печати, что и стандартные. Однако вкладка Лист окна диалога Параметры страницы для этих листов заменена вкладкой Диаграмма (Chart).

  1. Щелкните на корешке листа Диаграмма.

  2. Выберите команду Файл > Параметры страницы.

  3. Раскройте вкладку Диаграмма, показанную на рис. 12.14.

Рис. 12.14. Параметры печати диаграммы

  4. Чтобы диаграмма занимала весь лист целиком, выберите положение переключателя уместить на странице (Scale To Fit Page).

Примечание

Если диаграмма будет распечатываться на черно-белом принтере, установите флажок черно-белая (Print in black and white).

  5. Щелкните на кнопке ОК.

Осталось только вывести листы на принтер. Для этого выполните следующие действия.

  6. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на корешке листа Формулы. Активным останется лист Диаграмма, но корешок Формулы станет белым, что указывает на выделенный статус листа. Теперь с помощью одной операции печати можно распечатать сразу два листа.

  7. Выберите команду Файл > Печать (File > Print) или щелкните в режиме предварительного просмотра на кнопке Печать (Print) панели инструментов. Откроется окно диалога, показанное на рис. 12.15. Оно предлагает дополнительные способы задания диапазона печати.

Примечание

Чтобы выделить несколько смежных листов, щелкните на корешке первого из них, нажмите клавишу Shift и, не отпуская ее, щелкните на корешке последнего листа выделяемой группы.

Рис. 12.15. Печать листов

  8. Убедитесь, что в разделе Печатать (Print Range) выбрано положение переключателя все (All).

  9. Если вы хотите напечатать только некоторые страницы, выберите положение переключателя страницы (Page(s)) и введите необходимые номера в счетчики с (From) и по (То).

  10. Выберите положение выделенные листы (Active Sheets) переключателя Вывести на печать (Print What).

Положение всю книгу (Entire Workbook) этого переключателя обеспечивает печать всех листов, а выделенный диапазон (Selection) — только выделенных ячеек.

  11. В счетчик Число копий (Number Of Copies) введите требуемое число копий.

  12. В раскрывающемся списке Имя (Name) выберите нужный принтер.

  13. Щелкните на кнопке ОК.

Примечание

Чтобы быстро распечатать одну копию выделенных листов на стандартном принтере, достаточно щелкнуть на кнопке Печать (Print) панели инструментов Стандартная.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Контрольное упражнение

Если, изучая упражнения этого занятия, вы были достаточно внимательны, то без труда сможете выполнить проверочное задание.

  1. Откройте файл Электронная таблица,xls.

  2. Разверните лист Расходы.

  3. Задайте книжную ориентацию страницы.

  4. Установите поля сверху и снизу по 5 см, а справа и слева по 3 см.

  5. Отведите 2 см под верхний колонтитул и 3 см под нижний.

    • Как установить высоту верхнего колонтитула 2 см, а нижнего — 3 см?

  6. В верхний колонтитул добавьте название файла, название листа и номер страницы.

  7. Настройте параметры листа так, чтобы нумерация страниц начиналась с 20.

    • Где устанавливается номер первой страницы?

  8. В нижний колонтитул вставьте дату и время печати документа.

  9. Рассортируйте строки по убыванию чисел в столбце А.

  10. Скройте столбцы Б и F, являющиеся дубликатами столбцов В и С.

    • Как распечатать лист без столбцов Е и F, не скрывая их?

  11. Задайте такое разбиение на страницы, чтобы на первой из них печатались данные с января по апрель, а на второй — оставшиеся столбцы.

  12. Задайте режим повторения заголовков строк на всех страницах.

  13. Скройте строку 1, так как теперь введенный в ней заголовок делится между двумя страницами.

  14. Добавьте в верхний колонтитул текст заголовка таблицы, скрытого на предыдущем шаге.

  15. Проверьте правильность форматирования страниц в режиме предварительного просмотра.

  16. Настройте параметры печати листа Календарь по своему усмотрению.

  17. Выделите листы Расходы и Календарь.

  18. Распечатайте оба листа в двух экземплярах.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Подведение итогов

В упражнениях этого занятия были рассмотрены вопросы выбора диапазона печатаемых ячеек, настройки параметров страницы и формирования схемы разбиения листа Excel на страницы. Вы научились фильтровать и сортировать строки, скрывать ячейки, дублировать заголовки таблиц. Наконец, вы теперь умеете под- ' гонять размеры выводимой области под формат страницы, печатать одновремен- ' но несколько листов в нескольких экземплярах.

Самым полным справочником по всем возможностям, предоставляемым программой Excel 2000, является книга Б. Карпова «Microsoft Excel 2002: справочник» («Питер», 2001).

Это занятие завершает серию упражнений, посвященных описанию второго приложения комплекта Microsoft Office XP. Три следующих занятия описывают программу PowerPoint, предназначенную для организации презентаций.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Занятие №1

Excel

Microsoft Excel XP — программа, обладающая эффективными средствами обработки числовой информации, представленной в виде электронных таблиц. Она позволяет выполнять математические, финансовые и статистические вычисления, оформлять отчеты, построенные на базе таблиц, выводить числовую информацию в виде графиков и диаграмм.

Электронная таблица

ТЕМА ЗАНЯТИЯ

На этом занятии вы познакомитесь со структурой электронных таблиц Excel и научитесь выполнять следующие операции:

  • вводить данные;

  • копировать и перемещать листы Excel;

  • выделять ячейки таблицы;

  • форматировать текст;

  • настраивать ячейки;

  • форматировать числа;

  • добавлять строки и столбцы.

Электронные таблицы предназначены для ввода и обработки табличных данных. С помощью Excel можно выполнять сложные вычисления с большими массивами чисел, строить диаграммы и печатать финансовые отчеты.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Понятие электронной таблицы

Документ приложения Excel называется рабочей книгой (workbook) или просто книгой Excel. Такая книга состоит из листов (worksheet), которые представляют собой большие таблицы ячеек с числами и текстовой информацией. Таблицы Excel похожи на базы данных, но предназначены не столько для хранения информации, сколько для проведения математических и статистических расчетов.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 1. Книга Excel

Давайте создадим пустую книгу Excel, введем в нее числа и формулы и поучимся манипулировать с ее листами.

  1. Запустите Excel с помощью команды Пуск > Программы > Microsoft Excel (Start > Programs > Microsoft Excel). В окне Excel сразу откроется новая рабочая книга с тремя листами.

Рис. 9.1. Лист Excel

  2. Щелкните в ячейке А1 первого листа и введите текст Клиенты.

  3. Нажмите клавишу Enter и введите текст Январь.

  4. Перемещаясь по ячейкам с помощью клавиш со стрелками, клавиш Enter и Tab или с помощью мыши, сформируйте таблицу, показанную на рис. 9.1.

  5. Щелкните на ячейке А9 и введите слово Итого.

  6. Нажмите клавишу Tab и введите =СУММ(ВЗ : В7) (=SUM(B3 : В7)). Эта форму ла автоматически подсчитывает сумму ячеек столбца Январь.

  7. Снова нажмите клавишу Tab и введите 4юрмулу=СУММ(СЗ:С7) (=SUM(C3 :С7)).

  8. Добавьте подобные формулы во все ячейки строки 9, указывая в скобках букву текущего столбца. Теперь Excel автоматически суммирует числа в столбцах и выводит результат в строку 9, как показано на рис. 9.2.

Рис. 9.2. Таблица с формулами

  9. Щелкните на ячейке D9. Обратите внимание, что в выделенной ячейке с формулой выводится результат расчета, а сама формула видна в строке формулы в верхней части окна Excel. Попробуйте щелкнуть на любой ячейке верхних пяти строк таблицы и изменить находящееся в ней число. Excel автоматически скорректирует сумму столбца в строке Итого. Таким образом, вам теперь не нужно по несколько раз пересчитывать суммы столбцов на калькуляторе. Excel мгновенно реагирует на любые изменения таблицы, и вы всегда знаете точные итоговые значения. Конечно, Excel умеет выполнять над содержимым ячеек таблицы и более сложные математические операции. По умолчанию книга Excel имеет три листа со стандартными именами. Трех листов может не хватить для всех данных, а стандартные названия листов никак не раскрывают их назначение. Давайте научимся добавлять листы и назначать им более понятные имена.

Примечание

Если значение в ячейке с формулой не обновляется автоматически, выберите команду Сервис > Параметры (Tools > Options), раскройте вкладку Вычисления (Calculation) и выберите положение переключателя Автоматически (Automatic). Затем щелкните на кнопке ОК.

Примечание

Чтобы по умолчанию в книге появлялось другое количество листов, выберите команду Сервис > Параметры, раскройте вкладку Общие (General) и измените величину в счетчике Листов в новой книге (Sheets In New Workbook).

  10. Щелкните правой кнопкой мыши на корешке Лист1.

  11. Выберите в контекстном меню команду Переименовать (Rename).

  12. Введите новое имя Клиенты.

  13. Дважды щелкните на корешке Лист2 и введите имя Расходы.

  14. Щелкните на корешке Расходы правой кнопкой мыши и выберите в контек стном меню команду Переместить/скопировать (Move Or Copy).

  15. В открывшемся окне диалога (рис. 9.3) установите флажок Создавать копию (Create A Copy), чтобы выбранный лист копировался, а не перемещался.

Рис.9.3. Копирование листа

  16. В списке Перед листом (Before Sheet) щелкните на пункте переместить в конец (Move To End), чтобы скопировать первый лист в конец книги.

  17. Затем щелкните на кнопке ОК.

Примечание

Чтобы скопировать выбранный лист в новую рабочую книгу с одним листом, выберите в раскрывающемся списке В книгу (То Book) пункт Новая книга (New Book).

  18. Чтобы добавить еще один пустой лист, щелкните правой кнопкой мыши на корешке Расходы и выберите команду Добавить (Insert).

  19. На вкладке Общие (General) открывшегося окна диалога Вставка (Insert) щелкните на значке Лист (Worksheet). Затем щелкните на кнопке ОК. В рабочей книге появится пятый лист.

  20. Выберите команду Файл > Сохранить (File > Save).

  21. В появившемся окне диалога сохранения документа щелкните на кнопке Мои документы (My Documents).

  22. В поле Имя файла (File Name) введите название Электронная таблица. Затем щелкните на кнопке ОК, чтобы сохранить созданную книгу Excel. Обратите внимание, что документы Excel имеют расширение xls.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 2. Ввод данных

Электронные таблицы обрабатывают числовые данные, которые размещаются в ячейках листа Excel. Столбцы и строки таблицы могут иметь текстовые названия. На листе Excel могут также располагаться заголовки, подписи и дополнительные ячейки данных с пояснительным текстом. Ввод информации — это один из первых шагов построения электронной таблицы. В этом упражнении вы изучите некоторые приемы ввода данных.

  1. Откройте файл, созданный в предыдущем упражнении, и щелкните на корешке листа Расходы.

  2. Щелкните на ячейке ВЗ и введите в нее текст Январь.

  3. Excel позволяет автоматически заполнять ячейки листа последовательными логически связанными значениями. Поместите указатель на квадратный маркер в правом нижнем углу активной ячейки.

  4. Нажмите кнопку мыши и протащите указатель вправо, чтобы рамка охватила ячейки с ВЗ по НЗ (рис. 9.4), и отпустите кнопку мыши. Семь ячеек строки заполнятся последовательными названиями месяцев года.

Рис. 9.4. Заполнение ячеек последовательными значениями

  5. Введите в ячейку А4 число 2002, а в ячейку А5 число 2005.

  6. Щелкните на клетке А4.

  7. Нажмите клавишу Shift и щелкните на ячейке А5, чтобы выделить сразу две ячейки. Для выделения ячеек листа Excel можно пользоваться следующими приемами:

    • щелчок на ячейке выделяет ее;
    • чтобы выделить прямоугольную область, щелкните на ее угловой клетке, нажмите клавишу Shift и щелкните на клетке противоположного угла области либо протащите мышь по диагонали от первого угла области до второго;
    • строка или столбец выделяются щелчком на кнопке заголовка строки или столбца;
    • чтобы выделить несколько строк или столбцов, протащите мышь по их заголовкам или щелкните па первом заголовке, нажмите клавишу Shift и щелкните на последнем заголовке группы;
    • нажав клавишу Ctrl и щелкая в клетках листа, можно выделить несколько разрозненных ячеек;
    • чтобы выделить весь лист, щелкните на кнопке листа, расположенной на пересечении линеек заголовков строк и столбцов.

Примечание

Если шаг 4 привел к заполнению всех семи ячеек словом Январь, значит, в Excel не задан список последовательных названий месяцев на русском языке. Чтобы добавить список значений для автоматического ввода, выберите команду Сервис ^ Параметры, раскройте вкладку Списки (Custom Lists). В поле Элементы списка (List Entries) введите последовательные элементы списка (Январь, Февраль, Март и т. д.) по одному на каждую строку и щелкните на кнопке Добавить (Add).

  8. Протащите угловой маркер рамки выделения вниз, чтобы рамка охватила ячейки с А4 но А12. Указанная серия ячеек будет заполнена последовательными числами с шагом 3, который определяется разницей чисел, введенных в две первые ячейки серии.

  9. Введите 1 в ячейку В4 и 3 в ячейку С4. Выделите эти две ячейки и протащите маркер рамки вправо, чтобы охватить все клетки строки вплоть до Н4.

  10. Протащите маркер полученной рамки шириной в 7 клеток вниз, чтобы охватить все строки вплоть до 12. Теперь таблица будет выглядеть так, как показано на рис. 9.5. С помощью подобных приемов таблица быстро заполняется исходными значениями, которые позже можно корректировать по мере надобности. Чтобы таблица стала более попятной, ее нужно снабдить заголовком. Ниже таблицы полезно добавить несколько итоговых значений, рассчитанных на основе данных таблицы,

  11. Введите в ячейку В 1 текст Расходы компании по месяцам. Текст заголовка не влезает в одну ячейку, поэтому следует объединить несколько ячеек.

Примечание

В последней версии Office XP появился новый способ, облегчающий ввод данных. Обратите внимание на значок параметров автозаполнения, который появляется после завершения операции заполнения рядом с угловым маркером последней заполненной ячейки. Раскрывающийся список содержит возможные параметры заполнения.

Рис. 9.5. Автозаполнение ячеек

  12. Выделите клетки с В1 по Gl.

  13. Щелкните на кнопке Объединить и поместить в центре (Merge And Center) пане ли инструментов Форматирование (Formatting).

  14. Выделите ячейки с В14 по Е14 и щелкните на кнопке Объединить и поместить в центре.

  15. Введите текст Среднее значение таблицы. По окончании ввода текста или числа ячейка находится в режиме редактирования содержимого. Многие команды для работы с ячейками в этом режиме недоступны.

  16. Чтобы выйти из режима редактирования, но остаться в текущей ячейке, щелкните на кнопке Ввод (Enter), расположенной слева от строки формулы.

Примечание

Чтобы переключиться в режим редактирования и изменить содержимое ячейки, дважды щелкните на ней. Щелчок на кнопке Отмена (Cancel), расположенной левее кнопки Ввод, выключает режим редактирования с отменой всех изменений, выполненных с момента последнего входа в этот режим.

  17. Щелчком на кнопке По левому краю (Align Left) панели инструментов Форма тирование выравняйте содержимое объединенной ячейки по левому краю.

  18. Щелкните на ячейке F14. \

  19. В строке формул щелкните на кнопке Изменить формулу (Edit Formula). Откроется окно диалога, помогающее строить корректные формулы.

Рис. 9.6. Вычисление среднего значения

  20. В раскрывающемся списке Формула (Formula) выберите пункт СРЗНАЧ (AVERAGE).

  21. Щелкните на строке формул и измените величину в скобках на В4: Н12, как показано на рис. 9.6.

  22. Щелкните на кнопке ОК. Теперь в ячейке F14 будет автоматически подсчитываться среднее значение всех чисел прямоугольной области от клетки В4 до клетки Н12. В данной ситуации эта величина равна 7.

  23. Щелкните на ячейке В4 и введите число 500. Нажмите клавишу Enter. Среднее значение таблицы сразу же изменится.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Форматирование листа Excel

Упражнение 3. Оформление ячеек

Вы уже умеете вводить числа, заголовки и подписи, вычислять сумму и среднее значение группы ячеек. Однако работать с таблицей намного приятнее, когда ее строки и столбцы окрашены в разные цвета и выделены рамками. Грамотное оформление ячеек помогает быстрее отыскивать числа, которые требуют изменения, и ячейки с результатами вычислений.

Рис. 9.7. Окно диалога автоформата

  1. Чтобы раскрасить таблицу листа Расходы, выделите прямоугольную область АЗ:Н14 и выберите команду Формат > Автоформат (Format > AutoFormat).

  2. В открывшемся окне диалога (рис. 9.7) щелкните на образце Классический 3 (Classic 3).

  3. Щелкните на кнопке Параметры (Options), открыв этой командой область флажков для установки дополнительных параметров.

  4. Сбросьте флажок ширину и высоту (Width/Height), чтобы инструмент автоформата не изменял размеры ячеек.

Примечание

В формулах Excel прямоугольная область ячеек задается идентификаторами левой верхней и правой нижней ячеек, соединенными двоеточием, например АЗ:Н14. В упражнениях третьей части книги для обозначения группы ячеек (или диапазона) используется аналогичный синтаксис.

Рис. 9.8. Форматирование ячеек

  5. Затем щелкните на кнопке ОК. Программа Excel сама оформит таблицу выбранным стилем.

  6. Чтобы привести вид заголовков строк в соответствие заголовкам столбцов, выделите ячейки А4:А12 и выберите команду Формат > Ячейки (Format > Cells).

  7. Раскройте вкладку Вид (Patterns), показанную на рис. 9.8.

  8. Щелкните на квадрате темно-синего цвета, сходного с цветом фона заголовков столбцов.

  9. Раскройте вкладку Граница (Border), показанную на рис. 9.9.

Рис. 9.9. Настройка границ ячеек

  10. В списке Тип линии (Style) выберите линию подходящей толщины.

  11. Щелкните на кнопке Внешние (Outline), чтобы обвести выделенные ячейки рамкой.

Примечание

Чтобы залить выделенные ячейки узором, пользуйтесь раскрывающимся списком Узор (Pattern) вкладки Вид.

  12. Щелчком на кнопке верхней границы уберите линию между ячейками A3 иА4.

  13. Затем щелкните на кнопке ОК.

  14. Цвет ячеек заголовков строк стал темно-синим, и черный текст в них плохо виден. Не отменяя выделения ячеек, щелкните в панели инструментов Фор матирование на стрелке справа от кнопки Цвет шрифта (Font Color).

  15. Выберите в раскрывшейся палитре белый цвет.

  16. Выделите ячейки А12:Н12 и снова выполните команду Формат > Ячейки.

  17. На вкладке Граница выберите тот же тин линии, что и на шаге 10, затем щелк ните на кнопке нижней границы.

Рис. 9.10. Оформленная таблица

  18. Щелчком на кнопке ОК закройте окно диалога. На листе ниже строки 12 появится разделительная линия. Теперь таблица будет выглядеть так, как показано на рис. 9.10.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 4. Стиль

Конечно, Excel позволяет форматировать не только цвет и рамку ячеек, но также шрифт и расположение их содержимого.

  1. Снова выделите ячейки А4:А12, затем щелкните на них правой кнопкой мыши и выберите в контекстном меню команду Формат ячеек (Format Cells).

  2. В открывшемся окне диалога раскройте вкладку Выравнивание (Alignment), показанную на рис. 9.11.

  3. В раскрывающемся списке по горизонтали (Horizontal) выберите пункт по левому краю (отступ) (Left (Indent)),

  4. С помощью стрелок введите в счетчик отступ (Indent) величину 1, чтобы задать небольшой отступ чисел от левого края ячеек.

  5. Щелкните на кнопке ОК.

  6. В панели инструментов Форматирование щелкните на кнопках Полужирный (Bold) и Курсив (Italic). На занятии 6 обсуждались стили документов Word. Электронные таблицы Excel тоже можно форматировать с помощью стилей.

Рис. 9.11. Настройка выравнивания текста

Применение стилей позволяет быстро назначать ячейкам определенное заранее заданное оформление. Изменение стиля приводит к моментальному обновлению форматирования всех ячеек, которым назначен этот стиль. Давайте настроим стиль для заголовков и подписей и назначим его двум группам объединенных ячеек листа Расходы.

  7. За основу вновь создаваемого стиля всегда выбирается формат активной ячейки. Щелкните на объединенной ячейке B1:G1, чтобы выбрать формат ее стиля в качестве исходного.

  8. Выполните команду Формат > Стиль (Format > Style).

  9. Введите слово Надпись в поле раскрывающегося списка открывшегося окна диалога. Это будет имя нового стиля. В окне диалога появятся его исходные параметры (то есть режим форматирования диапазона B1:G1).

  10. Щелкните на кнопке Изменить (Modify).

  11. В открывшемся окне диалога Формат ячеек (Format Cells) на вкладке шрифт (Font) выберите полужирный шрифт размером 12 пунктов и щелкните на кнопке ОК.

Рис. 9.12. Окно настройки стиля

Рис. 9.13. Форматирование текста

  12. В окне диалога Стиль (Style) сбросьте все флажки, кроме шрифт, как показано на рис. 9.12, чтобы новый стиль влиял только на шрифт ячейки и не изменял другие параметры оформления.

  13. Щелкните на кнопке ОК. Заголовок Расходы компании по месяцам увеличится в соответствии с новым размером шрифта.

  14. Чтобы изменить шрифт подписи Среднее значение таблицы, выделите ячейки B14:F14.

  15. Выполните команду Формат > Стиль, в раскрывающемся списке Имя стиля (Style Name) выберите пункт надпись и щелкните на кнопке ОК.

Примечание

Чтобы создать новый документ на основе шаблона с дополнительными стилями и оформлением, выберите команду Файл > Создать (File > New), раскройте в окне диалога Создание документа (New) вкладку с нужным шаблоном и дважды щелкните на его значке. Любую книгу Excel можно использовать в качестве шаблона, предварительно сохранив ее в файле формата XLT.

Текущий документ был создан без использования шаблона, тем не менее в нем есть несколько стандартных стилей Excel:

  • Обычный (Normal) — стандартный стиль ячеек;

  • Процентный (Percent) — стиль ячеек, содержащих процентные величины;

  • Финансовый (Comma) — денежные значения (рубли и копейки);

  • Финансовый [0] (Comma [0]) — денежные значения (только рубли);

  • Денежный (Currency) — денежные значения (рубли, копейки и знак денежной единицы);

  • Денежный [0] (Currency [0]) — денежные значения (только рубли и знак денежной единицы).

  16. Чтобы задать ячейкам таблицы денежный стиль представления чисел, выделите ячейки В4:Н12.

  17. Нажмите клавишу Ctrl и, не отпуская ее, щелкните на ячейке F14. Эта ячейка будет присоединена к выделению.

  18. Выберите команду Формат > Стиль, в списке Имя стиля выберите пункт Денежный и щелкните на кнопке ОК. Таблица станет такой, как показано на рис. 9.13.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 5. Формат чисел

Так как программа Excel предназначена для обработки чисел, важную роль играет правильная настройка их формата. Для человека число 10 — это просто единица и ноль. С точки зрения Excel эти две цифры могут нести совершенно разную информацию в зависимости от того, обозначают ли они количество работников компании, денежную величину, процентную часть целого или фрагмент заголовка «10 ведущих фирм». Во всех четырех ситуациях это число должно отображаться и обрабатываться по-разному. Excel поддерживает следующие форматы данных:

  • Общий (General) — текст и числовые значения произвольного типа;

  • Числовой (Number) — наиболее общий способ представления чисел;

  • Денежный (Currency) — денежные величины;

  • Финансовый (Accounting) — денежные величины с выравниванием по разделителю целой и дробной частей;

  • Дата (Date) — дата или дата и время;

  • Время (Time) — время или дата и время;

  • Процентный (Percentage) — значение ячейки, умноженное на 100 с символом «%» в конце;

  • Дробный (Fraction) — рациональные дроби с числителем и знаменателем;

  • Экспоненциальный (Scientific) —десятичные дробные числа;

  • Текстовый (Text) — текстовые данные отображаются точно так же, как вводятся и обрабатываются строки, вне зависимости от их содержимого;

  • Дополнительный (Special) —форматы для работы с базами данных и списками адресов;

  • Заказной (Custom) — формат, настраиваемый пользователем.

Наиболее распространенные варианты формата данных можно назначать с помощью панели инструментов Форматирование.

  1. Щелкните на ячейке С4, а затем на кнопке Процентный формат (Percent Style). Величина клетки С4 будет умножена на 100, и к ней добавится знак «%».

Рис. 9.14. Вкладка выбора формата данных

  2. Нажмите клавишу вниз и щелкните на кнопке Денежный формат (Currency).

  3. Щелкните на ячейке Сб, а затем на кнопке Формат с разделителями (Comma Style). Эта кнопка заставляет числа выравниваться в столбце по разделителю целой и дробной частей.

  4. Выделите ячейку С7 и щелкните на кнопке Увеличить разрядность (Increase Decimal). Эта кнопка не изменяет основной формат, но добавляет один знак в дробной части числа.

  5. Нажмите клавишу Enter и щелкните на кнопке Уменьшить разрядность (Decrease Decimal). Эта операция убирает один знак дробной части и округляет число. Теперь ячейки с С4 по С9 выглядят совершенно по-разному, хотя исходно в них были введены совершенно одинаковые числа. Другие форматы назначаются с помощью следующих действий.

  6. Щелкните на ячейке С10 и выберите команду Формат > Ячейки.

  7. В открывшемся окне диалога раскройте вкладку Число (Number) (рис. 9.14).

  8. В списке Числовые форматы (Category) щелкните на пункте Дата (Date).

  9. В появившемся списке Тип (Type) щелкните на строке 14 мар 01 (14-Mar-Ol). Затем щелкните на кнопке ОК.

  10. Аналогичным образом назначьте ячейке С11 формат Экспоненциальный, а ячейке С12 — формат Числовой. Теперь таблица будет выглядеть так (рис. 9.15). Обратите внимание, что среднее значение таблицы не изменилось, то есть при смене формата изменяется только способ отображения, а сами числовые значения остаются неизменными. Для проверки этого факта выполните следующие шаги.

  11. Дважды щелкните на ячейке СЮ и измените величину 03.01.1900 на 03.02.1900.

  12. Нажмите клавишу Enter. Среднее значение таблицы (которое выводится в денежном формате) моментально изменится на 15.41р. Как войдите, можно суммировать даты с процентами и в результате получать рубли. Это типичный пример неверного назначения форматов данных.

Рис. 9.15. Различные форматы чисел


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 6. Добавление строк и столбцов

Редко удается сразу построить таблицу с нужной структурой. В процессе разработки листа часто приходится добавлять и переставлять столбцы и строки. Давайте поучимся этим операциям.

  1. Выделите ячейки ЕЗ и F3 и выберите команду Вставка >Столбцы (Insert > Columns). Слева от столбца с заголовком Апрель появятся два пустых столбца (рис. 9.16). Их количество соответствует числу ячеек выделенного блока по горизонтали.

  2. Выделите диапазон ВЗ:С12 и нажмите клавиши Ctrl+C, чтобы скопировать содержимое выделенных ячеек.

  3. Щелкните на клетке ЕЗ правой кнопкой мыши и выберите в контекстном меню команду Вставить (Paste). Эта операция вставит данные не только в ячейку ЕЗ, но и в другие ячейки новых столбцов. В правом нижнем углу вставленного фрагмента появился значок вставки. Поместив на него указатель мыши, вы увидите раскрывающийся список, позволяющий выбрать один из параметров вставки: Сохранить форматы оригинала (Keep Source Formatting), Использовать форматы конечных ячеек (Match Destination Formatting), Значения и форматы чисел (Values and Number Formatting), Сохранить ширину столбцов оригинала (Keep Source Column Width), Только форматы (Formatting Only) или Ссылки на ячейки (Link Cells).

Примечание

При вставке блока данных в одну ячейку программа Ехсе1.всегда занимает вставляемой информацией столько ячеек, сколько было вырезано или скопировано. Если перед выполнением вставки было выделено несколько ячеек, то данные будут вставлены только в том случае, если форма диапазона-приемника идентична форме диапазона-источника.

Рис. 9.16. Добавление столбцов

  4. Щелкните на ячейке Н14, в которую переместилась ячейка с формулой среднего значения таблицы. В строке формул вы увидите текст =CP3HA4(B4:J12) (=AVERAGE(B4:312)). To есть область вычисления среднего значения автоматически расширилась на два вставленных столбца. Таким образом, формулы, работающие с массивами данных, автоматически адаптируются при увеличении размера массива.

Дополнительные строки добавляются точно так же, как столбцы. Вставляя строки или столбцы в таблицу с данными, будьте внимательны. Удалить лишние ячейки гораздо труднее, чем вставить. Выделение ячеек с последующим нажатием клавиши Delete, конечно, очищает ячейки, но размеры таблицы при этом не изменяются.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Упражнение 7. Размеры ячеек и их замораживание

Чтобы таблица лучше вписывалась в экран компьютера или на страницу принтера, можно подрегулировать ширину и высоту ячеек.

  1. Поместите указатель на границу между заголовками столбцов А и В, чтобы его значок принял форму двунаправленной стрелки.

  2. Нажмите кнопку мыши и перетащите границу столбцов влево, уменьшив этим ширину первого столбца.

  3. Выделите строки 13 и 14.

  4. Выберите команду Формат > Строка > Высота (Format > Row > Height).

  5. В открывшемся окне диалога введите число 15 и щелкните на кнопке ОК. Выделенные строки станут выше.

  6. Чтобы максимально сузить таблицу, протащите мышь по кнопкам строк с 1 по 14, выделив этим все ячейки данных.

  7. Выберите команду Формат > Столбец > Автоподбор ширины (Format > Column > AutoFit Selection). Эта операция максимально сузит столбцы, но лишь до такого размера, чтобы все данные свободно помещались в ячейках таблицы.

Рис. 9.17. Закрепление ячеек

Иногда при редактировании таблицы приходится копировать или переносить данные между ячейками, далеко отстоящими друг от друга. В этом случае можно закрепить часть строк и столбцов на экране. Работая с большими таблицами, бывает удобно закрепить строку и столбец заголовков, чтобы не запутаться в ячейках. Для закрепления заголовков выполните следующие шаги.

  8. Щелкните на ячейке В4. Затем выберите команду Окно > Закрепить области (Window > Freeze Panes). Ячейки, расположенные выше или левее выделенной, окажутся закрепленными и отгороженными от остальной таблицы тонкими черными линиями.

  9. Щелкните три раза на кнопке прокрутки вниз.

  10. Теперь два раза щелкните на кнопке прокрутки вправо. Лист Excel прокручивается как обычно, но закрепленные ячейки остаются на экране, как показано на рис. 9.17. Создается впечатление, что столбцы В и С, а также строки 4, 5 и 6 временно исчезли с экрана.

  11. Чтобы отменить закрепление, выполните команду Окно > Снять закрепление областей (Window > Unfreeze Panes). Лист будет выглядеть, как прежде.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Контрольное упражнение

Попробуйте самостоятельно заполнить данными один лист электронной таблицы.

  1. Переключитесь на лист Лист4.

  2. Измените название этого листа на Календарь.

  3. Введите в ячейку A3 символы Пн.

  4. Перетащите маркер выделения вниз, чтобы ячейки с A3 по А9 заполнились сокращенными названиями дней недели.

  5. В прямоугольную область B3:F9 введите числа календаря на текущий месяц.

  6. В строке 1 введите заголовок Календарь на текущий меся ц, объедините для него несколько ячеек и выровняйте заголовок по правому краю диапазона.

  7. Добавьте обрамление жирной линией вокруг блока ячеек A3:F9.

  8. Отделите линией столбец А от столбца В.

    • Как быстро добавить вертикальную линию?

  9. Залейте фон ячеек строк 8 и 9 красным цветом, а шрифт текста этих строк выделите жирным начертанием.

    • Как изменить фон ячеек?

  10. Объедините ячейки А11:С11 и введите в них текст Всего дней в месяце.

  11. В ячейку D11 вставьте формулу, подсчитывающую число дней месяца.

    • Как подсчитать число дней месяца?

  12. Скопируйте текущий лист в новую книгу Excel с одним листом и сохраните новую книгу в файле Календарь.xls.

  13. В книге Электронная таблица.xls раскройте лист Клиенты(2).

  14. Выделите строку 9 и удалите ее.

  15. Переименуйте этот лист, дав ему название Формулы. Затем сохраните документ.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь

Подведение итогов

На этом занятии вы узнали, как добавлять, копировать и переименовывать листы Excel, строить таблицы, оформлять и форматировать их. Вы познакомились с разными форматами чисел и научились настраивать собственные стили.

В упражнениях занятия вы строили формулы для расчета среднего значения, суммы и количества чисел. Вычисление статистических величин — одно из основных назначений электронных таблиц. Расчеты в Excel выполняются с помощью формул. На следующем занятии вы узнаете основные правила построения формул и познакомитесь с некоторыми функциями Excel.


● Ищу рекламные места. Куплю интернет трафик дорого
● Покупаю ссылки с сайтов. Обращайтесь