Отличия зарегистрированной версии

  • Отличия платной версии
  • Регистрация

    • Покадровый редактор видео

    Покадровый редактор видео

    • Добавление, удаление кадров
    • Добавление выносок, текстовых надписей, картинок, рамок, стрелок, кнопок, затенений в записанный фильм с возможностью редактирования в дальнейшем
    • Импорт звука в форматах wav и mp3
    • Наложение нескольких звуковых дорожек
    • Уровень громкости для каждой звуковой дорожки
    • Эффекты появления и изчезновения для объектов
    • Возможность подключить модуль экспорта фильмов в Exe, защищенный от копирования new

    Новый модуль для экспорта фильмов в SWF

    Полученный swf файл можно редактировать в любом флэш редакторе. Доработана синхронизация звука и видео.

    Новые элементы управления в SWF фильмах

    Элементы управления в SWF фильмах

    Удобнее управлять воспроизведением SWF фильма (в том числе на вэб-страницах). Можно начать воспроизведения с любого кадра щелчком на линии прогресса.

    Экспорт фильмов в FLV формат

    Еще один популярный формат видео от Macromedia.

    Экспорт в GIF-анимацию

    Экспорт записанного с экрана фильма (или отдельных сегментов).

    Демо ролик в виде GIF-анимации, опубликованный на веб-странице, будет воспроизведен любым браузером без установки дополнительных модулей (типа Flash Player).

    Рисование на экране во время записи

    Позволяет выделять ключевые моменты в фильме красным цветом. Можно обводить, подчеркивать нужные области на экране, ставить галочки, восклицательные знаки и т.д.

    Чтобы рисовать только горизонтальные линии, держите нажатой кнопку Shift.

    Регистрация


Защита фильмов от копирования

? Зачем нужны фильмы в виде исполняемого EXE файла, защищенного от копирования?

Предположим Вы создали хороший обучающий фильм (или электронную книгу). Как получить за него деньги? Точнее, как получить за него максимальное количество денег? Я затрону только вопрос распространения фильма в интернете.

Размещаем на сайте описание фильма, выкладываем отдельные кадры или даже несколько первых минут фильма, чтобы показать как детально, наглядно и интересно подается информация. Обязательно показываем оглавление, чтобы было видно какие вопросы рассмотрены в фильме.

! Посмотреть пример фильма в интернете.

Свершилось - нашли наш сайт с описанием фильма. Посмотрели выложенные фрагменты, посмотрели оглавление, фильм кого-то заинтересовал. Чтобы скачать его целиком мы, естественно, требуем денег. Цена вполне приемлемая.

И вот тут первым делом все ищут где бы скачать этот фильм бесплатно. Даже не глядя на цену. Если мы успели продать хотя бы несколько копий, то велика вероятность, что фильм уже выложен в сети. Необязательно специально. Один другому дал посмотреть фильм по дружбе, тот скопировал его своей подружке, та поделилась со своим братом и т.д. В конце концов фильм окажется у человека которому не жалко выложить его для всех. Вопрос времени и весьма недолгого.

И как только это произошло, с продажами почти можно попрощаться. Зачем платить за бесплатное? Помимо денег это же еще и дополнительные усилия. Посчитаем сколько успели заработать до того как фильм стал "бесплатным"... Едва ли это стоило усилий, потраченных на его создание.

Теперь подумаем как исправить ситуацию. В каких форматах сейчас распространяют видео курсы? SWF, FLV, AVI, WMV, EXE. Обычный видео файл защитить от копирования невозможно. А вот EXE файл совсем другое дело.

Видео курсы в виде EXE файлов не редкость в сети. Но почти у всех есть один недостаток - даже если ключа или "кряка" в сети нет, их можно переснять с экрана любым граббером (например той же UVScreenCamera-й :) ). После чего уже обычное видео без какой-либо защиты копируется и выкладывается в Интернет без ограничений.

! Если вы заинтересованы в защите своих обучающих/демонстрационных видео фильмов или электронных книг от копирования, то советую внимательно присмотреться к новым возможностям UVScreenCamera.

? Что представляет из себя комплексное решение UVScreenCamera от UVsoftium?

1. | Удобный инструмент для снятия видео с экрана.
2. | Видео редактор, позволяющий добавлять/удалять кадры, "украшать" фильм выносками, стрелками, картинками, различными фигурами, накладывать звук.
3. | Предусмотрен элемент для создания интерактивного взаимодействия с пользователем.
4. | Эксклюзивный модуль для UVScreenCamera для экспорта в закрытый видео формат (компилируется специально для каждого автора, второго такого модуля ни у кого не будет).
5. | Проигрыватель для просмотра, с которого сложно переснять видео. Для просмотра фильма требуется ключ который действителен только на одном компьютере.
6. | Интерфейс для ручной и автоматической генеции ключа.

Скачать пример фильма в формате защищенного EXE. Не забывайте проверять все файлы, скачанные из Интернета, антивирусом!

! Советы
  • Видео в формате EXE вызывает опасения. Не меньше половины людей откажутся от скачивания такого файла. Называйте файлы "Интерактивный курс по ...", "Программа обучения ...". При такой формулировке расширение EXE у файла вполне уместно.

  • Обязательно дайте посмотреть фильм другому человеку и послушайте его мнение. Замечания вроде "где-то не успел прочесть выноску", "здесь совсем непонятно, надо бы пояснить" очень помогут в создании хорошего фильма.

  • Организуйте на Вашем сайте прием денег за фильм всеми возможными способами. Очень часто люди уже готовые платить, но видя (впервые) только значок WebMoney например, теряются и уходят с сайта в поисках альтернативы.

  • Раз у файла расширение EXE, то стоит разместить фильм в каталоги программ: www.freesoft.ru, www.softodrom.ru, www.freeware.ru, soft.mail.ru и др.

  • Стоит попробовать и рекламу. Тот же Яндекс.Директ обойдется 300 руб в неделю и за эту неделю обеспечит около 200 целевых посетителей.

! Ограничения
  • Модуль экспорта в защищенный EXE работает только в зарегистрированной UVScreenCamera.

  • Фильм не получится посмотреть на виртуальной машине (WMware, Virtual-PC, VirtualBox, ...). При запуске фильма будет выдано соответствующее предупреждение.

Шаги для создания видео курсов в формате защищенного EXE:

1. | Зарегистрировать программу UVScreenCamera.
2. | Заказать модуль uvf2.
3. | Подтвердить e-mail, указанный в заказе.
4. | Пополнить счет.
5. | Поместить, полученный по e-mail, модуль uvf2.dll в каталог программы.

После этого Вы имеете возможность управлять своим счетом и генерацией ключей из панели управления.

! Особенности генерации ключей.

При запуске фильма пользователю выдается окно с просьбой указать ключ для просмотра на этом компьютере.

Куда ведет ссылка Купить Вы сами указываете при экспорте фильма.

В скором времени планируется добавить для авторов фильмов услугу размещения и приема платежей на сайте www.uvsoftium.ru. А пока Вам необходимо организовать прием платежей за просмотр фильмов на своем сайте, например так или так.

Ключи можно генерировать вручную из панели управления или в автоматическом режиме. О том как подключить автоматический режим можно узнать в панели управления.

Стоимость каждого нового ключа сейчас составляет 30 руб. (эти деньги списываются с Вашего счета).


Настройка записи звука

Прежде чем записывать звук необходимо указать программе откуда его записывать. Это может быть микрофон, "колонки", телефонная линия и т.д. Если в компьютере несколько звуковых карт или подключено несколько микрофонов, то нужно указать с какого именно устройства нужно записывать звук.

Окно настройки звука выглядит примерно так:

В списке на картинке присутствует 2 устройства (звуковая карта Realtek AC97 и USB микрофон). Можно выбрать запись сразу с обоих устройств, отметив их галочками.

В звуковой карте, как правило, присутствует несколько источников (каналов) звука - Микрофон, Stereo Mix, Линейный вход и т.д. Для записи звука с колонок в большинстве случаев нужно выбрать Stereo Mix, но встречаются звуковые карты в которых это не так. Тогда лучше попробовать все источники звука по очереди.

Напротив каждого источника звука есть движок которым можно регулировать уровень записи (чувствительность). Если записанный звук слишком тихий, то необходимо повысить чувствительность устройства (уровень записи). Если же уровень записи слишком высокий, то записанный звук будет громче исходного и нередко с помехами, шумами.


VirtualKeyboard

Виртуальная клавиатура

Виртуальная клавиатура показывает все нажатия клавиш (за исключением горячих клавиш UVScreenCamera и системных, например Ctrl + Alt + Del)

Рекомендации

  • Отображение виртуальной клавиатуры во время записи заметно увеличивает размер фильмов, экспортированных в SWF. На остальные форматы практически не влияет.
  • Если вы записываете не весь экран, а его часть, то отобразите область записи, чтобы убедиться, что виртуальная клавиатура целиком попадает в нее.


Рисование на экране

Рисование на экране при записи

  • Включение режима рисования
  • Линии, прямоугольники, эллипсы, текст
  • Стирание нарисованного
  • Смена цвета во время рисования

Рисование на экране - очень удобный инструмент для создания обучающих фильмов. Экран тогда превращается в подобие школьной доски. Для рисования предусмотрено несколько инструментов. Вот пример фильма в виде gif-анимации:

Примечание
Рисование на экране на большой области может привести к заметному подтормаживанию компьютера, т.к. требует много ресурсов. Проявляется в частности в том, что кривые выглядят как ломанные линии. В зависимости от процессора и видеокарты можно без видимых тормозов рисовать либо на всем экране, либо только на его части.

Включение режима рисования

По умолчанию горячая клавиша для включения/выключения режима рисования Ctrl+Shift+D. Ее можно поменять в дополнительных настройках. При включении режима рисования курсор принимает вид карандаша.

Если записывается не весь экран, то рисовать можно только в пределах области записи.

Линии, прямоугольники, эллипсы, текст

Помимо рисования от руки можно рисовать горизонтальные линии, прямоугольники, эллипсы, текст.

Элемент | Как нарисовать
Горизонтальная линия | удерживая Shift
Прямоугольник | удерживая Ctrl
Эллипс | удерживая Alt
Текст | просто набирая его на клавиатуре

Примечание
Можно указать где должен появится текст средней кнопкой мыши в режиме рисования.

В дополнительных настройках можно указать цвета, толщину линий и размер шрифта по умолчанию для всех элементов рисования.

Стирание нарисованного

Для стирания последнего нарисованного элемента можно использовать комбинацию Ctrl+Z. Для очистки всего поля можно использовать двойной щелчок правой кнопкой мыши.

Смена цвета во время рисования

Можно поменять цвет карандаша прямо во время записи в режиме рисования. Нужно нажать Ctrl+Alt+ <буква>. Соответствие букв и цветов показано в таблице.

Ctrl+Alt+ | Цвет | Ctrl+Alt+ | Цвет | Ctrl+Alt+ | Цвет
B (black) | Черный | W (white) | Белый | E | Темно-серый
L (lime) | Светло-зеленый | G (green) | Зеленый | T (teal) | Сине-зеленый
A (aqua) | Голубой | U (blue) | Синий | N (navy) | Темно-синий
R (red) | Красный | M (maroon) | Бордовый | Q | Оранжевый
F (fuchsia) | Фиолетовый | P (purple) | Пурпурный | D | Сиреневый
Y (yellow) | Желтый | O (olive) | Оливковый | S (silver) | Серебристый

В зависимости от галочки в настройках выбранный цвет будет использоваться либо только для рисования от руки, либо для всех элементов рисования сразу.


Видео редактор

  • Добавление элементов (выносок, картинок, ...)
  • Выделение кадров
  • Добавление, удаление, копирование кадров
  • Метки кадров
  • Сглаживание движения курсора
  • Наложение звука
  • Разделение звука на части
  • Переименование проекта
  • Импорт фильмов UVF
  • Экспорт фильмов

После записи фильма можно вырезать лишние куски, добавить паузы, если нужно, наложить звук. Для наглядности можно добавить поясняющие выноски, рамки, картинки.

Добавление элементов (выносок, картинок, ...)

Пункт меню "Вставка объекта" или соответствующая кнопка на верхней панели. Если текущий слой занят другим элементом, то создается новый слой. Для настройки параметров каждого элемента нажмите кнопку "Свойства" или выберите соответствующий пункт из контекстного меню. Элементы можно перемещать по временной шкале, менять длительность отображения на экране, переносить с одного слоя на другой.

Примечание:

  • Порядок слоев снизу-вверх.
  • Элементы добавляются в текущий кадр
  • Очень полезен бывает пункт меню "Редактирование", где можно указать начало и длительность отображения для выделенных объектов

Выделение кадров

Появился новый удобный инструмент для выделения кадров. Посмотрите флэш-ролик.

Как и раньше, кадры можно выделять, используя панель кадров. Проведите мышью под номерами кадров. Можно щелкнуть на одном кадре, затем с Shift-ом на другом кадре. Выделится диапазон между этими кадрами.

Добавление, удаление, копирование кадров

Пункт меню "Кадры / Добавить кадры". Пока можно добавить только копию текущего кадра. Это нужно для создания паузы в фильме. В дальнейшем планируется добавить эффекты перехода из одного кадра в другой.

Кадры не удаляются сразу. Они помечаются на удаление. Можно посмотреть что получится после удаления выделенных кадров в предварительном просмотре. В любой момент кадры можно вернуть, сняв отметку об удалении.

Для того чтобы окончательно удалить кадры из проекта (без возможности восстановления) используйте пункт меню "удалить кадры, помеченные на удаление".

Кадры, как обычные объекты, можно копировать и вставлять в проект (Ctrl+C, Ctrl+V).

Метки кадров

Метки очень помогают в навигации по фильму. Создать метку можно из пункта меню "Кадр", "Редактировать метку кадра". После создания метки рядом с кадром появится значок @. Можно перемещаться по меткам с помощью кнопок "Ctrl + влево", "Ctrl + вправо", а также с помощью пункта меню "Навигация".

Метки служат также для разделения фильма на отдельные сегменты при экспорте в SWF, UVF, EXE.

Примечание:
Следует запомнить очень полезные для навигации сочетания клавиш: "Ctrl + влево", "Ctrl + вправо", Home, End, PageUp, PageDown.

Сглаживание движения курсора

Нередко проект пишется частями. На границе этих частей курсор "дергается", потому что в конце записи первой части и начале записи второй находится в разных точках. И чем больше расстояние между этими точками, тем сильнее это "скачок" курсора на границе. Теперь есть функция для сглаживания движения курсора. Выделяем диапазон кадров в которых нужно сгладить движение курсора и выбираем "Редактирование / Сгладить движение курсора". Как правило, достаточно выделить 5-10 кадров.

Наложение звука

Наложение звукового сопровождения лучше делать в последнюю очередь, чтобы не нарушать синхронизацию звука и видео. Звук можно записать с колонок или микрофона либо импортировать из файла (*.wav, *.mp3).

Окно наложения звука

Разделение звука на части

Звуковые объекты разделяются по текущему кадру. Порядок действий:

  1. Установите указатель текущего кадра в нужное положение
  2. Выделите звуковые объекты, которые необходимо разделить (чтобы выделить несколько объектов, удерживайте Ctrl)
  3. Выберите "Редактирование / Разделить звук" или соответствующий пункт из контекстного меню.
В результате получится два независимых объекта.

Примечание:
Если выделить не звуковые объекты, то данная функция будет недоступна.

Переименование проекта

Проект представляет собой отдельную папку с файлом *.upr. Имена проектам (и папке и файлу) присваиваются автоматически. Чтобы не путаться в своих проектах, лучше присвоить проекту понятное имя. Пункт меню "Файл", "Переименовать проект".

Если на компьютере не было старых версий UVScreenCamera, то все проекты хранятся в "Мои Документы\uvSC_Projects". Иначе в "Program Files\UVsoftium\UVScreenCamera\Projects". Каталог для проектов можно поменять в настройках.

Импорт фильмов UVF

В редактор можно импортировать фильмы, записанные с помощью предыдущих версий UVScreenCamera: либо открыть файл из главного окна и затем нажать "Редактор", либо прямо из редактора "Файл", "Импорт".

Примечание:
Импорт может занять довольно продолжительное время (т.к. происходит преобразование форматов).

Экспорт фильмов

"Файл", "Экспорт". Откроется мастер экспорта фильма. Часть форматов для экспорта доступна только после регистрации.


Интерактивность

  • Добавление кнопок в фильм
  • Размещение кнопки поверх других объектов
  • Опция "останавливать фильм"

Добавление кнопок в фильм

Для интерактивного взаимодействия с пользователем предусмотрен элемент "Кнопка". По сути, это просто прямоугольная область, при щелчке на которую выполняется некоторое действие.

Список действий, доступных в текущей версии:

  • Пауза (стоп)
  • Воспроизведение
  • Следующий кадр
  • Предыдущий кадр
  • Переход на кадр ... (указывается либо номер кадра, либо метка кадра)
  • Переход на URL (например: http://www.uvsoftium.ru)

Используя кнопки, в фильмах можно создавать:

  • Оглавление
  • Покадровый просмотр (слайд-шоу)
  • Контроль усвоения материала в виде тестов
  • и многое другое

Примечание:
В текущей версии кнопка экспортируется только в SWF фильмы и фильмы в формате защищенного EXE (в AVI или GIF-анимации кнопок быть не может).

Размещение кнопки поверх других объектов

Чтобы не подгонять положение и размеры кнопки вручную (что довольно неудобно), в редакторе предусмотрена автоматическая подгонка (в свойствах кнопки опция "Автопозиционирование"). Достаточно перетащить кнопку на нужный объект (см. флэш ролик).

Примечание:
Рамка у кнопки нужна скорее для удобства работы с кнопкой в редакторе. Перед экспортом или сразу после размещения кнопки на нужное место отображение рамки можно отключить.

Опция "останавливать фильм"

В свойствах кнопки есть опция "Останавливать фильм". Это значит, что если в кадре есть хотя бы одна кнопка с включенной опцией, то фильм на этом кадре останавливается. И ждет действий пользователя. Естественно в таком случае должна присутствовать кнопка для продолжения воспроизведения.


3D avi

Запись 3D игр в avi

Эта возможность появилась вследствие желания пользователей записывать все происходящее в 3D играх, однако формат uvf не предназначен для этого.

Примечание:
При включенном режиме 3D стандартный курсор мыши не записывается.

Записывать полноэкранное видео в режиме реального времени, прямо во время игры - это серьезное испытание для процессора, видеокарты и винчестера. Хорошо получаются фильмы, снятые при разрешении 512x384 (четверть площади экрана) с частотой 10 кадр/сек.

При запуске игра, как правило, занимает весь экран и кроме игры ничего не видно. Т.е. область записи нужно подготовить заранее. Проще всего нажать кнопку "Выделить..." на панели выбора области записи, щелкнуть правой клавишей в левом верхнем углу экрана и выбрать одно из стандартных разрешений экрана.

Нетрудно заметить, что в списке далеко не все возможные значения. Меньше чем 400х300 нет смысла, больше чем 800х600 не потянет компьютер. Рекомендуется использовать 512x384. Естественно в игре тоже нужно установить такое же разрешение. Где-нибудь в настройках игры обязательно есть такая возможность.

Примечания:

  • Для начала записи напрямую в AVI добавлена горячая клавиша Shift+F11. При этом используются кодек и настройки которые были использованы в прошлый раз.
  • Некоторые игры блокируют горячие клавиши, так что придется сначала запускать UVScreenCamera, потом игру.
  • Можно запустить запись всего экрана с задержкой
  • Некоторые игры позволяют играть в окне (не в полноэкранном режиме). В таком режиме легче записывать фильм.

Можно заранее указать полное имя файла, чтобы не искать потом записанный фильм. Если такой файл существует, при начале записи будет выдан запрос об имени файла.

При нажатии кнопки "Выбрать..." отображается список видео кодеков, такой же, как при настройке экспорта.

Как показала практика, лучше всего записывать фильм без сжатия. При этом за каждые 4 минуты фильма при разрешении 400x300 при 10 кадр/сек придется отдать ~1Гб на винчестере. Затем получившийся фильм можно сжать в 30 и более раз с помощью программы Virtual Dub или аналогичной. При использовании кодека файл получается в десятки раз меньше, но возможны "подтормаживания" в игре.

Примечание:
максимальный размер avi ~2Гб, а значит без сжатия можно записать около 8 минут фильма при разрешении 400x300 / 10 кадр/сек.

Если вы решили сжимать видео во время записи, то вам следует:

  • использовать достаточно быстрый кодек (например: XviD, Mpeg4, DivX)
  • не ставить качество меньше 85%
  • использовать разрешение экрана не более 512x384 (как правило, большинство игр такое разрешение поддерживает).

Из всех испробованных кодеков лучше всех себя показал DivX 5.1.1. В настройках кодека следует указать "быстрое" сжатие.


Копирование экрана

  • Снимок выделенной области
  • Редактор скриншотов
  • Сохранение изображений в файлы
  • Создание GIF-анимации

Снимок выделенной области

Сначала выбираем область экрана для копирования. Затем нажимаем [image] или соответствующую горячую клавишу (по умолчанию PrintScreen). С каждым нажатием добавляется новое изображение, ограниченное выбранной областью. Рамка мигнет фиолетовым цветом, сигнализируя, что снимок сделан.

Редактор скриншотов

Данное окно хранит "сфотографированные" изображения.

Под списком изображений теперь есть Навигатор - чтобы можно было просматривать интересующий фрагмент изображения, не помещающегося в окно просмотра. Можно нажать левую кнопку мыши и водить по нему для просмотра

Порядок кадров можно менять.

Назначение кнопок:

Сохранить выделенные изображения
Выделить все изображения
Снять выделение со всех изображений
Инверсия выделения
Удалить выделенные изображения из списка
Удалить все изображения из списка
Масштаб при просмотре. Текущий масштаб отображается внизу в строке состояния. Там же отображаются истинные размеры изображения.

Примечание:
Можно копировать фрагмент уже скопированного изображения. В окне предварительного просмотра выделяем нужный фрагмент и нажимаем "Снимок выделенной области".

Сохранение изображений в файлы

Можно сохранять в форматах *.bmp, *.gif, *jpg. Если выделено только одно изображение, то после нажатия кнопки [image] оно будет сохранено под именем, которое вы введете в диалоге. Если же выделено несколько изображений, то к имени каждого файла будет добавлен порядковый номер в виде

FileName003.jpg.

После сохранения наименование изображения в списке изменится на имя файла с расширением.


GIF-анимация

Для публикации роликов в Интернет это лучший выбор. Отображается любым браузером без установки дополнительных модулей (как, например, FlashPlayer для SWF-фильмов). Можно использовать в файлах справки chm. Формат достаточно компактный.

С помощью UVScreenCamera очень удобно создавать GIF-анимацию из снимков с экрана. Выделяете область, нажимаете [image] или клавишу PrintScreen на клавиатуре.

Затем открываем Редактор скриншотов, выставляем длительность показа каждого кадра (можно выставлять для нескольких выделенных сразу, выделяя их с Shift или Ctrl).

И сохраняем анимацию либо цветной, либо в серых тонах.

Цветная | Градации серого


Внедрение фильмов на веб страницы

  • Создание web страниц, содержащих анимацию (AVI, SWF)
  • GIF-анимация

Создание web страниц, содержащих анимацию

Для облегчения создания Web страниц, содержащих анимацию, в приложении теперь присутствует специальный мастер. На главном окне выбираем "Действия \ Публиковать видео в Web". Появится диалог выбора файла. Выбираем нужный фильм в формате AVI или SWF. Появится такое окно:

Отображаются свойства выбранного фильма. Из названий кнопок понятно, для чего они нужны.

Примечание:
Предполагается, что фильм находится в той же папке, что и Web страница.


Запуск проигрывателя с параметрами

Фильмы, сохраненные в exe можно встраивать в презентации PowerPoint. Если вам это нужно, пишите, я вышлю пример такой презентации.

Общий вид командной строки при запуске фильма, сохраненного в exe, выглядит так:

"filename.exe" [-size {FULLSCREEN|MAX|MIN|{w h}} [-pos {C|{{L|R|x} {T|B|y}}}]] [-segm N] [-closeonfinish]

fullscreen - полноэкранный режим без нижней панели управления
max - максимальный размер (занимает весь экран, но при этом остается заголовок окна и нижняя панель)
min - минимальный размер (600 x 400)
w h - Width, Height - ширина, высота проигрывателя

c - Center - в центре экрана

L - Left - по левому краю экрана
R - Right - по правому краю экрана
x - отступить от левого края экрана х пикселей

T - Top - по верхнему краю экрана
B - Bottom - по нижнему краю экрана
y - отступить от верхнего края экрана y пикселей

N - Segment Number - начинать воспроизведение с сегмента N

CloseOnFinish - закрыть проигрыватель по окончании воспроизведения

примеры:

"c:\Temp\Example.exe" -size 800 600 -pos c -segm 2 -closeonfinish

Это означает:

  • открыть файл "c:\Temp\Example.exe"
  • в окне размером 800 x 600
  • в центре экрана
  • начать воспроизведение со второго сегмента
  • автоматически закрыть проигрыватель после просмотра

Example.exe -size fullscreen -closeonfinish

Это означает:

  • открыть файл "Example.exe"
  • во весь экран
  • автоматически закрыть проигрыватель после просмотра

Можно использовать "/" вместо "-" перед параметрами. Например:

Example.exe /size 600 400 /pos r b

Примечание:
Проигрыватель тоже можно запускать с параметрами. Первым параметром должно быть имя файла. Например:

uvPlayer.exe "FileName.uvf" -size 800 600 -pos C -closeonfinish


Списки воспроизведения

  • Режимы работы: редактирование / воспроизведение
  • Создание списка воспроизведения
  • Создание простого bat-файла

В дистрибутив добавлена утилита uvFilmsViewer для создания списков воспроизведения UVF-фильмов. С этой утилитой немного удобнее демонстрировать обучающие ролики. Кроме того, если обучающие ролики разбиты на несколько отдельных файлов, нет проблем с задержкой при запуске.

Сценарий работы такой:
Пользователь просматривает первый фильм. После показа фильма uvFilmsViewer ставиться на паузу. Пользователь пытается повторить действия, показанные в фильме. Затем нажимает кнопку "продолжить" для просмотра следующего фильма.

Примечание:
Можно повторить любой из фильмов дважды щелкнув на нем в списке. Можно выбрать фильм в списке и нажать "Enter".

Режимы работы: редактирование / воспроизведение

Утилита может запускаться в режиме редактирования и режиме воспроизведения. В режиме воспроизведения большинство функций недоступны.

Примечание:
Открыть существующий список воспроизведения в режиме редактирования можно только запустив uvFilmsViewer и выбрав "Открыть (редактирование)" из выпадающего списка действий.

Создание списка воспроизведения

Рекомендуемый порядок действий:

  1. Скопировать фильмы в отдельную папку
  2. Запустить uvFilmsViewer указав имя файла (в той же папке)
  3. Отметить галочками нужные фильмы, выстроить их в нужном порядке
  4. Из выпадающего списка действий выбрать "Сохранить". В папке появятся файлы: uvFilmsViewer.exe, файл с расширением uvp и bat-файл для запуска. Как пример:

Примечание:

  • Для просмотра фильмов в соответствии со списком воспроизведения нужно запускать bat-файл (в данном случае _Example.bat).
  • Можно обойтись без bat-файла и запускать просмотр с командной строки:
    uvFilmsViewer.exe "Example.uvp"

    Создание простого bat-файла

    Если не хочется использовать утилиту uvFilmsViewer объемом 740 K, то можно обойтись проигрывателем и bat файлом, который по очереди запускает файлы и ждет нажатия кнопки после каждого фильма.

    Выбираем "Создать *.bat файл" из выпадающего списка действий.

    Вам нужно указать заголовок и имя bat файла. Файл должен быть сохранен в той же папке что и фильмы.

    В папке вместе с bat файлом появится uvPlayer.exe. Примерно так выглядит папка после создания bat файла "_Example.bat":

    Вот результат запуска файла "_Example.bat":

    Примечание:
    Имя файла лучше начинать с символа "_", тогда при сортировке по имени он будет наверху.


Анимация в файлах справки chm

Есть возможность размещать анимацию в формате uvcab в файлах справки chm, есть правда одно существенное ограничение - только в виде ссылок на файлы.

Сам фильм находится в папке Films. Там же находится и картинка для фона. При распространении справки придется копировать и папку с фильмами. Фильмы при этом доступны для просмотра вне справки. Вот сам HTML код для этой анимации.

  <p align="center">
  <object
    ID="UVScreenCameraPlayer Control"
    Classid="CLSID:389E738A-8484-46BD-BA5E-52F089CFF98F"
    width=277 height=263>
    <param name="ShowPanel" value="0">
    <param name="Color" value="#E0E0E0">
    <param name="Background" value="Examples\WinAmp.gif">
    <param name="FileName" value="Examples\WinAmp.uvcab">
  </object>
  </p>

Теперь можно создавать GIF-анимацию, которую можно использовать в файлах chm


Воспроизведение записанного фильма

  • Скорость воспроизведения
  • Навигация по фильму

Скорость воспроизведения

Скорость воспроизведения можно менять чтобы:

  • подробнее (замедленно) просмотреть участок фильма.
  • быстрее промотать до нужного места.

Для того чтобы изменить скорость воспроизведения "на лету", передвиньте "движок" на нужную скорость воспроизведения.

Примечание:
Звук слышен только при скорости воспроизведения равной 1.

Навигация по фильму

С помощью кнопок навигации вы можете указать сегмент для воспроизведения:

  • Следующий сегмент
  • Предыдущий сегмент
  • Выбрать сегмент из списка

Примечание:
Выбор сегмента при воспроизведении можно осуществлять щелчком на линии прогресса. Сегменты разделены вертикальным штрихом.


Благодарности

Особая благодарность

  • Ермоловой Татьяне,
  • Дмитрию Логвинову,
  • Василию Чубинскому,
  • Владиславу Орлову,
  • Алексею Балашову,
  • Игорю Яровенко,
  • Александру Кожевникову,
  • Александру Бакланову,
  • Александру Морозову,
  • Сергею Дергачеву,
  • Павлу Сафре,
  • Михаилу Зайцеву,
  • Василию Кисель,
  • Проскурнину Юрию
за помощь, ценные замечания, поддержку, советы, конструктивную критику.


В следующей версии

После опроса о желательных доработках программы, в одной из следующих версий планируется добавить:

  • Стрелки под произвольным углом
  • Возможность указывать размеры кадра при экспорте (масштабирование или слежение за курсором)
  • Возможность менять FPS после записи фильма
  • Добавить эффекты (переходы) между кадрами
  • Добавить действие "Отмена"
  • Захват видео с двух мониторов
  • Добавить элемент размытие для скрытия информации в записанном видео
  • Запись окна виртуальной машины без черного квадрата вокруг курсора
  • Подробный видео мануал по работе с программой
  • Озвучивание щелчков мыши и нажатий на клавиатуре
  • Новые элементы в редактор видео: водяной знак, клип ...
  • Импорт файла субтитров (*.srt)
  • Возможность загружать отдельные кадры из файлов
  • Сохранять отдельные кадры из фильма в виде картинок
  • Импорт файлов AVI
  • Аудио-редактор


Непредвиденное использование

Для любой программы можно найти новое, оригинальное применение. Вот несколько примеров из отзывов пользователей UVScreenCamera (мои комментарии выделены курсивом):

  • Какая-то программа выводила на экран какое-то сообщение и тут же быстро закрывалась. И никак было не успеть прочитать. Пользователь записал этот момент с помощью UVScreenCamera и затем просмотрел. Было неудобно ловить паузой момент, когда окно еще видимо, поэтому он попросил сделать возможность покадрового просмотра.

    Не рассчитывал на такое применение UVScreenCamera. Но функция полезна, поэтому добавил возможность менять скорость воспроизведения, в т.ч. покадровый просмотр.

  • Идея моего коллеги программиста. Он установил заказчику UVScreenCamera и попросил, как только его программа будет делать не то, что от нее ожидают, отсылать ему файл с записью их действий.

    На такое применение я тоже не рассчитывал. Видно какие горячие клавиши были нажаты, и очень универсально. Прямо готовая система наблюдения за действиями пользователя для любой программы. Развитие этой идеи привело к появлению отдельной утилиты uvLog.


Полезные советы

  • Сохраняйте выноски - на всякий случай, для еще одного дубля, если потребуется.

  • Хотя в UVScreenCamera есть возможность записать весь фильм сразу, лучше всего записывать фильм по одному сегменту - подготовили выноски для этого сегмента, записали, сохранили сегмент на диск. Аналогично со следующим сегментом. Потом собрали все сегменты в один фильм и сохранили в формате uvf или exe.

  • При записи фильма двигайте мышь плавно, делая паузы перед нажатием кнопок или выбором из списка. Это облегчает восприятие при последующем просмотре.

  • Если во время записи вы забыли, что сейчас нужно показывать на экране, нажмите F10 (пауза), подумайте, и когда решили нажмите опять F10 для продолжения записи.


Порядок действий при записи фильма

  • Порядок действий
  • Количество кадров в секунду
  • Скрытие главной формы при записи
  • Запуск записи с задержкой
  • Запись 3D игр в avi

Порядок действий

В общем случае запись фильма происходит в следующем порядке:

  1. Составление плана того, что и как показывать
  2. Выбор области записи
  3. Запись фильма
  4. Добавление надписей, поясняющих выносок, картинок, звука и т.д. в редакторе
  5. Экспорт фильма в любой из доступных форматов

Примечание:
Если Вы планируете записывать фильм в три этапа (запись видео, добавление выносок, наложение звука), то во избежание потери синхронизации звука и видео, делать это нужно именно в таком порядке:

  1. Запись видео
  2. Добавление выносок
  3. Наложение звука

Количество кадров в секунду

В зависимости от возможностей Вашего компьютера, и видеокарты в частности, максимальное количество кадров в секунду, которое UVScreenCamera успеет запомнить, может очень сильно варьироваться. Если в вашем распоряжении мощный компьютер, быстрая видеокарта, вы можете снимать фильмы с частотой до 40 кадров в секунду. Получится очень гладкая анимация. Но не факт, что другой, менее мощный компьютер, потянет этот фильм на такой скорости. Параметр FPS ограничивает верхний предел скорости записи. Фактическая скорость записи может быть меньше. Как правило, 10 - 15 кадров в секунду вполне достаточно.

Рекомендуется выбирать значение FPS из списка, но можно вводить любое значение руками.

Скрытие главной формы при записи

При записи главная форма часто мешает, заслоняя часть экрана. Для того чтобы скрывать главную форму при записи, установите соответствующую галочку на главном окне.

При записи в трее (рядом с часами) появится иконка, щелчок мыши на которой останавливает запись.

Запуск записи с задержкой

Бывают случаи когда очень полезна задержка перед началом записи. Нажали кнопку Запись, пошел обратный отсчет "3, 2, 1, Запись".

За это время можно запустить нужные приложения, переключится в полноэкранный режим или еще что-нибудь. Можно сделать чтобы отсчет был не с 3, а с 5 или 10, кому как больше нравится. Для этого заходим в дополнительные настройки и выставляем нужную задержку.


Системные требования

Операционная система: Win 9x / Me / Nt / 2000 / XP / 2003 / Vista / Seven

При записи в формат UVScreenCamera:

Параметр | Минимальные требования
Процессор | Pentium 333 MMX
Память | 128 М
Видеопамять | 16 М

Основная нагрузка при записи фильма ложится на видеокарту. Аппаратная поддержка 2D операций будет очень кстати.

При записи 3D игр непосредственно в avi

Параметр | Минимальные требования
Процессор | Pentium 850 МГц
Память | 256 М
Видеопамять | 32 М
Винчестер | 7200 rpm


Уменьшаем объем файла

Для получения компактных файлов нужно запомнить несколько простых правил:

  • Не следует перетаскивать формы, диалоги по экрану. Если этого не избежать, старайтесь потратить на это меньше времени.

  • Старайтесь избегать длительной прокрутки больших (по размерам) списков.

  • Старайтесь, чтобы фон был однотонным (при записи не редко бывает виден рабочий стол с пестрой, красочной картинкой - это существенно повлияет на объем файла короткого фильма).

  • По возможности реже переключайтесь с одного окна на другое.

  • Желательно заменить анимированные курсоры на обычные.

  • Даже если "железо" вам позволяет, не стоит увеличивать частоту кадров более 15 кадр / сек.

  • Чем меньше разрешение экрана при записи, тем меньше объем файла (во многих случаях 800 х 600 вполне приемлемо)


Что такое uvScreenCamera?

Как нагляднее всего показать пользователю, на что способна ваша программа? Как быстрее обучить пользователей ее использовать? Лучше один раз увидеть. UVScreenCamera запоминает все, что происходит на экране, включая движения курсора мыши и звук, и сохраняет в очень компактный файл с расширением uvf или exe. Все, что нужно для записи фильма в простейшем случае это:

  1. Запустить UVScreenCamera
  2. Выполнить действия, которые должен увидеть пользователь при просмотре фильма
  3. Остановить UVScreenCamera
  4. Сохранить фильм в формате Microsoft AVI, Macromedia Flash (*.swf), EXE, UVF, GIF-анимация.

Для более наглядного представления информации на экране в редакторе можно добавить выноски, стрелки, картинки, затенения, звук.

Для быстрого поиска нужного фрагмента фильма его можно разбивать на именованные сегменты.

Фильмы, записанные с помощью UVScreenCamera, обладают следующими достоинствами:

  • Компактный размер - 40К...200К / 1 мин (или 5 мин ... 25 мин / 1 Мб) без звука.
  • Высокое качество при высоком разрешении (10 кадров/сек при 1024 x 768 x 32)
  • Умеренные требования к "железу"
  • Работает под Windows 9x / Me / NT / 2000 / XP / 2003 / Vista / Seven

Запись фильма в UVScreenCamera - интересный и легкий процесс. Вы сможете делать фильмы уже через 5 минут после начала работы с UVScreenCamera.

Запись фильма

Новые версии, дополнительную информацию, другие программы автора можно увидеть на сайте www.uvsoftium.ru

Замечания, пожелания, требования можно отправлять по адресу mail@uvsoftium.com


Что нового в этой версии

Покадровый редактор

Покадровый редактор видео

  • Доработана функция выделения кадров в редакторе
  • В составе программы идет новый uvPlayer с гладкой стыковкой сегментов при воспроизведении
  • Доработан элемент "кнопка" для создания интерактивных презентаций и обучающих уроков
  • Добавлен модуль экспорта в Exe, защищенный от копирования
  • Новый проигрыватель uvfPlayer (не путать с uvPlayer) позволяет внедрять в фильм кнопки, поддерживает субтитры (файлы *.srt) и внешние звуковые дорожки (*.mp3)
  • Доработана функция копирования-вставки кадров
  • Расширены возможности рисования на экране во время записи - можно рисовать линии, прямоугольники, эллипсы, писать текст
  • Отсчет (задержка) 3, 2, 1 перед записью
  • В редакторе добавлен элемент "Увеличение области"

Примечание:
Часть новых возможностей работает только в зарегистрированной версии

Исправлено:

  1. Исправлена серьезная ошибка, связанная с копированием-вставкой кадров

В этой версии исправлены найденные ошибки, оставлены не найденные и добавлены новые. Так что если что не так - пишите на mail@uvsoftium.com.