Основы информатики

КОНТРОЛЬНАЯ РАБОТА

MS WORD

Контрольная работа по MS Word (для всех)

MS EXCEL

Контрольная работа по MS Excel (для всех)

Контрольная работа по MS Excel (по вариантам)


Документ1

Ввод и редактирование текста, работа с блоками, форматирование абзацев, списки

Упражнение 1
Работа со шрифтами, копирование блока текста

  1. Наберите следующее предложение “Я изучаю Microsoft Word успешно”, скопируйте его пять раз и оформите различными шрифтами, как предложено ниже.

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Упражнение 2
Форматирование абзацев

Форматирование абзацев осуществляется при помощи меню Формат\Абзац, а также при помощи кнопок форматирования(по левому, правому краям, по центру, по ширине листа). Предварительно необходимо выделить форматируемый абзац.

Оформите текст следующим образом, используя кнопки форматирования:

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно.

Красная строка оформляется одним из следующих способов (предварительно надо выделить абзац(ы)):

  • при помощи меню Формат\Абзац установить параметры “Первая строка”;

  • схватить верхний бегунок на горизонтальной линейке и, не отпуская, перетащить на нужное место.

Оформите следующий текст, используя оба способа. Красную строку установите — 1,5 см.

Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно.

Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно. Я изучаю Microsoft Word успешно.

Упражнение 3
Использование списков

Список форматируется как до ввода элементов, так и для набранных в виде отдельных абзацев элементов.

Существует несколько различных способов форматирования списков:

  • Формат\Список;

  • Контекстное_меню\Список;

  • С помощью кнопок панели инструментов "Форматирование": Нумерация и список.

Сформируйте список вашей подгруппы и оформите его в виде списка. Для оформления многоуровневого списка используйте один из следующих вариантов:

  • комбинацию клавиш Alt+Shift+стрелки влево или вправо (клавиши управления курсором), предварительно установив курсор в нужную строку,

  • предварительно выделив нужную строку, вызовите контекстное меню и выберите нужную команду (понизить уровень или повысить уровень).

Нумерованный список | Маркированный список | Многоуровневый список
1. Иванов 2. Петров 3. Сидоров 4. и т.д. | · Иванов · Петров · Сидоров · и т.д. | 1. Мужской пол 1.1. Иванов 1.2. Петров 2. Женский пол 2.1. Петрова 2.2. Калинина

Работа с таблицами. Вычисления в таблицах. Встроенные функции в Word

Упражнение 4
Создание таблиц

Создайте следующую таблицу (если имеются навыки работы с клавиатурой, необязательно вводить текст во все ячейки).

Сведения об обеспечении образовательного процесса

учебной литературой в учебном центре ТОО “MaксСофт”

№ П/П | Наименование предмета (курса, дисциплиы , учебного плана) по годам обучения | Число обучающихся, воспитанников, изучающих предмет (курс, дисциплину) | Обеспечение обучающихся, воспитанников, литературой, указанной в учебной программе предмета(курса), в качестве обязательной
 |  |  | Перечень литературы (автор, название, год и место издания) | Число экземпляров
1 | 2 | 3 | 4 | 5
1 | Курсы для пользователей | 1000 | Алексей Бабий. Компьютер куплен. Что дальше? | 1000
2 | Курсы для программистов | 10 | Фирменная документация | 1

Технология выполнения:

  1. Выбрать в меню пункт Таблица\Вставить_таблицу. Указать число строк и столбцов по 5.

Или

  1. Создать таблицу, используя пиктограмму Таблица на панели инструментов: щелкнуть на ней мышью и, не отпуская кнопку мыши, протащить ее вниз и вправо до нужного числа столбцов и строк.

  2. Для изменения ширины ячейки используйте меню Таблица\Высота и ширина ячейки (предварительно выделив нужные ячейки) или изменяйте ширину мышью: установить курсор мыши на линию границы между ячейками, появится двойная стрелка, ухватите мышью и тащите в нужном направлении.

  3. Текст в верхней правой ячейке (“Обеспечение обучающихся...”) идет по длине двух ячеек. Для оформления этих ячеек выполнить следующее: выделить две ячейки (четвертую и пятую). Выполнить пункт меню Таблица\Объединить_ячейкилибо через контекстное меню "Объеденить ячейки".

Примечание: При создании таблицы число столбцов и строк рекомендуется брать по максимуму.

  4. Для оформления верхних трех левых ячеек выделить сначала в первом столбце две строки и выполнить команду Таблица\Объединить_ячейки. Далее выполнить те же действия для второго и третьего столбцов.

  5. Проведите разделительные: а) для этого надо сначала выделить таблицу или ее участки (если это необходимо); б) далее использовать меню Формат\Границы и Заливка или использовать пиктограмму Границы.

  6. Установите размер шрифта 10 в таблице: для этого первоначально выделите ее (можно выделить, используя меню Таблица\Выделить_таблицу. Курсор перед выделением должен находиться внутри таблицы). Далее установите размер шрифта.

  7. Введите текст.

Упражнение 5
Вычисления в таблицах

Таблица может содержать максимум 31 столбец и произвольное число строк. Ячейки таблицы имеют адреса, образованные именем столбца (А, В, С...) и номером строки (1, 2, 3...), например, А1, С4 и т.д.

Word позволяет выполнять вычисления, записывая в отдельные ячейки таблицы формулы с помощью команды Таблица\Формула... Формула задается как выражение, в котором использованы:

  • абсолютные ссылки на ячейки таблицы в виде списка (разделяемые знаком “ ; ” — А1; В5; Е10 и т.д.) или блока (начало и конец блока ячеек — А1:А10);

  • ключевые слова для ссылки на блок ячеек:

  • LEFT — ячейки, расположенные в строке левее ячейки с формулой;

  • RIGHT — ячейки, расположенные в строке правее ячейки с формулой;

  • ABOVE — ячейки, расположенные в столбце выше ячейки с формулой;

  • BELOW — ячейки, расположенные в столбце ниже ячейки с формулой;

  • константы — числа, текст в двойных кавычках;

  • закладки, которым соответствует определенный текст документа (например, числа), созданный с помощью команды Правка\Закладка;

  • встроенные функции Word, например, SUM(), AVERAGE().

  • знаки операции (+, , *, /, %, ^, =, <, >, <=, >=).

В данной таблице произвести вычисления успеваемости студентов:

Сведения об успеваемости студентов юридического факультета за 2005-06 учебный год
 | Учебная дисциплина | Группа | Средний балл | Всего сдавало | Отл. | Хор. | Удовл. | Неудовл. | Неявки
 | Высшая математика |  |  |  |  |  |  |  |
1 |  | 51 |  | ячейка Е4 | 12 | 10 | 6 | 3 | 1
2 |  | 52 |  |  | 7 | 9 | 6 | 3 | 2
3 |  | 53 |  |  | 9 | 8 | 3 | 5 | 3
4 |  | 54 |  |  | 8 | 8 | 8 | 3 | 2
 | Итого: |  |  |  |  |  |  |  |

Технология выполнения:

  1. Ввести формулы для расчета числа студентов каждой группы, сдавших экзамен по дисциплине “Высшая математика”. Для этого установить курсор в ячейку Е4 и ввести формулу: SUM(RIGHT), предварительно убрав имеющуюся в ней запись. Ввести формулу надо, используя меню Таблица\Формула...

  2. Произвести те же действия для ячеек Е5-Е7.

  3. Ввести формулу для расчетов среднего балла по дисциплине “Высшая математика” для группы 51. Для этого установить курсор в ячейку D4 и ввести формулу: =(f4*5+g4*4+h4*3+i4*2)/e4. Выберите формат числа 0,00.

  4. Ввести аналогичные формулы в ячейки D5-D7.

  5. Ввести формулу для расчета общего числа студентов, сдавших экзамен по каждой дисциплине на отлично, хорошо и т.д. Для этого установить курсор в ячейку f8 и ввести формулу: SUM(ABOVE), затем аналогично в ячейку g8 и т.д.

Упражнение 6
Использование табуляторов

Создать следующую ведомость, используя табуляторы. В конце каждой строки для перехода на новую строку нажимать клавишу Enter.

Стипендиальная ведомость

№группы Фамилия, и.,о. Стипендия, руб. Подпись

56 Козлова И.М. 100

56 Петрова И.И. 120

57 Сидорова Н.Н. 100

57 Черникова Л.П. 130

58 Марков О.Л. 100

  1. С помощью горизонтальной линейки задайте форматы табуляторов для абзаца с заголовками колонок. Для этого выберите тип табуляторов на линейке: 2,5 см, 7 см, 11 см, 14 см.

  2. Ввести заголовки колонок.

  3. С помощью команды Формат\Табуляция для абзацев списка задать форматы табуляторов:

  • 2,5 см — выравнивание влево, заполнитель — линия (2);

  • 7 см — выравнивание влево, заполнитель — линия (2);

  • 11 см — выравнивание влево, заполнитель — линия (2);

  • 14 см — выравнивание вправо, заполнитель — линия (4).

  4. Ввести текст, используя клавишу Tab для перемещения к следующей позиции.

5. Преобразовать данные колонки в таблицу. Для этого выделить их. Выполнить команду Таблица\Преобразовать_в_таблицу.

Примечание. Аналогично можно преобразовать в таблицу текст, оформленный в виде колонок.

№ группы | Фамилия, и.,о. | Стипендия, руб. | Подпись
56 | Козлова И.М. | 100 |
56 | Петрова И.И. | 120 |
57 | Сидорова Н.Н. | 100 |
57 | Черникова Л.П. | 130 |
58 | Марков О.Л. | 100 |

Работа с графикой. Создание графических объектов с использованием панели инструментов «Рисование»

Упражнение 7
Создать рисунок, используя операции копирования и переноса

  1. Активизировать панель Рисование, если ее нет на экране. Для этого выбрать п. меню Вид\Панель_инструментов...

  2. Сначала нарисовать прямоугольник, скопировать его несколько раз, затем редактировать цвет и заливку, используя соответствующие инструменты на панели инструментов Рисование (прямоугольник, цвет линии, цвет заливки).

  3. Для нужного расположения объектов использовать инструмент Действия\Порядок.

  4. Сгруппировать все объекты. Для этого выделить их все: щелкать мышью на линии незакрашенных прямоугольников и на сами закрашенные прямоугольники, удерживая нажатой клавишу Shift, затем использовать инструмент Действия\Группировать.

Упражнение 8
Выполнить надпись, используя инструменты Автофигуры\Выноски

Упражнение 9
Создать рисунок, скопировать его, отредактировать расположение объектов

Работа с приложением MS Equation

Упражнение 10
Использование Редактора формул

Набрать математические выражения, входящие в тексты заданий:

  1. Запустите редактор формул (Вставка\Объект\Microsoft_Equation 3.0).

  2. Для набора формул используйте панель инструментов (скобки, дроби, умножение).

  3. Если текст задания вы хотите набрать, находясь в редакторе формул, то выберите команду Стиль\Текст.

  4. Для рисования фигурной скобки выделите обе строки, затем на панели инструментов “скобки” выберите левую фигурную скобку.

  5. Возвращение в Документ происходит щелчком мышью вне окна Microsoft Equation.

  6. Для редактирования набранной формулы (если необходимо после вставки внести изменения) используется двойной щелчок мыши.

В. Формула косинуса суммы (для набора греческих букв воспользуйтесь кнопкой [image] )


Документ1

Упражнение 1
Основные приемы работы с ЭТ: ввод данных в ячейку, форматирование шрифта, автозаполнение, ввод формул, обрамление таблицы

Выполнить это упражнение на примере таблицы, вычисляющей n-й член и сумму арифметической прогрессии.

Формула n-го члена арифметической прогрессии: , где a1 — первый член прогрессии, d — разность арифметической прогрессии. Формула суммы n первых членов арифметической прогрессии: .

  1. Создать новый документ (новую книгу), используя кнопку Создать на стандартной панели инструментов или использовать меню Файл\Создать, выбрать вкладку Общие.

Составить таблицу,

 | A | B | C | D
1 | Вычисление n-го члена и суммы арифметической прогрессии
2 |
3 | d | n | an |  | Sn
4 | -0,725 | 1 | 2 |  | 2
5 | -0,725 | 2 | 1,275 |  | 3,275
6 | -0,725 | 3 | 0,55 |  | 3,825
7 | -0,725 | 4 | 0,175 |  | 3,65
8 | -0,725 | 5 | 0,9 |  | 2,75
9 | -0,725 | 6 | 1,625 |  | 1,125
10 | -0,725 | 7 | 2,35 |  | 2,225
11 | -0,725 | 8 | 3,075 |  | 4,3
12 | -0,725 | 9 | 3,8 |  | 8,1
13 | -0,725 | 10 | 4,525 |  | 12,625

  2. Выделить ячейку А1 (щелкнуть курсором мыши в нее) и ввести заголовок таблицы “Вычисление n-го члена и суммы арифметической прогрессии”. Заголовок займет несколько ячеек правее А1. Введенные в ячейку данные фиксировать нажатием на клавишу выполнения (Enter).

  3. Оформить строку заголовков столбцов. В ячейку А3 введите d, в В3 — n, в С3 — an, в D3 — Sn. Размер шрифта 11 пт, выравнивание по центру, применить полужирный стиль начертания символов. Для набора нижних индексов воспользоваться командой Формат\Ячейки, выбрать вкладку Шрифт\Нижний_индекс.

  4. Оформить заголовок таблицы. Выделить ячейки А1:D2, применить полужирное начертание символов и выполнить команду Формат\Ячейки, вкладка Выравнивание — установить выравнивание по горизонтали «По центру», активизировать переключатели «Переносить по словам» и «Объединение ячеек».

  5. В ячейку А4 ввести величину разности арифметической прогрессии.

  6. Далее надо заполнить ряд нижних ячеек. Для этого в выделенной ячейке А4 установить курсор мыши в правый нижний угол ячейки. Когда курсор примет форму черного крестика (маркер заполнения), нажать на левую кнопку мыши и протянуть маркер заполнения на несколько ячеек вниз. Весь ряд заполнится данными, как в ячейке А4.

  7. В следующем столбце необходимо ввести последовательность чисел от 1 до 10. Для этого ввести в ячейку В4 число 1, в ячейку В5 число 2, выделите обе ячейки и, взявшись за маркер заполнения, протянуть его вниз.

  8. Или: Ввести в ячейку В4 число 1. Выделить блок, который надо заполнить. Выбрать команду Правка\Заполнить\Прогрессия. Выбрать необходимые параметры.

  9. В третьем столбце в ячейку С4 ввести значение первого члена арифметической прогрессии.

  10. В остальные нижние ячейки надо ввести формулу n-го члена арифметической прогрессии. Выделить ячейку С5 и введите в нее формулу =С4+А4 (все формулы начинаются со знака равенства!). Можно не набирать адреса ячеек при вводе формул, а просто в тот момент, когда надо в формуле набрать адрес ячейки, щелкнуть именно в эту ячейку.

  11. Скопировать данную формулу в нижние строки данного столбца.

  12. В данном примере разность арифметической прогрессии необязательно писать во всех строках, т.к. она везде одинакова. Достаточно ввести ее в ячейку А4. Тогда при вводе формулы в ячейку С5 необходимо применить абсолютную ссылку на ячейку А4. Внесите эти изменения.

  13. Занести в ячейку D4 формулу суммы n первых членов арифметической прогрессии с учетом адресов ячеек =(C$4+С4)*B4/2. Заполните формулами нижние столбцы.

  14. Выделить блок — ячейки с данными (кроме заголовков таблицы и столбцов) и установить необходимые параметры для шрифта, например, размер шрифта 11 пт, выровнять вправо, используя меню Формат\Ячейки, вкладки Выравнивание и Шрифт. Если какие-то данные в ячейках не помещаются, необходимо выделить блок ячеек с данными и выполнить автоподбор ширины ячеек через меню Формат\Столбец... \Автоподбор_ширины.

  15. Если выбрать команду Файл\Просмотр, то наша таблица окажется необрамленной. Для обрамления выделить таблицу (без заголовка), выбрать стиль линии (Формат\Ячейки... вкладка Рамка) и активизировать переключатели Сверху, Снизу, Слева, Справа.

  16. Выполнить те же действия для обрамления заголовка, предварительно выделив блок ячеек заголовка.

Нахождение наибольшего и наименьшего элементов в числовой таблице

Например, имеется таблица:

 | A | B | C | D
1 | 12 | 14,5 | 23 | 42
2 | 36 | 17 | 9 | 3,76
3 | 64 | 39 | 25 | 1
4 |  |  |  |

  1. Создать новую рабочую книгу.

  2. Внести элементы данной таблицы в ячейки.

  3. Установить курсор в ячейку C4, ввести запись «максимальное».

  4. Перейти в ячейку D4, выполнить команду Вставка\Функция или щелкнуть на кнопку Вставка_Функции на панели инструментов.

  5. В появившемся диалогом окне выбрать функции Статистические\МАКС.

  6. В следующем диалогом окне необходимо в строке Число1 ввести диапазон A1:D3. Для этого выделить его в таблице.

  7. Аналогично пунктам 3 и 4 выполнить действия по нахождению минимального в строке 5.

  8. Переименовать лист. Для этого выполнить команду Формат\Лист\Переименовать или выполнить двойной щелчок внизу на вкладке Лист1. Ввести имя МаксМин.

Упражнение 2
Построение диаграммы

  1. Перейти на Лист2.

  2. Протабулировать функцию [image] на отрезке [-5, 5] с шагом 1. Найти промежутки перемены знака значений функции. Определить корни уравнения.

Должна получиться следующая таблица:

 | A | B
1 | Х | У
2 | -5 | 64
3 | -4 | 42
4 | -3 | 24
5 | -2 | 10
6 | -1 | 0
7 | 0 | 6
8 | 1 | 8
9 | 2 | 6
10 | 3 | 0
11 | 4 | 10
12 | 5 | 24

  3. Построить график функции на данном интервале. Для этого выполнить команду Вставка\Диаграмма\На_этом_листе или щелкнуть на панели инструментов кнопку Мастер_диаграмм. Далее выполнять шаги:

  4. Шаг 1: Во вкладке Стандартные выберите тип График и выберите нужный вид

  5. Шаг 2: При активной вкладке Диапазон_данных выделить диапазон значений функции в таблице вместе с заголовком A1:B12. При активной вкладке Ряд в строке Подписи_оси_X активизировать курсор, затем выделить диапазон данных в таблице A2:A12.

  6. Шаг 3: Самостоятельно изучите все вкладки на этом этапе.

  7. Шаг 4: Указать местоположение полученной диаграммы: на новом листе или на этом.

  8. Измените цвет и толщину линии графика. Для этого подведите курсор мыши к линии графика и выполните двойной щелчок мышью. В появившемся окне Форматирование_ряда_данных выберите другой цвет и другую толщину линии, активизировав вкладку Вид.

  9. Выполнив двойной щелчок мыши на линиях осей, измените цвет в появившемся диалоговом окне Форматирование осей.

  10. Дайте имя Листу2 «Функция» или «График».

Упражнение 3
Условия в электронных таблицах

Вычислить значения функции в зависимости от значений аргумента на интервале [-5, 5] с шагом 1.

 | A | B
1 | X | У
2 | -5 | =ЕСЛИ(А2<0;А2*А2-4;А5+5)
3 | -4 |
4 | -3 |
5 | -2 |
6 | -1 |
7 | 0 |
8 | 1 |
9 | 2 |
10 | 3 |
11 | 4 |
12 | 5 |

  1. Перейти на Лист2.

  2. В ячейки столбца, озаглавленного буквой Х, внести значения от -5 до 5 с шагом 1.

  3. Прочитать справку в Excel о логических функциях. Для этого выбрать в меню Excel ?\Вызов_справки. Во вкладке Предметный_указатель в строке поиска ввести текст логические функции.

  4. В первую строку значений У ввести логическую функцию Если, используя Мастер функций.

  5. Скопировать формулу в нижние ячейки.

  6. Построить график. Определить, при каких значениях Х функция У принимает значение ноль.

Решение квадратного уравнения

Решить квадратное уравнение y = ax2 + bx + c, используя ЭТ. Оформить заголовок. Выполнить решение для нескольких наборов коэффициентов:

1) а=2 в=3, с=2; 2) а=2 в=4, с=6; 3) а=3 в=1, с=1.

Структурирование и отбор данных в ЭТ

Упражнение 4
Сортировка (упорядочение) записей списка

Рассмотрим заданную таблицу «Учет товаров на складе», представленную ниже.

Прокомментируем эту таблицу. Таблица имеет вид базы данных, состоящей из записей продажи товаров со склада. Запись указывает, какой организации продан товар, когда проведена продажа, единицу измерения товара, его стоимость и количество. В столбцах Дебет и Кредит заносится стоимость покупки и долг перед организацией, т.е. Цена*Кол-во. В последнем столбце указывается форма оплаты: безналичный расчет (б/р), бартер (бар), наличный расчет (н/р).

Для дальнейшей работы создать эту таблицу в Excel на Лист1и сохранить ее в виде отдельного файла.

 | A | B | C | D | E | F | G | H | I | J
1 | Организация | Дата | Товар | Ед.изм. | Цена | Кол-во1 | Дебет | Кол-во2 | Кредит | Ф.опл.
2 | АО “Альянс” | 1 Янв | соль | кг | 15000 | 550 | 8250000 |  |  | б/р
3 | ФОЗТ “Белокуриха” | 1 Янв | сахар | кг | 16000 | 200 | 3200000 |  |  | б/р
4 | ФОЗТ “Белокуриха” | 3 Янв | хлеб | бул | 700 |  | 0 | 900 | 630000 | бар
5 | Бийск.маслосырз-д | 3 Июн | сода | пач | 5500 | 300 | 1650000 |  |  | б/р
6 | ФОЗТ “Белокуриха” | 4 Янв | сок | бан | 56 | 26000 | 1456000 |  |  | б/р
7 | к/з “ЗАРЯ” | 4 Янв | пиломт | метр |  |  | 0 |  |  | б/р
8 | АО “Альянс” | 13 Янв | лимоны | кг | 4000 | 50 | 200000 |  |  | б/р
9 | АО “Альянс” | 3 Фев | компьют | шт | 250000 | 2 | 5000000 |  |  | б/р
10 | ФОЗТ “Белокуриха” | 12 Фев | хлеб | бул | 700 |  | 0 | 500 | 350000 | б/р
11 | Бийск.маслосырз-д | 12 Фев | бензин | л | 450 |  | 0 | 6048 | 2721600 | н/р
12 | ФОЗТ “Белокуриха” | 2 Мар | сода | пач | 3000 | 215 | 645000 |  |  | б/р
13 | к/з “ВОСТОК” | 2 Мар | апельсин | кг | 4000 | 100 | 400000 |  |  | б/р
14 | к/з “ЗАРЯ” | 5 Мар | апельсин | кг | 2300 | 124 | 285200 |  |  | н/р
15 | к/з “ЛУЧ” | 4 Апр | апельсин | кг | 5000 |  | 0 | 50 | 250000 | б/р
16 | к/з “ЗАРЯ” | 6 Апр | мука | кг | 20000 | 1000 | 2000000 |  |  | н/р
17 | к/з “ВОСТОК” | 6 Май | сахар | кг | 16000 | 50 | 800000 |  |  | б/р
18 | к/з “ВОСТОК” | 13 Июн | лимоны | кг | 6000 |  | 0 | 50 | 300000 | б/р
19 | к/з “ВОСТОК” | 13 Июн | хлеб | бул | 700 | 300 | 210000 |  |  | б/р

  1. Для упорядочения записей необходимо определить, по каким полям вы хотите отсортировать таблицу. Например, необходимо отсортировать наименования организаций в алфавитном порядке, внутри каждой организации наименование товара в алфавитном порядке и внутри каждого наименования товара отсортировать по возрастанию количество проданного товара.

  2. Курсор установить в область таблицы, выполнить команду Данные\Сортировка. В первом уровне сортировки выбрать поле Организация, во втором — Товар, в третьем — Кол-во1.

  3. Просмотреть результаты сортировки.

Фильтрация (выборка) записей списка

Автофильтр:

  1. Скопируйте таблицу с Листа1на Лист2 и назовите новый лист Автофильтр.

  2. Допустим, нам необходимо выбрать из заданного списка только те строки, где есть запись АОЗТ «Белокуриха». Выполнить команду Данные\Фильтр\Автофильтр.

  3. В строке заголовка таблицы появились значки падающего меню. (Чтобы их убрать, необходимо выполнить ту же команду, по которой их вызывали.)

  4. Щелкнуть на значок в столбце Организация и выбрать АОЗТ «Белокуриха». Появились только те записи, где присутствует указанная организация. Чтобы вернуть все записи, надо опять щелкнуть на значок и выбрать строку Все.

  5. Вывести на экран записи, содержащие организацию АОЗТ «Белокуриха», где в столбце «Товар» присутствует «хлеб», т.е. осуществить выборку по двум полям. Вернуть все записи.

  6. Вывести на экран записи, содержащие организацию АОЗТ «Белокуриха», в которых и цена товара не превышает 16000. Для выборки по столбцу «Цена» при открытии меню выбрать строку Условие. В появившемся окне Пользовательский_автофильтр при помощи значков открывающегося меню установить условие <16000 в верхней строке. Вернуть все записи.

  7. Вывести на экран записи, содержащие колхоз «Восток» и дату покупки товара в промежутке после 2 марта до 13 июня. В данном случае в окне Пользовательский_автофильтр заполнить обе строки. Правильно выбрать соединение условий И или ИЛИ. Вернуть все записи.

  8. Вывести на экран записи, содержащие колхоз «Восток», а в поле Цена больше 700, но меньше 16000. Вернуть все записи.

Расширенный фильтр:

Прочитать встроенную справку Excel Фильтры\Расширенные: Примеры условий отбора расширенного фильтра.

  1. Скопируйте таблицу с Листа1 на Лист3 и дайте имя листу Расширенный фильтр.

  2. Выполнить задание п.5 из предыдущего упражнения, воспользовавшись командой Расширенный_фильтр.

  3. Ниже таблицы, оставив пустые 2-3 строки, скопировать строку заголовка таблицы, например, в строку 23. В строке 24 сформировать критерий отбора записей. В столбец Организация ввести АОЗТ «Белокуриха», в столбец Товар — «хлеб».

  4. Далее выполнить команду Данные\Фильтр\Расширенный_фильтр. В появившемся диалогом окне ввести исходный диапазон, из которого будет проводиться выборка. Для этого щелкнуть в данное окно, затем перейти в область таблицы и выделите необходимый диапазон A1:J19. Аналогично ввести диапазон критериев, например, A26:J35.

  5. Для того, чтобы новые данные печатались в другом месте, необходимо активизировать кнопку Скопировать результат в другое место и также указать диапазон, куда будут выводиться отсортированные данные.

Начиная со строки 26 и ниже расположен результат выполнения расширенного фильтра.

  6. Выполнить задание п.6 из предыдущего упражнения. В данном случае для выборки товаров, стоимость которых не превышает 16000, в диапазоне критериев введите "<16000".

Примечание: алгоритм выполнении расширенного списка можно прочитать в справке Excel Фильтры\Расширенные: Фильтрация списка с помощью расширенного фильтра.


РЕШЕНИЕ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ

  1. Решение задач линейного программирования с помощью MS Excel (теория)
    • Решение задач линейного программирования. Контрольная работа

  2. Транспортная задача (теория)
    • Транспортная задача. Контрольная работа


Профильный курс. Методические материалы.

7. Транспортная задача

Введение

У некого предпринимателя, занимающегося производством и продажей холодильников, есть две фабрики, которые снабжают три его магазина. В начале месяца он получает от директора каждого из магазинов заявку на определенное число холодильников, в которых данный магазин нуждается в текущем месяце. Совокупность всех таких заявок позволяет установить общее число новых холодильников, которые нужно изготовить на этих двух фабриках. Для простоты мы предположим, что у предпринимателя достаточно ресурсов (рабочей силы, сырья и т. д.), чтобы выполнить все заявки, и что в данный момент отсутствует задел для продажи. Пусть первому магазину, обозначим его S1, требуется 10 холодильников, магазину S2 - 8 и магазину S3 - 7, всего, таким образом, 25 холодильников. Пусть предприниматель решил изготовить 11 холодильников на первой фабрике F1 и оставшиеся 14 на фабрике F2. Задача состоит в том, чтобы выяснить, сколько холодильников нужно отправить с каждой фабрики в каждый магазин, чтобы общая стоимость всех перевозок была минимальной.
Основная форма этой задачи, известной под названием транспортной задачи, представляет собой одну из самых ранних и наиболее широко используемых формулировок линейного программирования.

Решение

Нам нужна дополнительная информация относительно транспортных ограничений и цен. Предположим, что можно отправить любое число холодильников с каждой фабрики в любой магазин, то есть что имеются транспортные пути (железные дороги, шоссе и т. п.), связывающие каждую фабрику со всеми магазинами. Предположим далее, что нам известна также стоимость перевозки одного холодильника с фабрики в магазин в каждом случае. Здесь мы должны принять допущение относительно линейности, которое в некоторых случаях весьма спорно и может вызвать критику. Предположение о линейности, или пропорциональности, состоит в том, что если стоимость перевозки одного холодильника из F1 в S1 составляет 10 долларов, то стоимость перевозки двух холодильников составляет 20 долларов, трех - 30 долларов и т. д. Против подобного допущения можно было бы возразить, основываясь на реальном опыте. Если нанять грузовик для перевозки одного холодильника стоит 100 долларов, то в случае двух холодильников стоимость перевозки каждого составит 50 долларов (не считая стоимости погрузочно-разгрузочных работ), в случае трех - 33 [image] доллара, то есть стоимость меняется нелинейно.

В большинстве транспортных ситуаций стоимость нелинейна, но с помощью того или иного усреднения можно получить хорошее линейное приближение.

Итак, в нашей задаче мы предполагаем, что стоимость перевозки холодильника между любой фабрикой и любым магазином известна (см. табл. 1) и линейна. Транспортные задачи имеют, как и любая задача оптимизации, много допустимых решений.

Мы ищем решение, которое удовлетворяет принятым ограничениям (11 холодильников должны быть отправлены из F1, 14 холодильников-из F2, S1 получает 10, S2 - 8 и S3 - 7 холодильников) и одновременно минимизирует меру эффективности - общую стоимость всех перевозок.

Чтобы дать математическую постановку задачи, мы сведем всю информацию в две таблицы:

 |  | S1 | S2 | S3 |  |  | S1 | S2 | S3
 |  | 10 | 8 | 7 |  |  | 10 | 8 | 7
F1 | 11 | $8 | $6 | $10 | F1 | 11 | ? | ? | ?
F2 | 14 | $9 | $5 | $7 | F2 | 14 | ? | ? | ?
Таблица 1 |  |  |  |  | Таблица 2

В таблице 1 заданы стоимости перевозок, а в таблице 2 клетки со знаком ? соответствуют неизвестному числу холодильников, которые нужно перевезти с данной фабрики в определенный магазин. В дальнейшем в подобных таблицах будем опускать первую строку и первый столбец.

Приведем два допустимых решения этой задачи:

 | 10 | 8 | 7 |  | 10 | 8 | 7
11 | 10 | 1 | 0 | 11 | 0 | 7 | 4
14 | 0 | 7 | 7 | 14 | 10 | 1 | 3
Решение 1 |  |  |  | Решение 2

Можно попытаться найти и другие решения самостоятельно.
Числа, стоящие в белых ячейках первой таблицы, соответствуют решению задачи, при котором из F1 в магазины отправлено 10+1+0=11 холодильников, а из F2, 0+7+7==14 холодильников. Общее число холодильников, полученных магазином S1 с обеих фабрик, равно 10+0=10, магазином S2 1+7=8 и S3 0+7 = 7 холодильников. Второй вариант решения аналогичен. В предположении, что стоимость перевозок линейна, мы получим, что общая стоимость в первом случае равна 8·10+6·1+5·7+7·7=170 (долларов), а во втором случае 6·7+10·4+9·10+5·1+7·3=198 (долларов).
Таким образом, в первом случае затраты на перевозку холодильников меньше, чем во втором, однако не ясно, нет ли другого допустимого решения, позволяющего еще больше снизить затраты на перевозку. Методы линейного программирования позволяют утверждать, что минимум существует и его можно найти. В нашей задаче минимум затрат на перевозку холодильников достигается в первом решении.
Для построения математической модели транспортной задачи необходимо ввести некоторые математические сокращения. Пусть x11 означает число (пока еще не известное) холодильников, отправленных из F1 в S1, x12-число холодильников, отправленных из F1 в S2, и т. д. В общем случае хij - это число холодильников, отправленных с фабрики Fi в магазин Sj,. Введем эти обозначения в нашу таблицу:

 | 10 | 8 | 7
11 | x11 | x12 | x13
14 | x21 | x22 | x23

Теперь очень просто построить математическую модель. Из F1 отправлено x11, x12 и x13 холодильников, всего 11 штук. Аналогично из F2 отправлено x21, x22 и x23 холодильников, всего 14 штук. Поскольку требуется всего 25 холодильников (10+8+7) и произведено их ровно 25 (11+14), то все холодильники с каждой фабрики должны быть отправлены в магазины. Таким образом, общее число холодильников, отправленных из F1, дается уравнением x11+x12+x13=11, а из F2 - x21+x22+x23=14. Эти суммы получаются путем сложения по строкам чисел, стоящих в таблице.
Поскольку каждый магазин получает столько холодильников, сколько заказывает, то общее количество холодильников, полученное каждым магазином (оно находится суммированием по столбцам), задается уравнениями
x11+x21=10 для S1,
x12+x22=8 для S2,
x13+x23=7 для S3.
Для каждого набора чисел xij где i снова означает номер фабрики, а j - номер магазина, общая стоимость перевозок равна
8x11+6x12+10x13+9x21+5x22+7x23 (долларов).
Эти уравнения представляют собой основные ограничения нашей математической модели. Единственное наше упущение состоит в том, что мы не ограничили xij так, чтобы они могли принимать только положительные и нулевые значения. Отрицательные xij, означали бы, что холодильники перевозятся из магазина на фабрику, то есть общее число холодильников больше того, которое произведено на фабриках. Мы исключаем такую возможность, вводя ограничения xij>=0 (xij больше или равно нулю). Поскольку мы хотим определить множество значений xij>=0, удовлетворяющих уравнениям и минимизирующих общую стоимость, то имеем следующую математическую модель - модель линейного программирования данной транспортной задачи:

Каждая фабрика и магазин порождают уравнение, связывающее между собой те переменные, которые относятся к данной фабрике или магазину. Эти уравнения, так же как и целевая функция, линейны, поскольку они представляют собой просто суммы переменных. Общее количество переменных равно произведению числа фабрик на число магазинов, в нашем случае 2·3=6. Аналогично число уравнений равно сумме числа фабрик и магазинов; в нашем случае оно равно 5. Транспортные задачи могут быть очень громоздкими, и здесь на помощь придет ЭВМ.
До сих пор молчаливо предполагалось, что xij должны быть целыми (мы не в состоянии перевезти [image] холодильника!). Можно строго показать, что если количество фабрик и магазинов выражается целыми числами, то и сама транспортная задача будет допускать оптимальное решение в целых числах. Разумеется, утверждать, что так будет всегда, в любой задаче линейного программирования, нельзя. Возможность решения транспортной задачи в целых числах обусловлена особой структурой уравнений соответствующей ей математической модели.
Нашу модель мы описывали на конкретном примере и поэтому вынуждены были говорить о фабриках, магазинах и холодильниках, однако эти детали не имеют значения. Все рассуждения остаются в силе и в более общем случае, если рассматривать пункты отправления (фабрики), пункты назначения (магазины) и однородные единицы, подлежащие перевозке (холодильники), а также некую меру, которую необходимо минимизировать (общая стоимость перевозок).

Пример

Заданы стоимости перевозок в у.е. одного комплекта товара (мебель) в таблице 1. Доставки осуществляет фирма "Айсберг" от 4 поставщиков товаров, которые расположены соответственно: в Архангельске, Кандалакше и Петрозаводске на 5 оптовых баз разных фирм, которые находятся в Мурманской области . Кроме того задано количество комплектов товаров (наличие - 15), которое может купить каждая фирма от поставщика. И потребность каждой оптовой базы в определенном количестве комплектов товара (потребность - 12), для обеспечения нормальной работы. За одну поездку можно перевезти один комплект товара. Определить оптимальный план работы фирмы "Айсберг".

 |  | Оптовая база 1 | Оптовая база 2 | Оптовая база 3 | Оптовая база 4 | Оптовая база 5
 |  | 12 | 12 | 12 | 12 | 12
Архангельск | 15 | 60 | 19 | 53 | 24 | 57
Кандалакша | 15 | 54 | 59 | 32 | 49 | 50
Петрозаводск | 15 | 48 | 45 | 49 | 52 | 46
Петрозаводск | 15 | 44 | 17 | 31 | 28 | 41

Решение:

  1. Составление математической модели
    Пусть cij - стоимости перевозок от i-ого поставщика j-ой оптовой базе, а xij - количество комплектов мебели, которые нужно перевезти от i-ого поставщика j-ой оптовой базе в оптимальном плане.
    Тогда математическая модель примет вид:
  2. Создание формы для ввода условий задачи. Для данной задачи создать форму для ввода как на рис 7.16. Весь текст на этом рисунке, выделенный серым, является комментариями, и на решение задачи не повлияет.
    A
    B
    C
    D
    E
    F
    G
    1
    Стоимость перевозок фирмы "Айсберг"
    2
    Оптовая база1
    Оптовая база2
    Оптовая база3
    Оптовая база4
    Оптовая база5
    Наличие
    3
             Поставщик 1
    60
    19
    53
    24
    57
    15
    4
             Поставщик 2
    54
    59
    32
    49
    50
    15
    5
             Поставщик 3
    48
    45
    49
    52
    46
    15
    6
             Поставщик 4
    44
    17
    31
    28
    41
    15
    7
             Потребность
    12
    12
    12
    12
    12
    8
    Фактические перевозки (оптимальное число перевозок)
    9
    Оптовая база1
    Оптовая база2
    Оптовая база3
    Оптовая база4
    Оптовая база5
    Наличие
    10
             Поставщик 1
    11
             Поставщик 2
    12
             Поставщик 3
    13
             Поставщик 4
    14
             Потребность
    15
    16
             Стоимость всех перевозок:
    17
             Направление:
    минимум
    Рис 7.16
  3. Ввод исходных данных. Ввести исходные данные в форму согласно условию задачи. Рис 7.16
  4. Ввод зависимостей из математической модели. Ввести зависимости из математической модели. В режиме представления формул это будет выглядеть как на рис 7.17
    A
    B
    C
    D
    E
    F
    G
    1
             Стоимость перевозок фирмы "Айсберг"
    2
    Оптовая база1
    Оптовая база2
    Оптовая база3
    Оптовая база4
    Оптовая база5
    Наличие
    3
             Поставщик 1
    60
    19
    53
    24
    57
    15
    4
             Поставщик 2
    54
    59
    32
    49
    50
    15
    5
             Поставщик 3
    48
    45
    49
    52
    46
    15
    6
             Поставщик 4
    44
    17
    31
    28
    41
    15
    7
             Потребность
    12
    12
    12
    12
    12
    8
    Фактические перевозки (оптимальное число перевозок)
    9
    Оптовая база1
    Оптовая база2
    Оптовая база3
    Оптовая база4
    Оптовая база5
    Наличие
    10
             Поставщик 1 =СУММ (B10:F10)
    11
             Поставщик 2 =СУММ (B11:F11)
    12
             Поставщик 3 =СУММ (B12:F12)
    13
             Поставщик 4 =СУММ (B13:F13)
    14
             Потребность =СУММ (B10:B13) =СУММ (C10:C13) =СУММ (D10:D13) =СУММ (E10:E13) =СУММ (F10:F13)
    15
             Стоимость всех перевозок: =СУММПРОИЗВ(B3:F6; B10:F13)
    16
             Направление:
    минимум
    Рис 7.17
  5. Назначение целевой функции, ввод ограничений и граничных условий. Вызвать диалоговое окно Поиск Решения: Сервис-Поиск решения… (рис 7.10)
    Назначить целевую функцию: $B$15; направление: Минимальному значению
    Ввести адреса искомых переменных: $B$10:$F$13
    Ввести ограничения, нажав кнопку Добавить. Появиться диалоговое окно Добавление ограничения (рис 7.11)
    Ввести граничные условия: $B$10:$F$13>=0
    Ввести ограничения: $G$3:$G$6=$G$10:$G$13; $B$7:$F$7=$B$14:$F$14
  6. Решение задачи
    После ввода данных вызвать диалоговое окно Параметры… (рис 7.12) Установить флажок линейная модель. ОК. Выполнить.
  7. Сформулировать выводы.


Профильный курс. Методические материалы.

Транспортная задача. Практическая работа

Для данной задачи (см Приложение) составить форму ввода, ввести исходные данные и зависимости из математической модели. Вызвать диалоговое окно Поиск решения, ввести адрес целевой функции, указать изменяемые ячейки, ввести ограничения и граничные условия. В диалоговом окне Параметры установить флажок Линейная модель. Запустить алгоритм поиска оптимального решения. По полученным результатам сформулировать вывод


Профильный курс. Методические материалы.

Транспортная задача. Варианты самостоятельных работ

Вариант 1
 | 7 | 7 | 7 | 7 | 2
4 | 16 | 30 | 17 | 10 | 16
6 | 30 | 27 | 26 | 9 | 3
10 | 13 | 4 | 22 | 3 | 1
10 | 3 | 1 | 5 | 4 | 24
Вариант 2
 | 19 | 19 | 19 | 19 | 4
20 | 15 | 1 | 22 | 19 | 1
20 | 21 | 18 | 11 | 4 | 3
20 | 26 | 29 | 23 | 26 | 24
20 | 21 | 10 | 3 | 19 | 27
Вариант 3
 | 11 | 11 | 11 | 11 | 16
15 | 17 | 20 | 29 | 26 | 25
15 | 3 | 4 | 5 | 15 | 24
15 | 19 | 2 | 22 | 4 | 13
15 | 20 | 27 | 1 | 17 | 19
Вариант 4
 | 12 | 12 | 12 | 12 | 12
13 | 20 | 26 | 24 | 26 | 29
17 | 15 | 20 | 29 | 26 | 23
17 | 4 | 10 | 27 | 30 | 7
13 | 9 | 16 | 29 | 20 | 3
Вариант 5
 | 8 | 8 | 8 | 8 | 28
18 | 21 | 22 | 2 | 13 | 7
12 | 27 | 10 | 4 | 24 | 9
17 | 3 | 16 | 25 | 5 | 4
13 | 28 | 11 | 17 | 10 | 29
Вариант 6
 | 9 | 24 | 9 | 9 | 9
15 | 10 | 17 | 9 | 20 | 30
15 | 13 | 4 | 24 | 26 | 26
19 | 22 | 24 | 30 | 27 | 29
11 | 25 | 12 | 11 | 24 | 23
Вариант 7
 | 15 | 15 | 15 | 15 | 20
21 | 30 | 24 | 11 | 12 | 25
19 | 26 | 4 | 29 | 20 | 24
15 | 27 | 14 | 14 | 10 | 18
25 | 6 | 14 | 28 | 8 | 2
Вариант 8
 | 8 | 9 | 13 | 8 | 12
9 | 5 | 15 | 3 | 6 | 10
11 | 23 | 8 | 13 | 27 | 12
14 | 30 | 1 | 5 | 24 | 25
16 | 8 | 26 | 7 | 28 | 9
Вариант 9
 | 7 | 7 | 7 | 7 | 42
22 | 9 | 17 | 29 | 28 | 8
13 | 13 | 21 | 27 | 16 | 29
17 | 20 | 30 | 24 | 7 | 26
18 | 11 | 19 | 30 | 6 | 2
Вариант 10
 | 6 | 6 | 13 | 20 | 15
16 | 30 | 2 | 5 | 6 | 15
15 | 5 | 29 | 9 | 5 | 7
14 | 16 | 24 | 14 | 6 | 26
15 | 13 | 28 | 4 | 25 | 8


Профильный курс. Методические материалы.

Решение задач линейного программирования с помощью MS Excel

Пример 1

Требуется определить, в каком количестве надо выпускать продукцию четырех типов Прод1, Прод2, Прод3, Прод4, для изготовления которой требуются ресурсы трех видов: трудовые, сырье, финансы. Количество ресурса каждого вида, необходимое для выпуска единицы продукции данного типа, называется нормой расхода. Нормы расхода, наличие располагаемого ресурса, а также прибыль, получаемая от реализации единицы каждого типа продукции, приведены в таблице:

 | A | B | C | D | E | F | G
1 | Ресурс | Прод1 | Прод2 | Прод3 | Прод4 | знак | Наличие
2 | Прибыль | 60 | 70 | 120 | 130 | max | -
3 | Трудовые | 1 | 1 | 1 | 1 | <= | 16
4 | Сырье | 6 | 5 | 4 | 3 | <= | 110
5 | Финансы | 4 | 6 | 10 | 13 | <= | 100

Решение:

  1. Составим математическую модель, для чего введем следующие обозначения:
    xj - количество выпускаемой продукции j-ого типа, j=1, 2, 3,4;
    bi - количество располагаемого ресурса i -ого вида, i =1, 2, 3;
    aij - норма расхода i -ого ресурса для выпуска единицы продукции j-ого типа;
    cj - прибыль, получаемая от реализации единицы продукции j-ого типа.
    Для выпуска единицы Прод1 требуется 6 единиц сырья, значит, для выпуска всей продукции Прод1 требуется 6х1 единиц сырья, где х1 - количество выпускаемой продукции Прод1. С учетом того, что для других видов продукции зависимости аналогичны, ограничение по сырью будет иметь вид: 6х1+5х2+4х3+3х4<=110.
    В этом ограничении левая часть равна величине потребного ресурса, а правая показывает количество имеющего ресурса.
    Аналогично можно составить ограничения для остальных ресурсов и написать зависимость для целевой функции. Тогда математическая модель задачи будет иметь вид:
    (7.11)
  2. Создание формы для ввода условий задачи. Для данной задачи создать форму для ввода как на рис 7.7. Весь текст на этом рисунке является комментариями, и на решение задачи не повлияет.
    A
    B
    C
    D
    E
    F
    G
    H
    1
    Переменные
    2
    Имя
    Прод1
    Прод2
    Прод3
    Прод4
    3
             Значение
    4
             Нижн. гр.
    5
             Верх. гр.
    ЦФ
    Направление
    6
             Коэф. в ЦФ
    7
    Ограничения
    8
    Вид ресурсов
    Лев. часть
    Знак
    Прав. часть
    9
             Трудовые
    10
             Сырье
    11
             Финансы
    рис. 7.7
  3. Ввод исходных данных. Ввести исходные данные в форму согласно условию задачи (Рис 7.8).
    A
    B
    C
    D
    E
    F
    G
    H
    1
    Переменные
    2
    Имя
    Прод1
    Прод2
    Прод3
    Прод4
    3
             Значение
    4
             Нижн. гр.
    0
    0
    0
    0
    5
             Верх. гр.
    ЦФ
    Напр
    6
             Коэф. в ЦФ
    60
    70
    120
    130
    0
    макс
    7
    Ограничения
    8
    Вид ресурсов
    Лев. часть
    Знак
    Прав. часть
    9
             Трудовые
    1
    1
    1
    1
    0
    <=
    16
    10
             Сырье
    6
    5
    4
    3
    0
    <=
    110
    11
             Финансы
    4
    6
    10
    13
    0
    <=
    100
    Рис 7.8
  4. Ввод зависимостей из математической модели. Ввести зависимости из математической модели (7.11). В режиме представления формул это будет выглядеть как на рис 7.9
    A
    B
    C
    D
    E
    F
    G
    H
    1
    Переменные
    2
    Имя
    Прод1
    Прод2
    Прод3
    Прод4
    3
             Значение
    4
             Нижн. гр.
    0
    0
    0
    0
    5
             Верх. гр.
    ЦФ
    Напр
    6
             Коэф. в ЦФ
    60
    70
    120
    130
             =СУММПРОИЗВ(B$3:E$3;B6:E6)
    макс
    7
    8
    Вид ресурсов
    Ограничения
    Лев. часть
    Знак
    Прав. часть
    9
             Трудовые
    1
    1
    1
    1
             =СУММПРОИЗВ(B$3:E$3;B9:E9)
    <=
    16
    10
             Сырье
    6
    5
    4
    3
             =СУММПРОИЗВ(B$3:E$3;B10:E10)
    <=
    110
    11
             Финансы
    4
    6
    10
    13
             =СУММПРОИЗВ(B$3:E$3;B11:E11)
    <=
    100
    Рис 7.9
  5. Назначение целевой функции, ввод ограничений и граничных условий. Вызвать диалоговое окно Поиск Решения: Сервис-Поиск решения… (рис 7.10)
    Рис 7.10
    Назначить целевую функцию: $F$6
    Ввести адреса искомых переменных: $B$3:$E$3
    Ввести ограничения, нажав кнопку Добавить. Появиться диалоговое окно Добавление ограничения (рис 7.11)
    Рис 7.11
    Ввести граничные условия: $B$3:$E$3>=$B$4:$E$4
    Ввести ограничения: $F$9:$F$11<=$H$9:$H$11
  6. Решение задачи
    После ввода данных вызвать диалоговое окно Параметры… (рис 7.12)
    Рис 7.12
    Параметры, используемые по умолчанию, подходят для решения большинства задач. В нашем случае необходимо только установить флажок Линейная модель, что обеспечивает применение симплекс-метода. ОК.
    На экране вновь появится диалоговое окно Поиск решения. Выполнить.
    На экране появится диалоговое окно Результаты поиска решения. Решение найдено и результат оптимального решения задачи приведены в таблице (Рис. 7.14).
    Рис 7.13
    A
    B
    C
    D
    E
    F
    G
    H
    1
    Переменные
    2
    Имя
    Прод1
    Прод2
    Прод3
    Прод4
    3
             Значение
    10
    0
    6
    0
    4
             Нижн. гр.
    5
             Верх. гр.
    ЦФ
    Направление
    6
             Коэф. в ЦФ
    60
    70
    120
    130
    1320
    макс
    7
    8
    Вид ресурсов
    Ограничения
    Лев. часть
    Знак
    Прав. часть
    9
             Трудовые
    1
    1
    1
    1
    16
    <=
    16
    10
             Сырье
    6
    5
    4
    3
    84
    <=
    110
    11
             Финансы
    4
    6
    10
    13
    100
    <=
    100
    Рис 7.14
    Из рис. 7.14 видно, что в оптимальном решении Прод1=10, Прод2=0, Прод3=6, Прод4=0. При этом максимальная прибыль будет составлять 1320, а количество использованных ресурсов: трудовых=16, сырья=84, финансов=100.
  7. Важным фактором, помогающим принять решение является графическое представление полученного результата.
    Рис 7.15
  8. Преодоление несовместности и анализ оптимального решения оставляем на самостоятельное изучение. Этот материал можно найти в [5].

Пример 2

Компания производит два основных типа товара (Изделие-1, Изделие-2). Изделие-1 требует 2 единицы сырья А и 2 ед. сырья В, оно приносит прибыль компании 2 денежные единицы. Изделие-2 требует 3 ед. сырья А и 5 ед. сырья В, оно приносит прибыль 4 д. е. Найдите оптимальный план производства, если доступно всего 1200 единиц сырья А и 1600 единиц сырья В.

Решение:

Пусть Х - количество производимого товара первого изделия, Y - количество производимого товара второго изделия. Составим математическую модель.

Создадим форму для ввода условий задачи и введем исходные данные:

 | A | B | C | D | E | F
1 |  | Переменные |  |  |  |
2 | Имя | Изделие-1 | Изделие-2 |  |  |
3 | Значения |  |  |  |  |
4 | Нижн. Гр. | 0 | 0 |  |  |
5 | Верх. Гр. |  |  | ЦФ |  |
6 | Коэф. ЦФ | 2 | 4 |  |  |
7 |  | Ограничения |  |  |  |
8 | Вид |  |  | Левая часть | Знак | Правая часть
9 | Сырье А | 2 | 3 |  | <= | 1200
10 | Сырье Б | 2 | 5 |  | <= | 1600
Введем зависимости из математической модели:
 | A | B | C | D | E | F
1 |  | Переменные |  |  |  |
2 | Имя | Изделие-1 | Изделие-2 |  |  |
3 | Значения |  |  |  |  |
4 | Нижн. Гр. | 0 | 0 |  |  |
5 | Верх. Гр. |  |  | ЦФ |  |
6 | Коэф. ЦФ | 2 | 4 | =СУММПРОИЗВ(B$3:C$3;B6:C6) |  |
7 |  | Ограничения |  |  |  |
8 | Вид |  |  | Левая часть | Знак | Правая часть
9 | Сырье А | 2 | 3 | =СУММПРОИЗВ(B$3:C$3;B9:C9) | <= | 1200
10 | Сырье Б | 2 | 5 | =СУММПРОИЗВ(B$3:C$3;B10:C10) | <= | 1600
Назначение целевой функции, ввод ограничений и граничных условий. Вызвать диалоговое окно Поиск Решения: Сервис-Поиск решения…
Рис 7.16
Назначить целевую функцию: $D$6. Ввести адреса искомых переменных: $B$3:$C$3. Ввести ограничения и граничные условия: $D$9:$D$10<=$F$9:$F$10, $B$3:$C$3>=$B$4:$C$4. Вызвать диалоговое окно Параметры, установить флажок Линейная модель. OK. Выполнить.
На экране появится диалоговое окно Результаты поиска решения (рис 7.13). OK. Результат оптимального решения задачи приведен в таблице
 | A | B | C | D | E | F
1 |  | Переменные |  |  |  |
2 | Имя | Изделие-1 | Изделие-2 |  |  |
3 | Значения | 300 | 200 |  |  |
4 | Нижн. Гр. | 0 | 0 |  |  |
5 | Верх. Гр. |  |  | ЦФ |  |
6 | Коэф. ЦФ | 2 | 4 | 1400 |  |
7 |  | Ограничения |  |  |  |
8 | Вид |  |  | Левая часть | Знак | Правая часть
9 | Сырье А | 2 | 3 | 1200 | <= | 1200
10 | Сырье Б | 2 | 5 | 1600 | <= | 1600
По полученным результатам построим гистограмму:


Профильный курс. Методические материалы.

Решение задач линейного программирования. Практическая работа

Для данной задачи (см. Приложение) составить форму ввода, ввести исходные данные и зависимости из математической модели. Вызвать диалоговое окно Поиск решения, ввести адрес целевой функции, указать изменяемые ячейки, ввести ограничения и граничные условия. В диалоговом окне Параметры установить флажок Линейная модель. Запустить алгоритм поиска оптимального решения. По полученным результатам построить столбчатую гистограмму. Сформулировать вывод.


Профильный курс. Методические материалы.

Задачи оптимизации. Варианты самостоятельных работ

Задача 1. Завод выпускает обычные станки и станки с программным управлением, затрачивая на один обычный станок 200 кг стали и 200 кг цветного металла, а на один станок с программным управлением 700 кг стали и 100 кг цветного металла. Завод может израсходовать в месяц до 46 тонн стали и до 22 тонн цветного металла. Сколько станков каждого типа должен выпустить за месяц завод, чтобы объем реализации был максимальным, если один обычный станок стоит 2000 д.е., а станок с программным управлением 5000 д.е.

Задача 2. Для производства двух видов изделий А и В используется три типа технологического оборудования. На изготовление одного изделия А оборудование первого типа используется в течение 5 ч., второго - в течение 3 ч. и третьего - 2 ч. На производство одного изделия В, соответственно: 2 ч., 3 ч. и 3 ч. В плановом периоде оборудование первого типа может быть использовано в течение 505 ч., второго - 394 ч. и третьего - 348 ч. Прибыль от реализации одного изделия А равна 7 д.е., В - 4 д.е. Составить план производства, максимизирующий прибыль предприятия.

Задача 3. Для изготовления изделий А и В предприятие использует три вида сырья. На производство одного изделия А требуется сырья первого вида 15 кг, второго - 11 кг, третьего - 9 кг, а на производство одного изделия В, соответственно, 4 кг, 5 кг, 10 кг. Сырья первого вида имеется 1095 кг, второго - 865 кг, третьего - 1080 кг. Составить план производства, максимизирующий прибыль, если прибыль от реализации единицы изделия А составляет 3 д.е., В - 2 д.е.

Задача 4. Для производства изделий А и В используются три вида оборудования. При изготовлении одного изделия А оборудование первого вида занято 7 ч., второго - 6 ч. и третьего - 1 ч. При изготовлении одного изделия В, соответственно, 3 ч., 3 ч. и 2 ч. В месяц оборудование первого вида может быть занято 1365 ч., второго - 1245 ч. и третьего - 650 ч. Составить план производства, максимизирующий прибыль, если прибыль от реализации одного изделия А равна 6 д.е., изделия В - 5 д.е.

Задача 5. Для изготовления изделий А и В используется три вида сырья. На изготовление одного изделия А требуется 9 кг сырья первого вида, 6 кг сырья второго вида и 3 кг сырья третьего вида. На изготовление одного изделия В требуется, соответственно, 4 кг, 7 кг и 8 кг сырья. Производство обеспечено сырьем первого вида в количестве 801 кг, второго - 807 кг, третьего - 703 кг. Прибыль от продажи изделия А равна 3 д.е., изделия В - 2 д.е. Составить план производства, максимизирующий прибыль.

Задача 6. Завод выпускает два вида редукторов. На изготовление одного редуктора первого вида расходуется 4 тонны чугуна и 1 тонна стали, а на изготовление одного редуктора второго вида 2 тонны чугуна и 1 тонна стали. Завод располагает на месяц 160 тоннами чугуна и 120 тоннами стали. Составить месячный план производства редукторов, максимизирующий прибыль завода, если прибыль от продажи одного редуктора первого вида равна 400 д.е., а второго - 200 д.е.

Задача 7. Для производства изделий А и В используются три вида станков. На производство одного изделия А требуется 6 ч. работы станка первого вида, 4 ч. работы станка второго вида и 3 ч. работы станка третьего вида. На производство одного изделия В требуется 2 ч. работы станка первого вида, 3 ч. работы станка второго вида и 4 ч. работы станка третьего вида. Месячный ресурс работы всех станков первого вида, имеющихся на заводе равен 600 ч., всех станков второго вида - 520 ч. и всех станков третьего вида - 600 ч. Прибыль от реализации одного изделия А равна 6 д.е., изделия В - 3 д.е. Составить план производства на месяц, максимизирующий прибыль предприятия.

Задача 8. На ферме разводят нутрий и кроликов. В недельный рацион нутрий входят 17 кг белков, 11 кг углеводов и 5 кг жиров, а для кроликов эти нормы, соответственно, равны 13 кг, 15 кг и 7 кг. Доход от реализации одного кролика 20 д.е., а от реализации одной нутрии 25 д.е. Найти план разведения животных, максимизирующий доход фермы, если ферма не может расходовать в неделю более 184 кг белков, 152 кг углеводов и 70 кг жиров.

Задача 9. Для изготовления изделий А и В предприятие использует три вида сырья. На производство одного изделия А требуется 12 кг сырья первого вида, 10 - второго и 3 - третьего, а на производство одного изделия В, соответственно, 3 кг, 5 кг, 6 кг. Производство обеспечено сырьем первого вида в количестве 684 кг, второго - 690 кг и третьего 558 кг. Одно изделие А дает предприятию 6 д.е. прибыли, изделие В - 2 д.е. Составить план производства, максимизирующий прибыль предприятия.

Задача 10. Мастерская по покраске кузовов автомобилей рассчитана на покраску не более 160 кузовов в месяц. На покраску кузова "Москвича" краски расходуется 4 кг, а кузова "Волги" - 7 кг. Мастерская располагает 820 кг краски на месяц. Составить месячный план покраски автомобилей, максимизирующий прибыль мастерской, если покраска одного "Москвича" дает 30 д.е. прибыли, а одной "Волги" - 40 д.е. прибыли.


Основы информатики

лаборатоные работы

Лабораторная работа №1 ОПЕРАЦИОННАЯ СИСТЕМА WINDOWS.
ПРОВОДНИК. СТАНДАРТНЫЕ ПРИЛОЖЕНИЯ

Краткие сведения (теория)

Задания:

1. Отработайте приемы управления с помощью мыши. Для этого наведите указатель мыши на кнопку Пуск и выполните щелчок. Затем выполните щелчок в любом месте Рабочего стола. Щелкните на объекте Корзина. Двойной щелчок выполните на значке Мой компьютер. В любом месте окна вызовите контекстное меню.
2. Используя перетаскивание, переместите окно Мой компьютер в другое место Рабочего стола (наведите указатель на строку заголовка и перетащите).
3. Открыть окно Мой компьютер, изменить его размеры и положение, минимизировать, восстановить, затем закрыть.
4.Создать в папке Мои документы папку Юристы\номер группы
5. С помощью меню пуска запустить приложение блокнот, написать в нем «Это проверка» и сохранить этот текст в виде файла с названием «Это проверка» в папке Мои документы\Юристы\номер группы.
6. С помощью приложения Paint выполнить рисунок на тему текущего времени года и сохранить его в папке Мои документы\Юристы.
7. С помощью приложения Калькулятор вычислить 1234*5678.
8. Выполнить поиск файла «Это проверка.txt».
9. Открыв папку Мои документ\Юристыы в окне Мой компьютер переименовать файл «Это проверка.txt» в text.txt.
10. С помощью Мой компьютер скопировать файл text.txt методом перетаскивания на дискету A:
11. Удалить созданные в ходе выполнения заданий файлы в папке Мои документы\Юристы.
12. Запустите программу Проводник.
13. На левой панели найдите и откройте созданную Вами папку Юристы\номер группы. Откройте её.
14. На правой панели создайте новую папку New1. Убедитесь в том, что на левой панели в папке юристы\номер группы образовалась новая вложенная папка
15. В папке New1 создайте ярлык к программе Калькулятор
16. Разыщите на левой панели Корзину и перетащите папку New3 на ее значок. Раскройте Корзину и проверьте наличие в ней только что удаленной папки. Закройте окно программы Проводник.


Основы информатики

лаборатоные работы

Лабораторная работа №2 Графический редактор Paint

Теория

Задания:

1. нарисовать и сохранить в Мои документы\номер группы\Своя фамилия.bmp

2. Нарисовать олимпийские кольца. Залить их различными цветами.
3 . Нарисовать ромашку, копируя и поворачивая один лепесток, который нарисовать с использованием замкнутой кривой линии.
4 . Нарисовать сердечко с использованием незамкнутой кривой линии.
5 . Подписать один из рисунков «с тенью».


Основы информатики

лаборатоные работы

Первоначальные сведения и правила работы с WORD

Клавиша Delete нужна для стирания символа, расположенного правее положения курсора. Клавиша Backspase нужна для стирания символа, расположенного левее положения курсора.

Одно их основных понятий Word — абзац. Чтобы начать новый абзац надо нажать клавишу Enter. Основные параметры абзаца (красная строка, межстрочный интервал, выравнивание, абзацный отступ) устанавливаются через меню Формат\Абзац. Примеры абзацев:

Это абзац, состоящий из одной строки. Это абзац, состоящий из одной строки.

Это абзац, состоящий из двух строк. Это абзац, состоящий из двух строк. Это абзац, состоящий из двух строк. Это абзац, состоящий из двух строк.

Это абзац, состоящий из трех строк. Это абзац, состоящий из трех строк. Это абзац, состоящий из трех строк. Это абзац, состоящий из трех строк. Это абзац, состоящий из трех строк. Это абзац, состоящий из трех строк.

Чтобы работать с текстом надо научится его выделять. Это можно делать с помощью мыши или с помощью клавиатуры.

Чтобы выделить | Действие
Слово | Дважды щелкните слово.
Строку текста | Переместить указатель к левому краю строки так, чтобы он превратился в стрелку, направленную вправо, после чего щелкнуть кнопкой мыши.
Несколько строк текста | Переместить указатель к левому краю одной из строк так, чтобы он превратился в стрелку, направленную вправо, а затем перетащить указатель вверх или вниз.
Часть строки | Переместить указатель к левому краю строки так, чтобы он принял вид I; удерживая нажатой кнопку мыши, провести вправо до нужного символа
Блок текста | Щелкнуть начало фрагмента, удерживая нажатой клавишу SHIFT щелкнуть конец фрагмента.

Чтобы снять отметку щелкнуть по любому месту левой кнопкой мыши.

Чтобы скопировать или переместить отмеченный блок надо:

1)       скопировать или вырезать его в буфер (меню Правка\Копировать (Вырезать) или использовать соответствующие пиктограммы на панели инструментов);

2)       щелкнуть в то место, куда его надо вставить;

3)       выгрузить из буфера(меню (Правка\Вставить или пиктограмма Вставить_из_буфера), выгружать можно столько раз, сколько раз надо вставить.

Задание: Скопировать эту строку 4 раза.

Каждый абзац может иметь свой абзацный отступ и форматирование. Для задания отступа или форматирования надо:

1) выделить абзац;

2)   перетащить верхний “бегунок” линейки на нужную цифру.

Например:

Этот абзац имеет отступ 0 см.

Этот абзац имеет отступ 1 см.

Этот абзац имеет отступ 2 см.

Этот абзац имеет отступ 7 см.

Для задания выравнивания надо:

1) выделить абзац

2) нажать на одну из кнопок выравнивания

Например:

Этот абзац выровнен по левому краю.

Этот абзац выровнен по правому краю.

Этот абзац выровнен по центру.

Интервал между строками абзаца может быть различен.

Например:

Интервал между строками этого абзаца — одинарный. Интервал между строками этого абзаца — одинарный. Интервал между строками этого абзаца — одинарный.

Интервал между строками этого абзаца — полуторный. Интервал между строками этого абзаца —  полуторный. Интервал между строками этого абзаца — полуторный.

Интервал между строками этого абзаца — двойной. Интервал между строками этого абзаца —двойной. Интервал между строками этого абзаца — двойной.

Чтобы изменить интервал надо:

1)         выделить абзац;

2)         выбрать п. меню Формат\Абзац;

3)         выбрать нужный межстрочный интервал.

 Размер шрифта, его стиль и цвет можно изменять. Например:

Это 16 номер шрифта Arial Cyr.

Это 13 номер шрифта Times New Roman Cyr, стиль — курсив.

Для этого надо:

1)       выделить текст;

2)       войти п. Меню Формат\Шрифт;

3)       выбрать нужные параметры.

Во время работы в Word чтобы узнать размер и кегль(начертание или вид) шрифта, надо установить курсор на текст в образце — вид шрифта и размер высветятся на панели инструментов или войти в меню Формат\шрифт. Также обратите внимание на начертание(жирный, обычный, курсив).

Для набора верхних или нижних индексов необходимо:

1)       набрать символ;

2)       выделить его;

3)       войти п. Меню Формат\Шрифт;

4)       активизировать нужный индекс.

Например, для набора следующего выражения: 32 + 54 нужно сначала набрать 32 +54. Затем выделить 2, установить для нее атрибут — верхний индекс. Далее аналогично для цифры 4 выполнить те же действия.

Для любого абзаца можно заказывать обрамление и заливку.

Примеры:

обрамление снизу обрамление снизу обрамление снизу

обрамление слева обрамление слева обрамление слева

Обрамление снаружи Обрамление снаружи Обрамление снаружи Обрамление снаружи

Заливка +Обрамление

Для этого надо:

1) выделить абзац;

2) нажать одну из кнопок   [image]  для обрамления.

Или воспользоваться п. Меню Формат\Обрамление_и_заливка.

Чтобы отказаться от заливки и обрамления надо:

1)       выделить абзац;

2)       воспользоваться п. меню Формат\Обрамление_и_заливка;

3)       выбрать нет.

Чтобы сохранить результаты работы в новом файле надо:

1)       Щелкнуть п. меню Файл\Сохранить_как;

2)       Ввести имя файла с клавиатуры;

3)       Щелкнуть по кнопке Сохранить.

Все установленные параметры абзаца и текста можно сохранить под определенным стилем. Для этого надо:

1)     выделить абзац;

2)     установить для него атрибуты шрифта  и абзаца;

3)     выбрать п. Меню Формат\Стиль, кнопка Создать;

4)     заполнить диалоговое окно.

Далее этот стиль можно применить к другому абзацу: выделить абзац, через панель инструментов Стиль выбрать нужный стиль.

 При нажатии на клавишу Enter создается новый абзац. Он наследует все параметры предыдущего абзаца.

Внедрение и связывание объектов

Для объединения в одном документе объектов разного происхождения, например, чтобы вставить в текст графику, музыку, фрагмент электронной таблицы и т. д., в приложениях Windows широко применяется технология OLE (Object Link and Embedding) — связь и внедрение объектов. Это означает, что  помещаемый в текст объект  может включаться в него в двух вариантах:

·       как внедренный, т.е. он становится частью документа Word; все изменения, которые производятся в источнике, не будут отражаться в документе;  например, если внедрить ранее созданный в Pbrush рисунок в Word, затем загрузить Pbrush  и произвести изменения над рисунком, то эти изменения не отразятся на рисунке в текстовом документе;

·       как связанный;  здесь, наоборот, если производятся изменения над рисунком в источнике, то эти изменения отражаются и на рисунке, помещенном в текстовый документ.

Различают также термины технологии OLE:

·       клиент — приложение, принимающее объект;

·       сервер — приложение, средствами которого создается объект.

Внедренный или связанный объект можно впоследствии редактировать средствами приложения-сервера. Для этого надо выполнить двойной щелчок мыши на данном объекте, Word загрузит приложение-сервер, произвести изменения над объектом и вернуться в приложение-клиент.

Технология OLE осуществляется двумя способами:

1.     Через буфер обмена — командой приложения Правка\Специальная_вставка...

2.     Командой приложения Вставка\объект...

Первым способом можно внедрить (или связать) фрагмент документа или внедрить(или связать) весь документ, вторым способом — только целый документ. Причем во втором случае можно внедрять или связывать уже готовый объект, а также есть возможность создать новый объект в процессе внедрения (связывания).

Через буфер обмена: | Командой Правка\Объект...
Внедрение: 1... В приложении-сервере выделить объект; 2... Занести его в буфер обмена (Правка\Копировать); 3... Перейти в приложение-клиент; 4... Выполнить команду Вставка\Специальная вставка... 5... В зависимости от того, какое приложение-сервер (например, MS Excel, CorelDraw, MS Word и т.д.), Word предложит диалоговое окно для выбора различных типов внедрения. | Внедрение готового объекта: 1. . В приложении-клиенте выполнить команду Вставка\Объект... 2. . В появившемся диалогом окне активизировать вкладку Создание из файла; 3. . Через кнопку Обзор выбрать внедряемый объект. Внедрение объекта, создаваемого в процессе внедрения: 1. . В приложении-клиенте выполнить команду Вставка\Объект... 2. . В появившемся диалогом окне активизировать вкладку Создание; 3. . Выбрать приложение-сервер, создать в нем объект; 4. . Вернуться в приложение-клиент (щелкнуть вне границы размеров выделенной области)
Связывание: Выполнить те же самые действия, что и при внедрении, только в пункте 5 в диалоговом окне необходимо активизировать переключатель Связать. При этом можно активизировать еще переключатель Значок, который выводится вместо связанного объекта. | Связывание: Выполняется аналогично внедрению готового объекта, только в пункте 2 в диалоговом окне активизировать переключатель Связь_с_файлом. При этом можно активизировать еще переключатель Значок, который выводится вместо связанного объекта.

Примечание. Во многих случаях команда вставки содержимого буфера обмена Правка\Вставить по умолчанию внедряет объект, т.е. выполняет роль одного из вариантов внедрения.


Документ1

Проверочные работы по MS EXCEL

Лабораторная работа № 1

Ввод данных (числа, формулы) в ячейки, копирование данных, форматирование числовых данных

Задание: Составьте таблицу значений функции двух переменных F(x, y) заданной в прямоугольной области [a, b][c, d], для аргументов xi = a + ihx, yj = c + jhy, где i = 0..Nx, j = 0..Ny, (hx = (b-a)/Nx, hy = (d-c)/Ny) .

Время выполнения — 2 часа.

Варианты заданий

№ | F(x,y) | a | b | c | d | hx | hy
1 | xy+5,6(x+y) | 0 | 1 | 0 | 1 | 0,1 | 0,1
2 | ln(x+y) | 1 | 3 | 0 | 2 | 0,2 | 0,2
3 | cos(x)+sin(y) | 0 | 1 | 0 | 1 | 0,1 | 0,1
4 | sin(x) + cos(y) | 0 | 1 | 0 | 1 | 0,1 | 0,1
5 | tg( x + y) | 1 | 3 | 0 | 2 | 0,2 | 0,2
6 | sin(x) + xy | 0 | 1 | 0 | 1 | 0,1 | 0,1
7 | cos(x) + 5xy | 0 | 1 | 0 | 1 | 0,1 | 0,1
8 | y + tg (x+y) | 1 | 3 | 0 | 2 | 0,2 | 0,2
9 | sin(xy) + cos (xy) | 0 | 1 | 0 | 1 | 0,1 | 0,1
10 | 5sin(cos(x+y)+3,78) | 0 | 1 | 0 | 1 | 0,1 | 0,1
11 | 6,4cos(5,8+ln(xy)) | 1 | 3 | 0 | 2 | 0,2 | 0,2
12 | xy + x2+y2 | 0 | 1 | 0 | 1 | 0,1 | 0,1
13 | sin2(x+y)+cos2(x+y) | 0 | 1 | 0 | 1 | 0,1 | 0,1
14 | xsin(y) + ycos(x) | 1 | 3 | 0 | 2 | 0,2 | 0,2
15 | 10xy(sin(xy)+cos(y)) | 0 | 1 | 0 | 1 | 0,1 | 0,1
16 | xy (5,6(xy) | 0 | 1 | 0 | 1 | 0,1 | 0,1
17 | xy ln(x+y) | 1 | 3 | 0 | 2 | 0,2 | 0,2
18 | xy(cos(x)+sin(y)) | 0 | 1 | 0 | 1 | 0,1 | 0,1
19 | x(sin(x) + cos(y)) | 0 | 1 | 0 | 1 | 0,1 | 0,1
20 | xy tg( x + y) | 1 | 3 | 0 | 2 | 0,2 | 0,2
21 | sin(x) + xy2 | 0 | 1 | 0 | 1 | 0,1 | 0,1
22 | cos(x) + 5xy sin(y) | 0 | 1 | 0 | 1 | 0,1 | 0,1
23 | yx + tg (x+y)4 | 1 | 3 | 0 | 2 | 0,2 | 0,2
24 | xy (sin(xy) + cos (xy)) | 0 | 1 | 0 | 1 | 0,1 | 0,1
25 | xy sin(cos(x+y)+3,78) | 0 | 1 | 0 | 1 | 0,1 | 0,1

Лабораторная работа № 2

Структурирование и отбор данных в ЭТ

Задание. Создайте ЭТ «Стипендиальная ведомость факультета». Представьте, что на факультете 5 курсов, на каждом курсе 2 группы, в группах по 25 человек. В таблице используйте данные: ФИО студента, успеваемость (средний балл за сессию), сумма, надбавки за отличную и хорошую учебу. Стипендия студентам, имеющим балл ниже 3,5 не начисляется (в соответствующей графе указать 0).

Подготовьте отчеты по указанные в вариантах заданиям.

Время выполнения — 8 часов.

Варианты

Вариант 1

Сформируйте сводную ведомость студентов с отличной учебой. Выдайте диаграмму с долей таких учащихся. Создайте отчеты по каждому курсу с графическим отображением. Оформите диаграммы распределения отличников по группам курса и по курсам.

Вариант 2

Сформируйте сводную ведомость студентов со средней успеваемостью. Выдайте диаграмму с долей таких учащихся. Создайте отчеты по каждому курсу с графическим отображением. Оформите диаграммы распределения студентов со средней успеваемостью по группам курса и по курсам.

Вариант 3

Сформируйте сводную ведомость неуспевающих студентов. Выдайте диаграмму с долей таких учащихся. Создайте отчеты по каждому курсу с графическим отображением. Оформите диаграммы распределения неуспевающих студентов по группам курса и по курсам.

Вариант 4

Пусть первоначально составленная ведомость определяет фиксированный стипендиальный фонд факультета. Отмените выдачу стипендии для студентов имеющих средний балл успеваемости ниже 4. Перераспределите экономию стипендиального фонда для каждой группы и для каждого курса в зависимости от доли отличников. Выдайте соответствующие отчеты.

Вариант 5

Пусть первоначально составленная ведомость определяет фиксированный стипендиальный фонд факультета. Отмените надбавки за отличную учебу. Перераспределите экономию стипендиального фонда для каждой группы и для каждого курса в зависимости от доли студентов получающих стипендию. Выдайте соответствующие отчеты.

Вариант 6

Пусть первоначально составленная ведомость определяет фиксированный стипендиальный фонд факультета. Отмените выдачу стипендии для студентов имеющих средний балл успеваемости ниже 4,5. Экономию стипендиального фонда перераспределите всем студентам пропорционально их успеваемости. Составьте диаграммы роста размера стипендии для успевающих студентов (балл выше 4,5).

Вариант 7

Пусть первоначально составленная ведомость определяет фиксированный стипендиальный фонд факультета. Перераспределите заданный фонд всем (без исключения) студентам. Составьте диаграммы изменения размера стипендии для трех категорий студентов (отличники, успевающие, неуспевающие).

Вариант 8

Отчислите из каждой группы произвольным образом по три студента (не только неуспевающих!). Выполните задание варианта 1.

Вариант 9

Отчислите из каждой группы произвольным образом по несколько студентов, не менее 5 в каждой группе (не только неуспевающих!). Выполните задание варианта 2.

Вариант 10

Пусть первоначально составленная ведомость определяет фиксированный стипендиальный фонд факультета. Внесите в каждую группу дополнительно до трех студентов с разной успеваемостью. Перераспределите стипендиальный фонд в основном за счет лишения стипендии студентов с низким баллом успеваемости. Составьте отчет по изменению количества студентов получающих стипендию по курсам.

Вариант 11

Дополнительно факультету выделено 50% от стипендиального фонда. Проведите перерасчет размера стипендии. Составьте отчеты изменения размера стипендии по трем категориям студентов (по успеваемости).

Вариант 12

Дополнительно факультету выделено 50% от стипендиального фонда. Назначьте стипендию всем студентам. Составьте отчеты изменения размера стипендии по трем категориям студентов (по успеваемости).

Вариант 13

Дополнительно факультету выделено 50% от стипендиального фонда. Распределите их среди отличников. Составьте диаграмму стипендиальных фондов каждой группы и курса.

Вариант 14

Дополнительно факультету выделено 50% от стипендиального фонда. Распределите их среди успевающих. Составьте диаграмму стипендиальных фондов каждой группы и курса.

Вариант 15

Дополнительно факультету выделено 50% от стипендиального фонда. Распределите их всем студентам групп. Составьте диаграмму стипендиальных фондов каждой группы и курса.


Документ1

Краткие сведения
(электронные таблицы)

Электронная таблица — это прямоугольная матрица, состоящая из ячеек, каждая из которых имеет свой номер.

Адрес ячейки определяется обычным координатным способом, например ячейка В3, ячейка С5 и т.д.

В каждую из ячеек можно занести число, формулу (арифметическое выражение) или текст. Операндами формулы могут быть математические функции, константы, адреса ячеек; в последнем случае реальный операнд — содержимое ячейки с указанным адресом.

Тексты и числовые константы, занесенные в ЭТ, сами по себе в ходе работы таблицы никогда не изменятся. Что же касается формул, то программа по специальной команде производит вычисление их значений и отображает его на экране (в той же ячейке, куда занесена формула).

Данные, входящие в таблицы, можно автоматически обрабатывать в графическом виде. Их также можно подготовить и распечатать в удобном для пользователя виде, сохранять и использовать многократно.

Существует несколько программ такого класса. Ниже обсуждается одна из них, популярная в настоящее время программа Excel, из пакета Microsoft Office, в которой реализованы многочисленные возможности и удобный и комфортный интерфейс.

.

Электронные таблицы Excel

Задаваемый обычным образом адрес ячейки называется относительным адресом или относительной ссылкой.

При некоторых операциях копирования, удаления, вставки электронная таблица автоматически изменяет адреса ячеек. Иногда возникает необходимость не менять адрес ячейки. В таких случаях используют абсолютный адрес. Абсолютный адрес ячейки создается с помощью знака доллара $.

Группа ячеек (диапазон) задается через двоеточие, например, B3:D4 (или В3..D4) и образует прямоугольник, включающий ячейки B3, C3, D3, B4, C4, D4.

Ячейки могут содержать следующие типы данных:

  1. Символьные (текстовые) данные. Могут включать в себя алфавитные, числовые и специальные символы. По умолчанию символьные данные при вводе выравниваются по правому краю ячейки. При необходимости их можно выровнять по правому краю или по центру.

  2. Числовые данные. Могут содержать только числовые данные. Исключением являются десятичные точка (или запятая) и знак числа, стоящий перед ним. Числовые данные по умолчанию выравниваются при вводе по левому краю ячейки.

  3. Формулы. Формула может включать ряд арифметических, логических и других действий, производимых с данными из других ячеек. На экране после ввода формулы отображается результат вычислений, а сама формула отображается в строке ввода над таблицей. Ввод формул начинается со знака равенства.

  4. Функции. Функции могут самостоятельно присутствовать в ячейках, а также могут входить в состав формул. Различают математические, статистические, логические, финансовые и другие функции.

  5. Даты. В этом типе данных возможны такие функции, как добавление к дате числа (пересчет даты вперед и назад) или вычитание разности двух дат (длительность периода).

Названия ссылок | Обозначения | Результат при копировании или переносе формул
Частичная абсолютная ссылка | $A5 | Не меняется номер столбца
 | A$5 | Не меняется номер строки
Полная абсолютная ссылка | $A$5 | Не меняется и номер строки, и номер столбца

Excel имеет два окна — программное (внешнее) и рабочее (внутреннее). Внутреннее окно Sheet # содержит рабочую страницу (таких страниц несколько, они образуют книгу), представляющую двумерную прямоугольную таблицу. Справа и внизу на рабочей странице расположены линейки со стрелками прокрутки, позволяющие с помощью мыши быстро перемещаться по странице.

В окне Excel под зоной заголовка находится область заголовков меню. Чуть ниже находится основная линейка инструментов. Кнопки линейки инструментов позволяют быстро и легко вызывать различные функции Excel. Их можно вызывать также через меню.

Чтобы выполнить какое-либо действие с данными, помещенными в ячейки (ввод, копирование, удаление, форматирование и т.п.), необходимо их выделить. Чтобы выделить ячейку, укажите на нее и нажмите кнопку мыши. При нажатой кнопке можно выделить диапазон ячеек. После выделения необходимой области нажмите правую кнопку мыши, вызывая контекстное меню, которое позволяет выполнить ряд команд: Вырезать, Копировать, Вставить и т.п.

Изменение данных проводят прямо в ячейке. Перемещение или копирование содержимых ячеек можно осуществить перетаскиванием их с помощью мыши. Чтобы скопировать (а не переместить), держите нажатой клавишу CTRL.

Создание формулы начинается с ввода знака равенства (=). Формула содержит встроенные функции, адреса ячеек, константы. В случае затруднений с формированием формулы используйте Мастер функций.

Подобный сервис есть и при оформлении дизайна таблицы. Перед печатью таблиц (кнопка Печать) удобно осуществить предварительный просмотр (кнопка Предварительный_просмотр в меню Сохранить).

Excel работает с несколькими листами книги. Например, на одном листе можно разместить итоговые оценки студенческой группы за пять лет обучения, а на пяти следующих — данные за каждый год обучения. Листы книги могут служить местом для размещения графических иллюстраций, диаграмм.

Для отображения числовых данных в графической форме используют линии, полосы, столбцы, сектора и другие маркеры, а также их объединенные вариации. Для размещения диаграммы рядом с данными создают внедренную диаграмму на том же листе. Можно создать диаграмму на отдельном листе диаграммы. Если нет времени, желания и возможности для относительно сложных построений, используют автоматическое оформление диаграмм с помощью команды Автоформат в меню Формат.

Помимо того, что имеется большая встроенная библиотека построения графических образов (графиков, диаграмм, гистограмм), Excel содержит мощный встроенный графический редактор.

Excel не только «дружен» с текстовыми и графическими системами, но и поддерживает основные действия, характерные для систем управления базами данных (СУБД). Более того, у него развит аппарат импортирования и экспортирования данных из других программных систем.

В Excel, кроме адресов ячеек, предусмотрен также удобный способ ссылки на ячейку с помощью присвоения этой ячейке произвольного имени. Это делается при выделенной ячейке с помощи меню Вставка\Имя\Присвоить… Ввести любое имя, например, Сумма. Введенное имя можно использовать в дальнейшем вместо адреса.

Для форматирования данных в ячейках электронной таблицы используется меню Формат\Ячейки…, для настройки ширины и высоты ячеек —меню Формат\Строка и Формат\Столбец.


Нелинейные уравнения

Операции над матрицами. Решение СЛАУ

Функции для работы с матрицами (мопред( ), мобр( ), мумнож( )) находятся в разделе Математические.
Функция транспонирования матрицы трансп( ) находится в разделе Ссылки и массивы.
При вычислении нормы матрицы удобно использовать функцию суммкв() из раздела Математические.

Формулы, выполняющие несколько вычислений над одним или несколькими наборами значений, а затем возвращающие один или несколько результатов, называются формулами массива. Формулы массива заключены в фигурные скобки {}, автоматически добавляемые Microsoft Excel, и вводятся нажатием клавиш CTRL+SHIFT+ENTER.

Некоторые функции возвращают массив значений (мобр( ), мумнож( ), трансп( )). Они вычисляются с помощью формулы массива. Для этого

  1. Выделите диапазон ячеек, в который требуется ввести формулу массива.
  2. Введите формулу.
  3. Нажмите сочетание клавиш CTRL+SHIFT+ENTER.

    теория по матрицам
    Решение СЛАУ

Задания

Даны квадратные матрицы A, B, C формата 4x4 и вектор d (4x1). Найти

Вариант 1

  1. a) A+B; b) A-B; c) A*B; d) A*d
  2. |A| - определитель матрицы A
  3. A-1 - обратную матрицу для матрицы A, если |A|<>0
  4. AT - транспонированную матрицу для матрицы A
  5. ||A|| - норму матрицы A
  6. (A+3B)C-1
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    -2x1 + 3x2 + 4x3 + x4 = -1
    2x1 + 1x2 - 6x3 - x4 = -1
    3x1 + 4x2 + 7x3 + x4 = 2
    x1 - x2 + 2x3 - x4 = -4

Вариант 2

  1. a) C+B; b) C-B; c) C*B; d) C*d
  2. |B| - определитель матрицы B
  3. B-1 - обратную матрицу для матрицы B, если |B|<>0
  4. BT - транспонированную матрицу для матрицы B
  5. ||B|| - норму матрицы B
  6. (2A-B)-1d
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    -4x1 - 3x2 + 4x3 + x4 = 3
    2x1 + x2 - 6x3 + 5x4 = -1
    3 x1 - 2x2 + 7x3 + x4 = 1
    x1 - x2 + 2x3 + 6x4 = 5

Вариант 3

  1. a) A+B; b) C-B; c) A*B; d) B*d
  2. |C| - определитель матрицы C
  3. C-1 - обратную матрицу для матрицы C, если |C|<>0
  4. CT - транспонированную матрицу для матрицы C
  5. ||C|| - норму матрицы C
  6. (2C+B)-1A
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    2x1 + x2 + 3x3 - x4 = 3
    -4x1 -6x2 + x3 + 2x4 = 4
    2x1 - 2x2 + 5x3 + x4 = 8
    -x1 + x2 + 4x3 - 5x4 = 0

Вариант 4

  1. a) C+B; b) B-A; c) C*A; d) C*d
  2. |A| - определитель матрицы A
  3. A-1 - обратную матрицу для матрицы A, если |A|<>0
  4. AT - транспонированную матрицу для матрицы A
  5. ||A|| - норму матрицы A
  6. A-1(C-2B)
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    x1 - 3x2 + 4x3+ 2x4 = 4
    2x1 + 2x2 - x3 + 4x4 = 9
    3 x1 + 7x2 + 4x3 + x4 = -6
    3 x1 - x2 + 2x3 + 2x4 = 6

Вариант 5

  1. a) A+B; b) A-B; c) A*C; d) B*d
  2. |B| - определитель матрицы B
  3. B-1 - обратную матрицу для матрицы B, если |B|<>0
  4. BT - транспонированную матрицу для матрицы B
  5. ||B|| - норму матрицы B
  6. (A-3B)-1d
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    4x1 - 3x2 + 5x3 - 2x4 = -5
    - x1 + x2 - 7x3 + 5x4 = 3
    3 x1 - 2x2 + 6x3 + x4 = -8
    x1 - x2 + 3x3 + 2x4 = -6

Вариант 6

  1. a) C+B; b) B-C; c) B*C; d) C*d
  2. |C| - определитель матрицы C
  3. C-1 - обратную матрицу для матрицы C, если |C|<>0
  4. CT - транспонированную матрицу для матрицы C
  5. ||C|| - норму матрицы C
  6. B-1(-4C+A)
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    x1 - 3x2 + 4x3 + 3x4 = -4
    2x1 - x2 - 6x3 + 5x4 = 1
    2x1 + 3x2 + 7x3 - 5x4 = -1
    x1 + 4x2 + 2x3 - 6x4 = 1

Вариант 7

  1. a) A+B; b) A-B; c) A*B; d) A*d
  2. |A| - определитель матрицы A
  3. A-1 - обратную матрицу для матрицы A, если |A|<>0
  4. AT - транспонированную матрицу для матрицы A
  5. ||A|| - норму матрицы A
  6. (A+B)(2C)-1
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    -3x1+ 2x2 + 4x3 + x4 = 2
    2x1 + x2 - 6x3 + 5x4 = 1
    2x1 - 2x2 + 7x3 - 5x4 = 4
    -2x1 + x2 + x3 + 2x4 = 1

Вариант 8

  1. a) A+B; b) A-B; c) A*C; d) B*d
  2. |B| - определитель матрицы B
  3. B-1 - обратную матрицу для матрицы B, если |B|<>0
  4. BT - транспонированную матрицу для матрицы B
  5. ||B|| - норму матрицы B
  6. (B-4C)-1d
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    -4x1 - 3x2 + 4x3 + x4 = -3
    -3x1 - 2x2 + 4x3 = 1
    3x1 - 4x2 + 2x3 + x4 = -2
    x1 - x2 + 2x3 + 6x4 = -3

Вариант 9

  1. a) C+B; b) B-C; c) B*C; d) C*d
  2. |C| - определитель матрицы C
  3. C-1 - обратную матрицу для матрицы C, если |C|<>0
  4. CT - транспонированную матрицу для матрицы C
  5. ||C|| - норму матрицы C
  6. B-1(3C+A)
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    2x1 - 3x2 + 2x3 + 5x4 = 8
    x1 + x2 - 2x3 + 5x4 = 1
    x1 - 2x2 + 2x3 + x4 = 4
    2x1 - x2 + 2x3 + 6x4 = 7

Вариант 10

  1. a) A+B; b) A-B; c) A*B; d) A*d
  2. |A| - определитель матрицы A
  3. A-1 - обратную матрицу для матрицы A, если |A|<>0
  4. AT - транспонированную матрицу для матрицы A
  5. ||A|| - норму матрицы A
  6. (3A+2B)C-1
  7. Решить систему линейных уравнений a) матричным способом, б) методом Крамера
    -x1 - 3x2 + 5x3 + x4 = 0
    x1 + 4x2 - 6x3 + 2x4 = 3
    4x1 - 2x2 + 5x3 + 2x4 = -5
    x1 - x2 + 2x3 + 6x4 = 4


Матрицы

С матрицей и ее определителем мы уже встречались в разделе 10.9. В данной главе мы рассмотрим эти объекты более детально. Сначала расширим понятие матрицы.
Подразделы
  • Определение, обозначения и типы матриц
  • Сложение матриц и умножение на число
  • Символ суммирования
  • Умножение матриц
  • Транспонирование матрицы
  • Определители
  • Обратная матрица
  • Ранг матрицы


Определение, обозначения и типы матриц

Определение 14.1 Матрицей размеров [image] называется прямоугольная таблица чисел, содержащая $ m$ строк и $ n$ столбцов. Числа, составляющие матрицу, называются элементами матрицы.

Обычно принято обозначать матрицы большими буквами, а саму таблицу чисел заключать в круглые скобки. Например, [image] -- матрица размеров [image] , [image] -- матрица размеров [image] , или другими словами, матрица-столбец, [image] -- матрица размеров [image] , или матрица-строка.

Иногда вместо круглых скобок в записи матрицы используют квадратные или двойные прямые линии. Например, [image] или [image] .

Если элементы матрицы обозначаются буквами, то для этого обозначения используется та же буква, что и для обозначения матрицы, только не большая, а малая, и эта буква снабжается двумя индексами. Например, матрицу размеров [image] можно записать в виде

В этой записи [image] означает, что элемент находится в строке с номером $ i$ и столбце с номером $ j$ , то есть первый индекс указывает номер строки, а второй -- номер столбца. Например, в матрице

, [image] .

Наряду с указанным обозначением элементов матрицы используется также обозначение [image] , в котором номер строки указывает верхний индекс, а номер столбца -- нижний.

Укажем основные типы матриц.

Если число строк матрицы равно числу столбцов, то матрица называется квадратной. Число строк или, что то же самое, число столбцов в ней называется порядком матрицы.

Если все элементы матрицы равны нулю, то матрица называется нулевой. Нулевая матрица обозначается обычной цифрой 0. Как правило, из контекста ясно, является ли этот 0 числом или матрицей.

Совокупность элементов квадратной матрицы, расположенных на отрезке, соединяющем левый верхний угол с правым нижним, называется главной диагональю матрицы. Например, в матрице [image] главную диагональ образуют числа [image] . Отметим, что при обозначении элементов матрицы буквами с двумя индексами у элементов главной диагонали и только у них индексы будут равны друг другу. Так у квадратной матрицы $ A$ порядка $ n$ элементами главной диагонали являются элементы [image] , [image] .

Квадратная матрица, у которой все элементы вне главной диагонали равны нулю, называется диагональной. Примеры диагональных матриц:

Квадратная матрица называется верхней треугольной (нижней треугольной), если все ее элементы, стоящие ниже (выше) главной диагонали, равны нулю. Например, верхние треугольные матрицы:

Нижние треугольные матрицы:

Верхняя треугольная матрица иногда называется правой треугольной, а нижняя треугольная -- левой треугольной.

Единичной матрицей называется диагональная матрица, у которой все элементы главной диагонали равны 1. Для обозначения единичной матрицы обычно используется буква $ E$ . Порядок матрицы при этом обычно ясен из контекста. Например, [image] -- единичная матрица третьего порядка.

Из определения единичной матрицы видно, что ее элементы [image] равны нулю, если индексы различны, и равны 1, если индексы совпадают. В математике таким свойством обладает величина [image] , называемая символом Кронекера:

Поэтому [image] .

Две матрицы называются равными, если они имеют одинаковые размеры и элементы, стоящие на одинаковых местах, равны друг другу.

Вперед: Сложение матриц и умножение на число Наверх: Матрицы Назад: Матрицы


Сложение матриц и умножение на число

Сложение определено только для матриц одинаковых размеров.

Определение 14.2 Суммой матриц $ A$ и $ B$ размеров [image] является матрица $ C$ таких же размеров, у которой [image] , [image] , [image] .

Другими словами, при сложении матриц складываются элементы, стоящие на одинаковых местах. Например,

Определение 14.3 Произведением матрицы $ A$ размеров [image] на число [image] называется матрица $ C$ таких же размеров, у которой [image] , [image] , [image] .

Другими словами, при умножении матрицы на число все ее элементы умножаются на это число. Например, [image] .

Операцию вычитания матриц можно определить следующим способом:

что соответствует вычитанию элементов, стоящих на одинаковых местах.

Используя операции сложения и умножения, мы можем находить линейные комбинации матриц, то есть выражения вида [image] , где [image] -- числа, [image] -- матрицы одинаковых размеров.

Пример 14.1 Пусть [image] , [image] . Найдем [image] :

Легко проверить, что операции сложения матриц и умножения матрицы на число, называемые линейными операциями, обладают следующими свойствами:

  1. -- свойство коммутативности;
  2. -- свойство ассоциативности;
  3. ;
  4. ;
  5. -- свойство дистрибутивности;
  6. ;
  7. ;
  8. .
Здесь [image] -- матрицы, [image] -- числа, 0 -- нулевая матрица.

Отметим, что перечисленные здесь свойства совпадают со свойствами векторов, из теоремы 10.1.

Вперед: Символ суммирования Наверх: Матрицы Назад: Определение, обозначения и типы матриц


Символ суммирования

В математике для записи сумм, содержащих много слагаемых, или в случае, когда число слагаемых обозначено буквой, применяется следующая запись:

которая расшифровывается так

(14.1)

где $ f(i)$ -- функция целочисленного аргумента. Здесь символ [image] (большая греческая буква "сигма") означает суммирование. Запись [image] внизу символа суммирования показывает, что переменная, которая меняет свои значения от слагаемого к слагаемому, обозначена буквой $ i$ и что начальное значение этой переменной равно $ m$ . Запись вверху обозначает последнее значение, которое принимает переменная $ i$ .

Пример 14.2 Вычислим несколько сумм:

1) [image] .

2) [image] . Так как в правой части стоит сумма геометрической прогрессии с первым членом равным [image] и знаменателем прогрессии равным $ m$ , то эту сумму легко найти

3) [image] .

4) [image] .

5) [image] .

В курсе линейной алгебры чаще всего будут встречаться суммы вида [image] . Здесь переменная с индексом рассматривается как функция от своего индекса. Поэтому

С помощью знака суммы формулу (10.1) скалярного произведения векторов можно записать так:

(14.2)

где для трехмерного пространства [image] , для плоскости [image] .

Для единообразия будем считать, что

и говорить, что это сумма, содержащая одно слагаемое.

Замечание 14.1 Буква, стоящая внизу под знаком суммы (индекс суммирования), не влияет на результат суммирования. Важно лишь, как от этого индекса зависит суммируемая величина. Например,

Или

в правой части никакой буквы $ i$ нет, значит, и результат от $ i$ не зависит.

Предложение 14.1 Множитель, не зависящий от индекса суммирования, может быть вынесен за знак суммы:

Доказательство этого предложения предоставляется читателю.

Предложение 14.2

(14.3)

Это предложение является частным случаем следующего утверждения.

Предложение 14.3

(14.4)

Доказательство. Пусть

Тогда

Раскроем скобки в правой части этого равенства. Получим сумму элементов [image] при всех допустимых значениях индексов суммирования. Слагаемые сгруппируем по-другому, а именно, сначала соберем все слагаемые, у которых первый индекс равен 1, потом, у которых первый индекс равен 2 и т.д. Получим

Заменив в этом равенстве $ S$ в левой части его выражением через знаки суммирования, получим формулу (14.4).

Замечание 14.2 Двойные суммы из равенства (14.4) можно записывать и без использования скобок

Нужно помнить, что двойная сумма означает сумму элементов [image] для всех допустимых значений индексов суммирования. По этой же причине, если встречается запись, содержащая подряд три или более символов суммирования, то порядок расстановки этих символов можно менять произвольно.

Если границы изменения всех индексов суммирования одинаковы, то можно для суммирования по нескольким индексам использовать запись вида

Иногда под символом суммы указывают дополнительные условия, налагаемые на индексы суммирования. Так запись

означает, что в сумму не включаются величины [image] , [image] ,..., [image] , то есть [image] с равными индексами.

Иногда в записи суммы не указываются границы изменения индексов, например,

Такая запись используется, когда значения, которые могут принимать индексы, очевидны из предыдущего текста или будут оговорены сразу после окончания формулы.

Вперед: Умножение матриц Наверх: Матрицы Назад: Сложение матриц и умножение на число


Умножение матриц

Определение 14.4 Произведением матрицы $ A$ размеров [image] на матрицу $ B$ размеров [image] называется матрица $ C$ размеров [image] , элементы которой вычисляются по формуле

(14.5)

где [image] , [image] .

Во-первых, в этом определении нужно обратить внимание на то, что важен порядок сомножителей, нужно знать, какой сомножитель первый, а какой -- второй.

Во-вторых, нужно отметить, что произведение определено только в том случае, если число столбцов первого сомножителя равно числу строк второго. Если это условие не выполняется, то произведение не определено.

В-третьих, размеры результата умножения определяются следующим образом: число строк результата равно числу строк первого сомножителя, а число столбцов результата равно числу столбцов второго сомножителя.

Правило вычисления элементов произведения можно сформулировать следующим образом.

Для того, чтобы вычислить элемент произведения, стоящий в $ i$ -ой строке и $ j$ -ом столбце, нужно взять $ i$ -ую строку первого сомножителя и $ j$ -ый столбец второго сомножителя, попарно перемножить их элементы, стоящие на одинаковых местах, и результаты сложить. (Точно так же мы поступаем, когда находим скалярное произведение двух векторов по их координатам, см. формулу (14.2).)

Пример 14.3 Даны матрицы [image] , [image] . Найдите произведения $ AB$ и $ BA$ .

Решение. Рассмотрим произведение $ AB$ . Число столбцов в первом сомножителе $ (A)$ равно 3, число строк во втором сомножителе $ (B)$ тоже равно 3. Числа совпали, следовательно, произведение определено.

Результатом умножения будет матрица $ C$ , [image] , у которой строк столько, сколько их в первом сомножителе, то есть 3, а столбцов столько, сколько их во втором сомножителе, то есть 2. Итак, матрица $ C$ имеет размеры [image] .

Находим элемент [image] . В его вычислении участвует первая строка [image] первого сомножителя $ (A)$ и первый столбец [image] второго сомножителя $ (B)$ :

Находим элемент [image] . В его вычислении участвует первая строка [image] первого сомножителя $ (A)$ и второй столбец [image] второго сомножителя $ (B)$ :

Все элементы первой строки матрицы $ C$ вычислены. Находим элемент [image] . В его вычислении участвует вторая строка [image] первого сомножителя $ (A)$ и первый столбец [image] второго сомножителя $ (B)$ :

Находим элемент [image] . В его вычислении участвует вторая строка [image] первого сомножителя $ (A)$ и второй столбец [image] второго сомножителя $ (B)$ :

Вычислены все элементы второй строки матрицы $ C$ . Аналогично находим элементы третьей строки:

Итак, [image] .

Рассмотрим произведение $ BA$ . Число столбцов в первом сомножителе $ (B)$ равно 2, число строк во втором сомножителе $ (A)$ равно 3. Числа не совпали, следовательно, произведение не определено.

Ответ: , произведение $ BA$ не определено.

Замечание 14.3 Легко проверить, что произведение квадратных матриц одного порядка всегда существует (определено).

У читателя может возникнуть законный вопрос: "Зачем так сложно определять произведение матриц? Нельзя ли его определить попроще, например, как произведение элементов матриц-сомножителей, стоящих на одинаковых местах?" Ответ на этот вопрос мы увидим позже, когда будем рассматривать системы линейных уравнений, правило изменения координат векторов при изменении базиса и такие неизвестные пока читателю объекты как линейные преобразования и квадратичные формы. Тогда мы увидим, что введенное определение умножения матриц используется очень эффективно, что оно "похоже" на умножение чисел. Если же произведение матриц определить по-другому, то его не удается разумно использовать ни в математике, ни в прикладных науках.

Рассмотрим, какими свойствами обладает операция умножения матриц.

Прежде всего отметим, что умножение матриц -- некоммутативная операция. Это означает, что существуют такие матрицы $ A$ и $ B$ , что

Для прямоугольных матриц мы убедились в этом в примере 14.3. В нем произведение $ AB$ существует, а произведение $ BA$ -- нет. Для квадратных матриц это видно из следующего примера. Пусть [image] , [image] . Тогда

то есть [image] .

Предложение 14.4 Умножение матриц обладает следующими свойствами: -- ассоциативность умножения; [image] , где [image] -- число; [image] , [image] -- дистрибутивность умножения; [image] , [image] , где $ E$ -- единичная матрица соответствующего порядка. Предполагается, что все указанные произведения имеют смысл.

Доказательство. На протяжении всего доказательства предполагается, что $ A$ -- матрица размеров [image] .

Докажем свойство ассоциативности. Чтобы произведение $ AB$ было определено, матрица $ B$ должна иметь размеры [image] . Произведение $ AB$ обозначим буквой $ D$ . Тогда матрица $ D$ имеет размеры [image] . Чтобы произведение [image] было определено, матрица $ C$ должна иметь размеры [image] . Матрицу $ (AB)C$ обозначим $ F$ , матрицу $ BC$ обозначим $ G$ , матрицу $ A(BC)$ обозначим $ H$ . Покажем, что элементы, стоящие в $ i$ -ой строке и $ j$ -ом столбце матриц $ F$ и $ H$ , равны друг другу, то есть что $ {f_{ij}= h_{ij}}$ .

По определению

Подставив [image] из второго равенства в первое, получим

В силу предложения 14.1

В силу предложения 14.3

(14.6)

С другой стороны

откуда

Применим предложение 14.1

Сравнивая этот результат с (14.6), заключаем, что $ {f_{ij}= h_{ij}}$ . Ассоциативность умножения доказана.

Свойство 2 предоставляем читателю доказать самостоятельно.

Докажем дистрибутивность умножения. Чтобы произведение [image] было определено, матрицы $ B$ и $ C$ должны иметь размеры [image] . Положим [image] , [image] , [image] , [image] , [image] . Для доказательства равенства [image] , нужно доказать, что [image] , [image] , [image] .

Так как [image] , то

По определению суммы матриц, [image] . Следовательно,

(14.7)

С другой стороны,

Тогда

Сравнивая полученный результат с (14.7), получаем [image] . Первое равенство в свойстве дистрибутивности доказано. Второе равенство доказывается аналогично.

Докажем первое равенство в свойстве 4. Чтобы произведение $ EA$ было определено, матрица $ E$ должна иметь порядок $ m$ . Пусть [image] . Тогда

где [image] -- символ Кронекера. Сумма справа имеет вид

Таким образом [image] , первое равенство в свойстве 4 доказано. Второе равенство доказывается аналогично.

Замечание 14.4 Из ассоциативности умножения матриц следует, что если произведение содержит три и более сомножителей, то его можно записывать без использования скобок. Например, $ ABC$ или $ ABCD$ . Эта кажущаяся очевидной запись произведения верна не для всяких математических объектов. Действительно, в силу предложения 10.23, для векторного произведения векторов запись [image] неприемлема, так как результат вычисления этого произведения зависит от расстановки скобок.

Замечание 14.5 Свойство дистрибутивности позволяет раскрывать скобки в матричных выражениях. Но нужно обратить внимание, что, раскрывая скобки, нельзя менять порядок сомножителей.

Замечание 14.6 Свойство 4 объясняет происхождение названия "единичная" матрица. В умножении матриц единичная матрица ведет себя так же, как число 1 при умножении чисел.

Упражнение14.4.6. Докажите, что произведение двух верхних треугольных матриц одного порядка является верхней треугольной матрицей того же порядка. Докажите аналогичное утверждение для нижних треугольных матриц.

Упражнение14.4.7. По определению считается, что [image] . Покажите, что для матриц формула [image] не верна. Объясните почему.

Вперед: Транспонирование матрицы Наверх: Матрицы Назад: Символ суммирования


Транспонирование матрицы

Над матрицами определена еще одна операция, называемая транспонированием.

Определение 14.5 Пусть $ A$ -- матрица размеров [image] . Тогда транспонированной матрицей $ A$ называется такая матрица $ B$ размеров [image] , что $ {b_{ij}= a_{ji}}$ , [image] , [image] .

Транспонированная матрица $ A$ обозначается [image] или [image] . Операция транспонирования заключается в том, что строки и столбцы в исходной матрице меняются ролями. В транспонированной матрице первым столбцом служит первая строка исходной матрицы, вторым столбцом -- вторая строка исходной матрицы и т.д. Например,

Читатель легко проверит, что

где [image] -- число.

Предложение 14.5 Если произведение $ AB$ определено, то

(14.8)

Доказательство. Пусть $ A$ -- матрица размеров [image] , $ B$ -- матрица размеров [image] . Тогда [image] имеет размеры [image] , [image] -- размеры [image] . Число столбцов в [image] совпадает с числом строк в [image] , поэтому произведение [image] на [image] определено. Размеры этого произведения [image] . Матрица $ AB$ имеет размеры [image] , поэтому [image] -- матрица размеров [image] . Итак, матрицы в правой и левой части равенства (14.8) существуют и имеют одинаковые размеры.

Пусть [image] , [image] , [image] , [image] , [image] . Нам нужно показать, что [image] , [image] , [image] .

По определению транспонирования [image] . По определению умножения матриц

(14.9)

С другой стороны,

Поэтому

Сравнивая полученный результат с (14.9), получаем [image] .

Вперед: Определители Наверх: Матрицы Назад: Умножение матриц


Определители

С понятием определителя мы уже сталкивались при изучении векторного произведения в разделе 10. Там были введены определители матриц второго и третьего порядка. В этом разделе мы дадим определение определителя квадратной матрицы любого порядка. Это определение будет рекуррентным, то есть чтобы установить, что такое определитель матрицы порядка $ n$ , нужно уже знать, что такое определитель матрицы порядка [image] . Такое рекуррентное определение и было использовано для введения определителя матрицы третьего порядка. Отметим также, что определитель существует только у квадратных матриц.

Определитель квадратной матрицы $ A$ будем обозначать [image] или [image] .

Определение 14.6 Определителем квадратной матрицы [image] второго порядка называется число [image] . Определителем квадратной матрицы [image] порядка $ n$ , [image] , называется число

где [image] -- определитель матрицы порядка [image] , полученной из матрицы $ A$ вычеркиванием первой строки и столбца с номером $ k$ .

Легко проверить, что это определение для определителей второго и третьего порядка совпадает с данным ранее в разделе 10.

Для наглядности запишем, как можно вычислить определитель матрицы четвертого порядка:

Замечание 14.7 Реальное вычисление определителей для матриц выше третьего порядка на основе определения используется в исключительных случаях. Как правило, вычисление ведется по другим алгоритмам, которые будут рассмотрены позже и которые требуют меньше вычислительной работы.

Замечание 14.8 В определении 14.6 было бы точнее сказать, что определитель есть функция, определенная на множестве квадратных матриц порядка $ n$ и принимающая значения в множестве чисел.

Замечание 14.9 В литературе вместо термина "определитель" используется также термин "детерминант", имеющий тот же самый смысл. От слова "детерминант" и появилось обозначение [image] .

Рассмотрим некоторые свойства определителей, которые сформулируем в виде предложений.

Предложение 14.6 При транспонировании матрицы определитель не меняется, то есть [image] .

Предложение 14.7 Определитель произведения квадратных матриц равен произведению определителей сомножителей, то есть [image] .

Предложение 14.8 Если в матрице $ A$ поменять местами две строки, то ее определитель сменит знак.

Ввиду ограниченности курса доказательства этих трех свойств мы опускаем. Читатель может найти их в учебниках по линейной алгебре [3], [5] или же может без особых сложностей проверить их на матрицах второго и третьего порядков.

Предложение 14.9 Если матрица $ A$ имеет две одинаковые строки, то ее определитель равен нулю.

Доказательство. Поменяем местами две одинаковые строки. В силу предложения 14.8 определитель сменит знак. С другой стороны, так как строки были одинаковыми, то матрица не изменилась и, следовательно, не изменился и ее определитель. Получим, что [image] , откуда следует, что [image] .

В дальнейшем нам потребуется складывать строки и умножать строку на число. Эти действия над строками (столбцами) мы будем выполнять так же, как действия над матрицами-строками (матрицами-столбцами), то есть поэлементно. Результатом будет служить строка (столбец), как правило, не совпадающая со строками исходной матрицы. При наличии операций сложения строк (столбцов) и умножения их на число мы можем говорить и о линейных комбинациях строк (столбцов), то есть суммах с числовыми коэффициентами.

Предложение 14.10 Если строку матрицы умножить на число [image] , то ее определитель умножится на это число.

Доказательство. Пусть $ A$ -- исходная матрица, $ B$ -- матрица, полученная из $ A$ умножением первой строки на число [image] :

Тогда

где [image] -- определитель матрицы, полученной из матрицы $ B$ или, что то же самое, из матрицы $ A$ вычеркиванием первой строки и $ k$ -ого столбца.

Вынесем множитель [image] за знак суммы и получим

Пусть теперь матрица $ B$ получается из матрицы $ A$ умножением $ j$ -ой строки на число [image] . Поменяем местами первую и $ j$ -ую строки в матрице $ A$ и то же самое проделаем в матрице $ B$ . Получим две новых матрицы [image] и [image] . По предложению 14.8

(14.10)

Очевидно, что матрица [image] получается из матрицы [image] умножением первой строки на число [image] . Как только что было доказано, [image] . Таким образом, из второго равенства (14.10) находим [image] , отсюда с помощью первого равенства (14.10) получаем [image] .

Предложение 14.11 Если матрица содержит нулевую строку, то ее определитель равен нулю.

Доказательство. Нулевую строку можно рассматривать как строку из единиц, умноженную на число ноль. По предложению 14.10 определитель такой матрицы равен нулю, умноженному на определитель матрицы, содержащей строку из единиц. Результат такого умножения всегда будет ноль.

Предложение 14.12 Если одна из строк матрицы равна другой, умноженной на число [image] (строки пропорциональны), то определитель матрицы равен нулю.

Доказательство. По предложению 14.10 определитель исходной матрицы равен числу [image] , умноженному на определитель матрицы, у которой есть две одинаковые строки. По предложению 14.9 определитель последней матрицы равен нулю. Поэтому и определитель исходной матрицы равен нулю.

Предложение 14.13 Пусть в матрице $ A$ $ i$ -ая строка имеет вид [image] . Тогда [image] , где матрица [image] получается из матрицы $ A$ заменой $ i$ -ой строки на строку [image] , а матрица [image] -- заменой $ i$ -ой строки на строку [image] .

Доказательство. Пусть первая строка матрицы $ A$ имеет вид [image] . Тогда

Для случая [image] утверждение доказано.

Пусть [image] . Обозначим через $ B$ , [image] , [image] матрицы $ A$ , [image] , и [image] , в которых поменяли местами первую и $ i$ -ую строки. По только что доказанному (для [image] ) утверждению [image] . По предложению 14.8 [image] , [image] , [image] . Следовательно, [image] . Умножив обе части последнего равенства на $ -1$ , получим требуемое утверждение.

Предложение 14.14 Если к одной из строк матрицы добавить другую, умноженную на число, то определитель матрицы не изменится.

Доказательство. Пусть к $ i$ -ой строке матрицы $ A$ прибавлена $ j$ -ая строка, умноженная на число [image] . Новую матрицу обозначим $ B$ . В матрице $ B$ элементы $ i$ -ой строки имеют вид [image] . По предложению 14.13 [image] , где $ C$ -- матрица, полученная из матрицы $ A$ заменой $ i$ -ой строки на $ j$ -ую строку, умноженную на число [image] . По предложению 14.12 [image] , то есть [image] .

Предложение 14.15 Если одна из строк матрицы является линейной комбинацией других ее строк, то определитель матрицы равен нулю.

Доказательство. По предложению 14.13 определитель исходной матрицы равен сумме определителей матриц, в каждой из которых есть пропорциональные строки. По предложению 14.12 все эти определители равны нулю. Следовательно, и определитель исходной матрицы тоже равен нулю.

Определение 14.7 Алгебраическим дополнением к элементу [image] матрицы $ A$ называется число, равное [image] , где [image] -- определитель матрицы, полученной из матрицы $ A$ вычеркиванием $ i$ -ой строки и $ j$ -ого столбца.

Алгебраическое дополнение к элементу [image] матрицы $ A$ обозначается [image] .

Пример 14.4 Пусть [image] . Тогда

Замечание 14.10 Используя алгебраические дополнения, определение 14.6 определителя можно записать так:

Предложение 14.16 Разложение определителя по произвольной строке. Для определителя матрицы $ A$ справедлива формула

Доказательство. Если [image] , положим [image] . Пусть [image] . Тогда $ i$ -ую строку поменяем местами со строкой с номером [image] . Определитель сменит знак. Затем строку с номером [image] поменяем местами со строкой с номером [image] . Определитель снова сменит знак. Процесс перестановки строк будем продолжать до тех пор, пока $ i$ -ая строка матрицы $ A$ не станет первой строкой новой матрицы, которую мы обозначим $ B$ . Отметим, что в матрице $ B$ , начиная со второй строки, стоят строки матрицы $ A$ , причем порядок их следования не изменился.

При переходе от матрицы $ A$ к матрице $ B$ определитель сменит знак $ i-1$ раз (проверьте для случая [image] ). Таким образом

(14.11)

Это соотношение верно и при [image] . По определению 14.6 определителя,

где [image] -- определитель матрицы, полученной из матрицы $ B$ вычеркиванием первой строки и $ k$ -ого столбца. Первая строка матрицы $ B$ совпадает с $ i$ -ой строкой матрицы $ A$ , поэтому [image] . Результат вычеркивания в матрице $ B$ первой строки и $ k$ -ого столбца будет таким же, как при вычеркивании в матрице $ A$ $ i$ -ой строки и $ k$ -ого столбца. Поэтому [image] , где [image] -- определитель матрицы, полученной при вычеркивании в матрице $ A$ $ i$ -ой строки и $ k$ -ого столбца. Следовательно,

В силу равенства (14.11) получим

По определению 14.7 алгебраического дополнения получим $ {(-1)^{i+k} M_{ik}=A_{ik}}$ . Тогда из предыдущего равенства вытекает

что и требовалось доказать.

Пример 14.5 Вычислите [image] .

Решение. Воспользуемся разложением по третьей строке, так выгоднее, поскольку в третьей строке два числа из трех -- нули. Получим

Предложение 14.17 Для квадратной матрицы $ A$ порядка $ n$ при [image] выполнено соотношение

(14.12)

Доказательство. Пусть $ B$ -- матрица, полученная из матрицы $ A$ , в которой $ j$ -ая строка заменена $ i$ -ой строкой этой же матрицы, а сама $ i$ -ая строка осталась без изменения. Таким образом, в матрице $ B$ есть две одинаковые строки и в силу предложения 14.9 [image] .

С другой стороны, используя разложение определителя по $ j$ -ой строке (предложение 14.16), получим

где [image] -- алгебраическое дополнение к элементу [image] . Так как все строки матрицы $ B$ , кроме $ j$ -ой, совпадают со строками матрицы $ A$ , то [image] . Так как по построению матрицы $ B$ [image] , то

Так как [image] , то равенство (14.12) доказано.

Предложение 14.18 Все свойства определителя, сформулированные для строк ( предложения 14.8-14.17), справедливы и для столбцов, в частности, справедливо разложение определителя по $ j$ -ому столбцу

(14.13)

и равенство

при [image] .

Доказательство. В силу предложения 14.6 определитель не меняется при транспонировании матрицы, а ее столбцы становятся строками транспонированной матрицы, для которой доказываемые свойства имеют место.

Предложение 14.19 Определитель треугольной матрицы равен произведению элементов ее главной диагонали.

Доказательство. Воспользуемся индукцией по порядку матрицы. Для [image] :

утверждение верно. Предположим, что доказываемое утверждение верно для матриц порядка [image] . Покажем, что оно верно для матрицы порядка $ n$ .

Если $ A$ -- верхняя треугольная матрица, то используем разложение по первому столбцу (равенство (14.13) при [image] ):

Справа стоит определитель треугольной марицы порядка [image] . По предположению индукции этот определитель равен [image] . Поэтому [image] .

Если $ A$ -- нижняя треугольная матрицы, то нужно воспользоваться разложением по первой строке. В остальном рассуждения аналогичны.

Итак, утверждение верно для матрицы порядка $ n$ . Предложение доказано.

Следствие 14.1 Определитель единичной матрицы равен единице, [image] .

Перечисленные выше свойства позволяют находить определители матриц достаточно высоких порядков при сравнительно небольшом объеме вычислений. Алгоритм вычислений следующий.

Алгоритм создания нулей в столбце.

Пусть требуется вычислить определитель матрицы $ A$ порядка $ n$ . Если [image] , то поменяем местами первую строку и любую другую, в которой первый элемент не нуль. В результате определитель $ A$ , будет равен определителю новой матрицы с противоположным знаком. Если же первый элемент каждой строки равен нулю, то матрица $ A$ имеет нулевой столбец и по предложениям 14.11, 14.18 ее определитель равен нулю.

Итак, считаем, что уже в исходной матрице [image] . Первую строку оставляем без изменений. Прибавим ко второй строке первую строку, умноженную на число [image] . Тогда первый элемент второй строки будет равен

Остальные элементы новой второй строки обозначим [image] , [image] . Определитель новой матрицы по предложению 14.14 равен [image] .

Первую строку умножим на число [image] и прибавим к третьей. Первый элемент новой третьей строки будет равен

Остальные элементы новой третьей строки обозначим [image] , [image] . Определитель новой матрицы по предложению 14.14 равен [image] .

Процесс получения нулей вместо первых элементов строк продолжим дальше. Наконец, первую строку умножим на число [image] и прибавим к последней строке. В результате получается матрица, обозначим ее [image] , которая имеет вид

причем [image] . Для вычисления определителя матрицы [image] используем разложение по первому столбцу

Так как [image] , то

В правой части стоит определитель матрицы порядка [image] . К нему применим тот же алгоритм, и вычисление определителя матрицы $ A$ сведется к вычислению определителя матрицы порядка [image] . Процесс повторяем до тех пор, пока не дойдем до определителя второго порядка, который вычисляется по определению.

Если матрица $ A$ не обладает какими-то специфическими свойствами, то заметно уменьшить объем вычислений по сравнению с предложенным алгоритмом не удается. Еще одна хорошая сторона этого алгоритма -- по нему легко составить программу для компьютера для вычисления определителей матриц больших порядков. В стандартных программах вычисления определителей используется этот алгоритм с не принципиальными изменениями, связанными с минимизацией влияния ошибок округления и погрешностей входных данных при вычислениях компьютера.

Пример 14.6 Вычислите определитель матрицы

.

Решение. Первую строку оставляем без изменения. Ко второй строке прибавляем первую, умноженную на число [image] :

Определитель не меняется. К третьей строке прибавляем первую, умноженную на число [image] :

Определитель не меняется. К четвертой строке прибавляем первую, умноженную на число [image] :

Определитель не меняется. В результате получаем

По тому же алгоритму считаем определитель матрицы порядка 3, стоящий справа. Первую строку оставляем без изменений, ко второй строке прибавляем первую, умноженную на число [image] :

К третьей строке прибавляем первую, умноженную на число [image] :

В результате получаем

Ответ. .

Замечание 14.11 Внимательный читатель, наверное, отметил, что хотя при вычислениях использовались дроби, результат оказался целым числом. Действительно, используя свойства определителей и то, что исходные числа -- целые, операций с дробями можно было бы избежать. Но в инженерной практике числа крайне редко бывают целыми. Поэтому, как правило, элементы определителя будут десятичными дробями и применять какие-то ухищрения для упрощения вычислений нецелесообразно.

Вперед: Обратная матрица Наверх: Матрицы Назад: Транспонирование матрицы


Обратная матрица

Определение 14.8 Матрица $ B$ называется обратной матрицей для квадратной матрицы $ A$ , если [image] .

Из определения следует, что обратная матрица $ B$ будет квадратной матрицей того же порядка, что и матрица $ A$ (иначе одно из произведений $ AB$ или $ BA$ было бы не определено).

Обратная матрица для матрицы $ A$ обозначается [image] . Таким образом, если [image] существует, то [image] .

Из определения обратной матрицы следует, что матрица $ A$ является обратной для матрицы [image] , то есть [image] . Про матрицы $ A$ и [image] можно говорить, что они обратны друг другу или взаимно обратны.

Предложение 14.20 Если матрица $ A$ имеет обратную, то [image] и [image] .

Доказательство. Так как определитель произведения матриц равен произведению определителей ( предложение 14.7), то [image] . По следствию 14.1 [image] , поэтому [image] , что невозможно при [image] . Из предыдущего равенства следует также [image] .

Последнее предложение можно сформулировать в следующем виде.

Если определитель матрицы равен нулю, то обратная к ней не существует.

Так как для нахождения обратной матрицы важно, равен ли определитель марицы нулю или нет, то введем следующие определения.

Определение 14.9 Квадратную матрицу $ A$ назовем вырожденной или особенной матрицей, если [image] , и невырожденной или неособенной матрицей, если [image] .

Предложение 14.21 Если обратная матрица существует, то она единственна.

Доказательство. Пусть две матрицы $ B$ и $ C$ являются обратными для матрицы $ A$ . Тогда

и

Следовательно, [image] .

Предложение 14.22 Если квадратная матрица $ A$ является невырожденной, то обратная для нее существует и

(14.14)

где [image] -- алгебраические дополнения к элементам [image] .

Доказательство. Так как для невырожденной матрицы $ A$ правая часть равенства (14.14) всегда существует, то достаточно показать, что эта правая часть является обратной матрицей для матрицы $ A$ . Обозначим правую часть равенства (14.14) буквой $ B$ . Тогда нужно проверить, что [image] и что [image] . Докажем первое из этих равенств, второе доказывается аналогично.

Пусть [image] . Найдем элементы матрицы $ C$ , учитывая, что [image] :

Если [image] , то по предложению 14.17 сумма справа равна нулю, то есть [image] при [image] .

Если [image] , то

Сумма справа представляет собой разложение определителя матрицы $ A$ по $ i$ -ой строке (предложение 14.16). Таким образом,

Итак, в матрице $ C$ диагональные элементы равны 1, а остальные равны нулю, то есть [image] .

Результаты предложений 14.20, 14.21, 14.22 соберем в одну теорему.

Теорема 14.1 Обратная матрица для квадратной матрицы $ A$ существует тогда и только тогда, когда матрица $ A$ -- невырожденная, обратная матрица единственна, и справедлива формула (14.14).

Замечание 14.12 Следует обратить особое внимание на места, занимаемые алгебраическими дополнениями в формуле обратной матрицы: первый индекс показывает номер столбца, а второй -- номер строки, в которые нужно записать вычисленное алгебраическое дополнение.

Пример 14.7 Найдите обратную матрицу для матрицы [image] .

Решение. Находим определитель

Так как [image] , то матрица $ A$ -- невырожденная, и обратная для нее существует.

Находим алгебраические дополнения:

Составляем обратную матрицу, размещая найденные алгебраические дополнения так, чтобы первый индекс соответствовал столбцу, а второй -- строке:

(14.15)

Полученная матрица и служит ответом к задаче.

Замечание 14.13 В предыдущем примере было бы точнее ответ записать так:

(14.16)

Однако запись (14.15) более компактна и с ней удобнее проводить дальнейшие вычисления, если таковые потребуются. Поэтому запись ответа в виде (14.15) предпочтительнее, если элементы матриц -- целые числа. И наоборот, если элементы матрицы $ A$ -- десятичные дроби, то обратную матрицу лучше записать без множителя [image] впереди.

Замечание 14.14 При нахождении обратной матрицы приходится выполнять довольно много вычислений и необычно правило расстановки алгебраических дополнений в итоговой матрице. Поэтому велика вероятность ошибки. Чтобы избежать ошибок следует делать проверку: вычислить произведение исходной матрицы на итоговую в том или ином порядке. Если в результате получится единичная матрица, то обратная матрица найдена правильно. В противном случае нужно искать ошибку.

Пример 14.8 Найдите обратную матрицу для матрицы [image] .

Решение.

-- существует.

Ответ: .

Нахождение обратной матрицы по формуле (14.14) требует слишком много вычислений. Для матриц четвертого порядка и выше это неприемлемо. Реальный алгоритм нахождения обратной матрицы будет приведен позже.

Вперед: Ранг матрицы Наверх: Матрицы Назад: Определители


Ранг матрицы

В этом разделе рассмотрим еще одну важную числовую характиристику матрицы, связанную с тем, насколько ее строки (столбцы) зависят друг от друга.

Определение 14.10 Пусть дана матрица $ A$ размеров [image] и число $ k$ , не превосходящее наименьшего из чисел $ m$ и $ n$ : . Выберем произвольно $ k$ строк матрицы $ A$ и $ k$ столбцов (номера строк могут отличаться от номеров столбцов). Определитель матрицы, составленной из элементов, стоящих на пересечении выбранных $ k$ строк и $ k$ столбцов, называется минором порядка $ k$ матрицы $ A$ .

Пример 14.9 Пусть [image] .

Минором первого порядка является любой элемент матрицы. Так 2, $ -5$ , $ -4$ -- миноры первого порядка.

Миноры второго порядка:

  1. возьмем строки 1, 2, столбцы 1, 2, получим минор [image] ;
  2. возьмем строки 1, 3, столбцы 2, 4, получим минор [image] ;
  3. возьмем строки 2, 3, столбцы 1, 4, получим минор

Миноры третьего порядка:

строки здесь можно выбрать только одним способом,

  1. возьмем столбцы 1, 3, 4, получим минор [image] ;
  2. возьмем столбцы 1, 2, 3, получим минор [image] .

Предложение 14.23 Если все миноры матрицы $ A$ порядка $ k$ равны нулю, то все миноры порядка [image] , если такие существуют, тоже равны нулю.

Доказательство. Возьмем произвольный минор порядка [image] . Это определитель матрицы порядка [image] . Разложим его по первой строке. Тогда в каждом слагаемом разложения один из множителей будет являться минором порядка $ k$ исходной матрицы. По условию миноры порядка $ k$ равны нулю. Поэтому и минор порядка [image] будет равен нулю.

Определение 14.11 Рангом матрицы $ A$ называется наибольший из порядков миноров матрицы $ A$ , отличных от нуля. Ранг нулевой матрицы считается равным нулю.

Единое, стандартное, обозначение ранга матрицы отсутствует. Следуя учебнику [1], мы будем обозначать его [image] .

Пример 14.10 Матрица $ A$ примера 14.9 имеет ранг 3, так как есть минор третьего порядка, отличный от нуля, а миноров четвертого порядка нет.

Ранг матрицы [image] равен 1, так как есть ненулевой минор первого порядка (элемент матрицы [image] ), а все миноры второго порядка равны нулю.

Ранг невырожденной квадратной матрицы порядка $ n$ равен $ n$ , так как ее определитель является минором порядка $ n$ и у невырожденной матрицы отличен от нуля.

Предложение 14.24 При транспонировании матрицы ее ранг не меняется, то есть [image] .

Доказательство. Транспонированный минор исходной матрицы $ A$ будет являться минором транспонированной матрицы [image] , и наоборот, любой минор [image] является транспонированным минором исходной матрицы $ A$ . При транспонировании определитель (минор) не меняется ( предложение 14.6). Поэтому если все миноры порядка [image] в исходной матрице равны нулю, то все миноры того же порядка в [image] тоже равны нулю. Если же минор порядка $ r$ в исходной матрице отличен от нуля, то в [image] есть минор того же порядка, отличный от нуля. Следовательно, [image] .

Определение 14.12 Пусть ранг матрицы равен $ r$ . Тогда любой минор порядка $ r$ , отличный от нуля, называется базисным минором.

Пример 14.11 Пусть [image] . Определитель матрицы $ A$ равен нулю, так как третья строка равна сумме первых двух. Минор второго порядка, расположенный в первых двух строках и первых двух столбцах, равен [image] . Следовательно, ранг матрицы равен двум, и рассмотренный минор является базисным.

Базисным минором является также минор, расположенный, скажем, в первой и третьей строках, первом и третьем столбцах: . Базисным будет минор во второй и третьей строках, первом и третьем столбцах: .

Минор в первой и второй строках, втором и третьем столбцах [image] равен нулю и поэтому не будет базисным. Читатель может самостоятельно проверить, какие еще миноры второго порядка будут базисными, а какие нет.

Так как столбцы (строки) матрицы можно складывать, умножать на числа, образовывать линейные комбинации, то можно ввести определения линейной зависимости и линейной независимости системы столбцов (строк) матрицы. Эти определения аналогичны таким же определениям 10.14, 10.15 для векторов.

Определение 14.13 Система столбцов (строк) называется линейно зависимой, если существует такой набор коэффициентов, из которых хотя бы один отличен от нуля, что линейная комбинация столбцов (строк) с этими коэффициентами будет равна нулю.

Определение 14.14 Система столбцов (строк) является линейно независимой, если из равенства нулю линейной комбинации этих столбцов (строк) следует, что все коэффициенты этой линейной комбинации равны нулю.

Верно также следующеее предложение, аналогичное предложению 10.6.

Предложение 14.25 Система столбцов (строк) является линейно зависимой тогда и только тогда, когда один из столбцов (одна из строк) является линейной комбинацией других столбцов (строк) этой системы.

Сформулируем теорему, которая называется теорема о базисном миноре.

Теорема 14.2 Любой столбец матрицы является линейной комбинацией столбцов, проходящих через базисный минор.

Доказательство можно найти в учебниках по линейной алгебре, например, в [1], [3].

Предложение 14.26 Ранг матрицы равен максимальному числу ее столбцов, образующих линейно независимую систему.

Доказательство. Пусть ранг матрицы $ A$ равен $ r$ . Возьмем столбцы, проходящие через базисный минор. Предположим, что эти столбцы образуют линейно зависимую систему. Тогда один из столбцов является линейной комбинацией других. Поэтому в базисном миноре один столбец будет линейной комбинацией других столбцов. По предложениям 14.15 и 14.18 этот базисный минор должен быть равен нулю, что противоречит определению базисного минора. Следовательно, предположение о том, что столбцы, проходящие через базисный минор, линейно зависимы, не верно. Итак, максимальное число столбцов, образующих линейно независимую систему, больше либо равно $ r$ .

Предположим, что [image] столбцов образуют линейно независимую систему. Составим из них матрицу $ B$ . Все миноры матрицы $ B$ являются минорами матрицы $ A$ . Поэтому базисный минор матрицы $ B$ имеет порядок не больше $ r$ . По теореме о базисном миноре, столбец, не проходящий через базисный минор матрицы $ B$ , является линейной комбинацией столбцов, проходящих через базисный минор, то есть столбцы матрицы $ B$ образуют линейно зависимую систему. Это противоречит выбору столбцов, образующих матрицу $ B$ . Следовательно, максимальное число столбцов, образующих линейно независимую систему, не может быть больше $ r$ . Значит, оно равно $ r$ , что и утверждалось.

Предложение 14.27 Ранг матрицы равен максимальному числу ее строк, образующих линейно независимую систему.

Доказательство. По предложению 14.24 ранг матрицы при транспонировании не меняется. Строки матрицы становятся ее столбцами. Максимальное число новых столбцов транспонированной матрицы, (бывших строк исходной) образующих линейно независимую систему, равно рангу матрицы.

Предложение 14.28 Если определитель матрицы равен нулю, то один из его столбцов (одна из строк) является линейной комбинацией остальных столбцов (строк).

Доказательство. Пусть порядок матрицы $ A$ равен $ n$ . Определитель является единственным минором квадратной матрицы, имеющим порядок $ n$ . Так как он равен нулю, то [image] . Следовательно, система из $ n$ столбцов (строк) является линейно зависимой, то есть один из столбцов (одна из строк) является линейной комбинацией остальных.

Результаты предложений 14.15, 14.18 и 14.28 дают следующую теорему.

Теорема 14.3 Определитель матрицы равен нулю тогда и только тогда, когда один из ее столбцов (одна из строк) является линейной комбинацией остальных столбцов (строк).

Нахождение ранга матрицы с помощью вычисления всех ее миноров требует слишком большой вычислительной работы. (Читатель может проверить, что в квадратной матрице четвертого порядка 36 миноров второго порядка.) Поэтому для нахождения ранга применяется другой алгоритм. Для его описания потребуется ряд дополнительных сведений.

Определение 14.15 Назовем элементарными преобразованиями матриц следующие действия над ними:

1) перестановка строк или столбцов;
2) умножение строки или столбца на число отличное от нуля;
3) добавление к одной из строк другой строки, умноженной на число или добавление к одному из столбцов другого столбца, умноженного на число.

Предложение 14.29 При элементарных преобразованиях ранг матрицы не меняется.

Доказательство. Пусть ранг матрицы $ A$ равен $ r$ , $ A'$ -- матрица, получившаяся в результате выполнения элементарного преобразования.

Рассмотрим перестановку строк. Пусть $ M$ -- минор матрицы $ A$ , тогда в матрице $ A'$ есть минор $ M'$ , который или совпадает с $ M$ , или отличается от него перестановкой строк. И наоборот, любому минору $ N'$ матрицы $ A'$ можно сопоставить минор матрицы $ A$ или совпадающий с $ N'$ , или отличающийся от него порядком строк. Поэтому из того, что в матрице $ A$ все миноры порядка [image] равны нулю, следует, что в матрице $ A'$ тоже все миноры этого порядка равны нулю. И так как в матрице $ A$ есть минор порядка $ r$ , отличный от нуля, то и в матрице $ A'$ тоже есть минор порядка $ r$ , отличный от нуля, то есть [image] .

Рассмотрим умножение строки на число [image] , отличное от нуля. Минору $ M$ из матрицы $ A$ соответствует минор $ M'$ из матрицы $ A'$ или совпадающий с $ M$ , или отличающийся от него только одной строкой, которая получается из строки минора $ M$ умножением на число, отличное от нуля. В последнем случае [image] . Во всех случаях или $ M$ и $ M'$ одновременно равны нулю, или одновременно отличны от нуля. Следовательно, [image] .

Пусть к $ i$ -ой строке матрицы $ A$ прибавлена ее $ j$ -ая строка, умноженная на число [image] . Рассмотрим миноры порядка [image] в матрице $ A'$ . Если через минор $ M'$ не проходит $ i$ -ая строка, то он совпадает с минором $ M$ , расположенным в тех же строках и столбцах в матрице $ A$ , и следовательно, равен нулю.

Если через минор $ M'$ проходят и $ i$ -ая и $ j$ -ая строки, то он получается из минора $ M$ , расположенного в тех же строках и столбцах матрицы $ A$ , прибавлением к $ i$ -ой строке минора $ M$ $ j$ -ой строки, умноженной на [image] . По свойству определителя [image] . Следовательно, [image] .

Пусть через минор $ M'$ проходит $ i$ -ая строка и не проходит $ j$ -ая. Тогда $ M'$ отличается от $ M$ $ i$ -ой строкой. Эта строка в $ M'$ является строкой $ M$ , к которой добавлены элементы $ j$ -ой строки, умноженные на [image] . По свойствам определителей [image] , где $ N$ -- минор порядка [image] матрицы $ A$ , стоящий в $ j$ -ой строке и в тех же строках, что и минор $ M$ , исключая $ i$ -ую, а знак " [image] " связан с возможным изменением порядка строк. Так как все миноры порядка [image] в матрице $ A$ равны нулю, то [image] .

Итак, в матрице $ A'$ все миноры порядка [image] равны нулю. Следовательно, [image] , то есть при выполнении элементарного преобразования третьего типа ранг не может повыситься. Предположим, что [image] , и [image] . Тогда в матрице $ A'$ к $ i$ -ой строке прибавим $ j$ -ую строку, умноженную на число [image] . В результате получим исходную матрицу $ A$ . По только что доказанному [image] . Получили противоречие: . Предположение [image] не верно, следовательно, [image] .

Алгоритм вычисления ранга матрицы похож на алгоритм вычисления определителя и заключается в том, что с помощью элементарных преобразований матрица приводится к простому виду, для которого найти ранг не представляет труда. Так как при каждом преобразовании ранг не менялся, то, вычислив ранг преобразованной матрицы, мы тем самым находим ранг исходной матрицы.

Алгоритм нахождения ранга матрицы.

Пусть требуется вычислить ранг матрицы $ A$ размеров [image] . Если матрица $ A$ нулевая, то по определению [image] . В противном случае с помощью перестановки строк и столбцов матрицы добиваемся того, чтобы в левом верхнем углу матрицы стоял ненулевой элемент. Итак, считаем, что [image] .

Первую строку оставляем без изменений. Ко второй строке прибавляем первую, умноженную на число [image] . В результате вторая строка принимает вид

Затем к третьей строке прибавляем первую строку, умноженную на число [image] . В результате третья строка принимает вид

Процесс продолжаем до тех пор, пока не получим нуль на первом месте в последней строке.

Преобразованная матрица имеет вид

Если все строки, начиная со второй, в полученной матрице нулевые, то ее ранг равен 1, так как есть минор первого порядка, отличный от нуля [image] . В противном случае перестановкой строк и столбцов матрицы с номерами, большими единицы, добиваемся, чтобы второй элемент второй строки был отличен от нуля. Итак, считаем, что [image] .

Первую и вторую строки оставляем без изменений. К третьей строке прибавляем вторую, умноженную на число [image] . В результате получим, что второй элемент третьей строки равен нулю. Затем к четвертой строке прибавляем вторую, умноженную на число [image] , и т.д. В результате получаем матрицу

Если все строки, начиная с третьей, нулевые, то [image] , так как минор [image] . В противном случае перестановкой строк и столбцов с номерами, большими двух, добиваемся, чтобы третий элемент третьей строки был отличен от нуля. Далее, добавлением третьей строки, умноженной на соответствующие числа, к строкам с большими номерами получаем нули в третьем столбце, начиная с четвертого элемента, и т.д.

На каком-то этапе мы придем к матрице, у которой все строки, начиная с [image] -ой , равны нулю (или отсутствуют при [image] ), а минор в первых $ r$ строках и первых $ r$ столбцах является определителем треугольной матрицы с ненулевыми элементами на диагонали. Ранг такой матрицы равен $ r$ . Следовательно, [image] .

Замечание 14.15 В предложенном алгоритме нахождения ранга матрицы все вычисления должны производиться без округлений. Сколь угодно малое изменение хотя бы в одном из элементов промежуточных матриц может привести к тому, что полученный ответ будет отличаться от ранга исходной матрицы на несколько единиц.

Замечание 14.16 Если в исходной матрице элементы были целыми числами, то и вычисления удобно производить без использования дробей. Поэтому на каждом этапе целесообразно умножать строки на такие числа, чтобы при вычислениях дроби не возникали.

Пример 14.12 Найдите ранг матрицы [image] .

Решение. Первую строку оставляем без изменений. Чтобы избежать появления дробей, умножим вторую, третью и четвертую строки на 2:

Первую строку умножим на $ (-3)$ и прибавим ко второй. Получим строку [image] . Первую строку умножим на $ (-5)$ и прибавим к третьей. Получим строку [image] . Первую строку умножим на $ (-3)$ и прибавим к четвертой. Получим строку [image] . В итоге имеем матрицу

Вторую строку оставляем без изменений. К третьей строке прибавляем вторую, умноженную на 2. Получим строку [image] . К четвертой строке прибавляем вторую. Получим нулевую строку. Преобразованная матрица имеет вид

Поменяем местами третий и четвертый столбцы:

Базисный минор матрицы [image] стоит в первых трех столбцах и первых трех строках, [image] . Следовательно, [image] .

Замечание 14.17 В приведенном примере вычисления были бы проще, если сначала четвертый столбец сделать первым и четвертую строку сделать первой. Но для того, чтобы догадаться об этом, нужно анализировать вопросы делимости чисел, что достаточно сложно описать в алгоритме, пригодном для всех случаев.

Вперед: Системы линейных уравнений Наверх: Матрицы Назад: Обратная матрица


Системы линейных уравнений

Определение 15.1 Системой $ m$ линейных уравнений с $ n$ неизвестными называется система уравнений вида

(15.1)

Система уравнений называется однородной, если [image] и неоднородной в противном случае.

Систему (15.1) можно записать также в виде

или в виде

Но наиболее удобной формой записи системы (15.1) является матричная запись. Введем следующие матрицы: матрица системы $ A$ , столбец неизвестных $ x$ и столбец свободных членов $ b$ ,

Читатель, выполнив матричное умножение, легко проверит, что с помощью введенных обозначений систему (15.1) можно записать в виде

(15.2)

Определение 15.2 Решением системы (15.1) называется любой набор чисел [image] , которые при подстановке в систему вместо неизвестных [image] превращают все уравнения системы в верные равенства.

Решением системы (15.2) называется столбец чисел [image] , который после подстановки в уравнение вместо столбца $ x$ превращает уравнение (15.2) в верное матричное равенство.

Подразделы
  • Правило Крамера
  • Существование решения системы линейных уравнений общего вида
  • Однородная система уравнений
  • Структура решений неоднородной системы линейных уравнений
  • Алгоритм нахождения решений произвольной системы линейных уравнений (метод Гаусса)


Правило Крамера

Рассмотрим частный случай системы линеных уравнений (15.1), когда [image] , то есть когда число уравнений совпадает с числом неизвестных. Именно такие системы при [image] или [image] рассматриваются в школе.

Если число уравнений равно числу неизвестных, то матрица $ A$ исходной системы -- квадратная, порядка $ n$ , $ x$ и $ b$ -- столбцы высоты $ n$ . Предположим, что [image] . Тогда по теореме 14.1 существует обратная матрица. Умножив слева обе части равенства (15.2) на [image] , получим

Таким образом, система уравнений (15.1) имеет единственное решение и оно в матричной форме может быть записано в виде

(15.3)

Это так называемый матричный способ решения системы линейных уравнений.

Введем следующие обозначения. Пусть [image] , [image] -- определитель матрицы, полученной из матрицы $ A$ заменой столбца с номером $ i$ на столбец $ b$ свободных членов, [image] :

Теорема 15.1 (Правило Крамера) Если в системе $ n$ линейных уравнений с $ n$ неизвестными [image] , то система имеет решение и притом единственное. Это решение задается формулами

Доказательство. По теореме 14.1 обратная матрица находится по формуле

где [image] -- алгебраические дополнения. Тогда из (15.3) следует, что

Заметим, что по формуле (14.13) разложение определителя [image] по первому столбцу в точности совпадает с первым элементом матрицы-столбца в правой части последнего равенства, разложение определителя [image] по второму столбцу дает второй элемент матрицы-столбца и т.д. Поэтому [image] , откуда и следует утверждение теоремы.

Пример 15.1 Решите систему уравнений

Решение. Выписываем матрицу системы [image] и столбец свободных членов [image] .

Находим определитель системы: . Определитель отличен от нуля, следовательно, можно применить правило Крамера. Находим дополнительные определители:

Итак,

Ответ: .

Замечание 15.1 При кажущейся простоте правила Крамера применяется оно для систем более, чем из трех уравнений, только в каких-то исключительных случаях. Дело в том, что вычисление определителей требует выполнения большого числа арифметических операций и существует способ, требующий меньшей вычислительной работы. Этот способ будет описан позже.

Замечание 15.2 При решении системы уравнений приходится выполнять довольно большой объем вычислений. Поэтому велика вероятность ошибки. Чтобы обнаружить эту ошибку, рекомендуется выполнить проверку ответа, то есть подставить полученные значения неизвестных в уравнения системы. Если все уравнения превратятся в верные равенства, то решение найдено верно. В противном случае при вычислениях где-то допущена ошибка.

Вперед: Существование решения системы линейных уравнений общего вида Наверх: Системы линейных уравнений Назад: Системы линейных уравнений


Существование решения системы линейных уравнений общего вида

Определение 15.3 Система (15.1) называется совместной, если она имеет хотя бы одно решение, и несовместной -- в противном случае, то есть в случае, когда решений у системы нет.

Вопрос о том, имеет ли система решение или нет, связан не только с соотношением числа уравнений и числа неизвестных. Например, система из трех уравнений с двумя неизвестными

(15.4)

имеет решение [image] , [image] и даже имеет бесконечно много решений, а система из двух уравнений с тремя неизвестными

(15.5)

решений не имеет, то есть является несовместной.

Ответ на вопрос о совместности произвольной системы уравнений (15.1) дает приведенная ниже теорема.

Определение 15.4 Расширенной матрицей системы линейных уравнений (15.1) называется матрица [image] , отличающаяся от матрицы $ A$ системы наличием дополнительного столбца из свободных членов:

Предложение 15.1 Ранг расширенной матрицы [image] либо равен рангу матрицы системы $ A$ , либо больше его на единицу.

Доказательство. Так как любая линейно независимая система столбцов матрицы $ A$ является линейно независимой системой столбцов матрицы [image] , то в силу предложения 14.26 [image] .

Пусть [image] . Предположим, что [image] , [image] . Тогда в матрице [image] есть линейно независимая система из [image] столбцов. Среди этих столбцов может быть только один, не принадлежащий матрице $ A$ . Тогда подсистема остальных [image] столбцов, принадлежащих матрице $ A$ , должна быть линейно независимой. Следовательно, [image] . Получили противоречие. Предположение, что [image] , неверно.

Теорема 15.2 (Теорема Кронекера-Капелли.) Система линейных уравнений (15.1) является совместной тогда и только тогда, когда ранг матрицы системы $ A$ равен рангу расширенной матрицы [image] .

Доказательство. Оно распадается на два этапа.

1. Пусть система имеет решение. Покажем, что [image] .

Пусть набор чисел [image] является решением системы. Обозначим через [image] $ i$ -ый столбец матрицы $ A$ , [image] . Тогда [image] , то есть столбец свободных членов является линейной комбинацией столбцов матрицы $ A$ . Пусть [image] . Предположим, что [image] . Тогда по предложению 15.1 [image] . Выберем в [image] базисный минор $ M$ . Он имеет порядок [image] . Столбец $ b$ свободных членов обязан проходить через этот минор, иначе он будет базисным минором матрицы $ A$ . Столбец свободных членов в миноре $ M$ является линейной комбинацией столбцов матрицы $ A$ . В силу свойств определителя ( предложения 14.13, 14.18) [image] , где [image] -- определитель, который получается из минора $ M$ заменой столбца свободных членов на столбец [image] . Если столбец [image] проходил через минор $ M$ , то в [image] , будет два одинаковых столбца и, следовательно, [image] . Если столбец [image] не проходил через минор $ M$ , то [image] будет отличаться от минора порядка [image] матрицы $ A$ только порядком столбцов. Так как [image] , то [image] . Таким образом, [image] , что противоречит определению базисного минора. Значит, предположение, что [image] , неверно.

2. Пусть [image] . Покажем, что система имеет решение. Так как [image] , то базисный минор $ M$ матрицы $ A$ является базисным минором матрицы [image] . Пусть через минор $ M$ проходят столбцы [image] . Тогда по теореме о базисном миноре в матрице [image] столбец свободных членов является линейной комбинацией указанных столбцов:

(15.6)

Положим [image] , [image] , [image] , [image] , остальные неизвестные возьмем равными нулю. Тогда при этих значениях [image] получим

В силу равенства (15.6) [image] . Последнее равенство означает, что набор чисел [image] является решением системы. Существование решения доказано.

В рассмотренной выше системе (15.4) [image] , и система является совместной. В системе (15.5) [image] , [image] , и система является несовместной.

Замечание 15.3 Хотя теорема Кронекера-Капелли дает возможность определить, является ли система совместной, применяется она довольно редко, в основном в теоретических исследованиях. Причина заключается в том, что вычисления, выполняемые при нахождении ранга матрицы, в основном совпадают с вычислениями при нахождении решения системы. Поэтому, обычно вместо того, чтобы находить [image] и [image] , ищут решение системы. Если его удается найти, то узнаем, что система совместна и одновременно получаем ее решение. Если решение не удается найти, то делаем вывод, что система несовместна.

Вперед: Однородная система уравнений Наверх: Системы линейных уравнений Назад: Правило Крамера


Однородная система уравнений

Предложение 15.2 Однородная система уравнений

(15.7)

всегда является совместной.

Доказательство. Для этой системы набор чисел [image] , [image] , [image] , [image] является решением.

В этом разделе мы будем использовать матричную запись системы: .

Предложение 15.3 Сумма решений однородной системы линейных уравнений является решением этой системы. Решение, умноженное на число, тоже является решением.

Доказательство. Пусть $ c$ и $ d$ служат решениями системы [image] . Тогда [image] и [image] . Пусть [image] . Тогда

Так как [image] , то $ g$ -- решение.

Пусть [image] -- произвольное число, [image] . Тогда

Так как [image] , то $ h$ -- решение.

Следствие 15.1 Если однородная система линейных уравнений имеет ненулевое решение, то она имеет бесконечно много различных решений.

Действительно, умножая ненулевое решение на различные числа, будем получать различные решения.

Определение 15.5 Будем говорить, что решения [image] системы [image] образуют фундаментальную систему решений, если столбцы [image] образуют линейно независимую систему и любое решение системы является линейной комбинацией этих столбцов.

Определение 15.6 Пусть [image] -- фундаментальная система решений однородной системы [image] . Тогда выражение

где [image] -- произвольные числа, будем называть общим решением системы [image] .

Из определения фундаментальной системы решений следует, что любое решение однородной системы может быть получено из общего решения при некоторых значениях [image] . И наоборот, при любых фиксированных числовых значениях [image] из общего решения получим решение однородной системы.

Как находить фундаментальную систему решений мы увидим позже, в разделе "Алгоритм нахождения решений произвольной системы линейных уравнений (метод Гаусса)".

Теорема 15.3 Пусть [image] -- фундаментальная система решений однородной системы [image] . Тогда [image] , где $ n$ -- число неизвестных в системе.

Доказательство читатель может найти, например, в [1].

Вперед: Структура решений неоднородной системы линейных уравнений Наверх: Системы линейных уравнений Назад: Существование решения системы линейных уравнений общего вида


Структура решений неоднородной системы линейных уравнений

Систему неоднородных уравнений запишем в матричном виде [image] , где матрица $ A$ имеет размеры [image] .

Предложение 15.4 Пусть $ c$ и $ d$ -- решения неоднородной системы [image] . Тогда их разность [image] является решением однородной системы с той же матрицей, то есть решением системы [image] .

Доказательство. По условию [image] и [image] . Тогда

Так как [image] , то $ g$ -- решение однородной системы.

Предложение 15.5 Пусть $ c$ -- решение неоднородной системы [image] , $ g$ -- любое решение однородной системы [image] . Тогда [image] -- решение неоднородной системы.

Доказательство предоставляется читателю.

Определение 15.7 Пусть [image] -- некоторое решение неоднородной системы линейных уравнений [image] , $ z$ -- общее решение однородной системы [image] . Тогда выражение [image] называется общим решением неоднородной системы.

Учитывая запись общего решения однородной системы через фундаментальную систему ее решений [image] , получаем для общего решения неоднородной системы формулу

Из двух последних предложений следует, что любое решение неоднородной системы может быть получено из общего решения при некоторых числовых значениях коэффициентов [image] .

Теорема 15.4 Система линейных уравнений [image] может иметь либо бесконечно много решений, либо одно решение, либо не иметь решений.

Доказательство. Пусть система имеет решение [image] . Если однородная система [image] имеет только одно решение, то из формулы общего решения будет следовать, что [image] -- единственное решение неоднородной системы. Если однородная система имеет хотя бы одно ненулевое решение, то ее фундаментальная система решений будет состоять не менее, чем из одного решения. В формуле общего решения неоднородной системы будет произвольный коэффициент [image] , и при различных его значениях мы будем получать различные решения неоднородной системы.

Вперед: Алгоритм нахождения решений произвольной системы линейных уравнений (метод Гаусса) Наверх: Системы линейных уравнений Назад: Однородная система уравнений


Алгоритм нахождения решений произвольной системы линейных уравнений (метод Гаусса)

Пусть дана система $ m$ линейных уравнений с $ n$ неизвестными [image] . Требуется найти ее общее решение, если она совместна, или установить ее несовместность. Метод, который будет изложен в этом разделе, близок к методу вычисления определителя 5.1.с и к методу нахождения ранга матрицы (раздел 5.8). Предлагаемый алгоритм называется методом Гаусса или методом последовательного исключения неизвестных.

Выпишем расширенную матрицу системы

Назовем элементарными операциями следующие действия с матрицами:

  1. перестановка строк;
  2. умножение строки на число, отличное от нуля;
  3. сложение строки с другой строкой, умноженной на число.

Отметим, что при решении системы уравнений, в отличие от вычисления определителя и нахождения ранга, нельзя оперировать со столбцами.

Читатель легко проверит, что если по матрице, полученной из [image] выполнением элементарной операции, восстановить систему уравнений, то новая система будет равносильна исходной.

Цель алгоритма -- с помощью применения последовательности элементарных операций к матрице [image] добиться, чтобы каждая строка, кроме, быть может, первой, начиналась с нулей, и число нулей до первого ненулевого элемента в каждой следующей строке было больше, чем в предыдущей.

Шаг алгоритма заключается в следующем. Находим первый ненулевой столбец в матрице [image] . Пусть это будет столбец с номером $ i$ . Находим в нем ненулевой элемент и строку с этим элементом меняем местами с первой строкой. Чтобы не нагромождать дополнительных обозначений, будем считать, что такая смена строк в матрице [image] уже произведена, то есть [image] . Тогда ко второй строке прибавим первую, умноженную на число [image] , к третьей строке прибавим первую, умноженную на число [image] , и т.д. В результате получим матрицу

(Первые нулевые столбцы, как правило, отсутствуют.)

Если в матрице [image] встретилась строка с номером $ k$ , в которой все элементы [image] равны нулю, а [image] , то выполнение алгоритма останавливаем и делаем вывод, что система несовместна. Действительно, восстанавливая систему уравнений по расширенной матрице, получим, что $ k$ -ое уравнение будет иметь вид

Этому уравнению не удовлетворяет ни один набор чисел [image] .

Матрицу [image] можно записать в виде

где

По отношению к матрице [image] выполняем описанный шаг алгоритма. Получаем матрицу

где $ j>i$ , [image] . Эту матрицу снова можно записать в виде

и к матрице [image] снова применим описанный выше шаг алгоритма.

Процесс останавливается, если после выполнения очередного шага новая уменьшенная матрица состоит из одних нулей или если исчерпаны все строки. Заметим, что заключение о несовместности системы могло остановить процесс и ранее.

Если бы мы не уменьшали матрицу, то в итоге пришли бы к матрице вида

Далее выполняется так называемый обратный ход метода Гаусса. По матрице [image] составляем систему уравнений. В левой части оставляем неизвестные с номерами, соответствующими первым ненулевым элементам в каждой строке, то есть [image] . Заметим, что [image] . Остальные неизвестные переносим в правую часть. Считая неизвестные в правой части некоторыми фиксированными величинами, несложно выразить через них неизвестные левой части.

Теперь, придавая неизвестным в правой части произвольные значения и вычисляя значения переменных левой части, мы будем находить различные решения исходной системы [image] . Чтобы записать общее решение, нужно неизвестные в правой части обозначить в каком-либо порядке буквами [image] , включая и те неизвестные, которые явно не выписаны в правой части из-за нулевых коэффициентов, и тогда столбец неизвестных можно записать в виде столбца, где каждый элемент будет линейной комбинацией произвольных величин [image] (в частности, просто произвольной величиной [image] ). Эта запись и будет общим решением системы.

Если система была однородной, то получим общее решение однородной системы. Коэффициенты при [image] , взятые в каждом элементе столбца общего решения, составят первое решение из фундаментальной системы решений, коэффициенты при [image] -- второе решение и т.д.

Фундаментальную систему решений однородной системы можно получить и другим способом. Для этого одному переменному, перенесенному в правую часть, нужно присвоить значение 1, а остальным -- нули. Вычислив значения переменных в левой части, получим одно решение из фундаментальной системы. Присвоив другому переменному в правой части значение 1, а остальным -- нули, получим второе решение из фундаментальной системы и т.д.

Замечание 15.4 У читателя может возникнуть вопрос: "Зачем рассматривать случай, когда некоторые столбцы матрицы [image] нулевые? Ведь в этом случае соответствующие им переменные в системе уравнений в явном виде отсутствуют." Но дело том, что в некоторых задачах, например, при нахождении собственных чисел матрицы, такие системы возникают, и игнорировать отсутствующие переменные нельзя, так как при этом происходит потеря важных для задачи решений.

Пример 15.2 Найдите общее решение системы уравнений

где неизвестными являются [image] .

Решение. Выпишем расширенную матрицу системы

Прибавим ко второй строке первую, умноженную на число [image] , к третьей строке прибавим первую, умноженную на [image] . В результате получим

Прибавим к третьей строке вторую, умноженную на число [image] . Получим

Прямой ход метода Гаусса закончен. Выписываем по матрице [image] систему уравнений

Переносим в правую часть неизвестные [image] (неизвестное [image] реально в ней присутствовать не будет, коэффициент перед ним равен нулю). Получаем

Пусть [image] , [image] , [image] , [image] . Из уравнений находим:

Ответ: , [image] , [image] , [image] , [image] , [image] , где [image] , [image] , [image] , [image] -- произвольные числа.

Замечание 15.5 В процессе решения можно также установить, какие ранги у матриц $ A$ и [image] и где расположены их базисные миноры. В предыдущем примере [image] , базисный минор расположен в строках с номерами 1, 2, столбцах с номерами 2, 5.

Пример 15.3 Найдите общее решение системы уравнений

Решение. Запишем расширенную матрицу системы:

Ко второй строке прибавим первую, умноженную на $ (-2)$ , к третьей строке прибавим первую, умноженную на $ (-4)$ , к четвертой строке прибавим первую, умноженную на $ (-5)$ :

Вторую строку, умноженную на $ (-1)$ , прибавим к третьей:

В третьей строке все элементы [image] равны нулю, а элемент [image] . Значит, система несовместна.

Ответ: Система несовместна.

Пример 15.4 Решите систему

Решение. Имеем:

Первую строку, умноженную на числа [image] , $ (-1)$ , $ (-2)$ , прибавим соответственно ко второй, третьей и четвертой строкам:

К третьей строке прибавим вторую, умноженную на [image] . Получим

К четвертой строке прибавим третью, умноженную на [image] :

Выписываем по матрице [image] систему уравнений:

Находим последовательно значения неизвестных:

Ответ: .

Замечание 15.6 Так же, как и при решении системы уравнений по правилу Крамера, при использовании метода Гаусса приходится выполнять большой объем вычислительной работы. Из-за этого вполне возможно, что будет допущена какая-либо ошибка в вычислениях. Поэтому желательно после решения системы выполнить проверку, то есть подставить полученные значения неизвестных в уравнения системы. Для выполнения полной проверки подстановку нужно произвести во все уравнения системы. Если же по каким-то причинам это не выполнимо, то можно подставить найденные значения в одно уравнение. В отличие от правила Крамера в методе Гаусса эту подстановку нужно производить в ПОСЛЕДНЕЕ уравнение исходной системы. При наличии в этом уравнении всех неизвестных эта подстановка почти всегда покажет наличие ошибки, если таковая была допущена.

Пример 15.5 Найдите фундаментальную систему решений и общее решение однородной системы линейных уравнений:

Решение. Составляем расширенную матрицу системы:

Умножим первую строку последовательно на $ (-2)$ , 5 и 1 и прибавим соответственно ко второй, третьей и четвертой строкам. Получим матрицу

Вторую строку умножим последовательно на числа 4 и 2 и прибавим соответственно к третьей и четвертой строкам. Получим матрицу

Прямой ход метода Гаусса закончен. У полученной матрицы легко определить ранг, ее базисный минор [image] . Отсюда следует, что [image] . По теореме 15.3 число решений в фундаментальной системе равно разности между числом неизвестных и рангом матрицы, в нашем случае фундаментальная система состоит из трех решений.

Переходим к системе уравнений

Неизвестные [image] и [image] оставляем в левой части, остальные переносим в правую часть:

Положим [image] , [image] . Получим [image] , [image] . Первое решение из фундаментальной системы: .

Положим [image] , [image] . Получим [image] , [image] . Второе решение из фундаментальной системы решений: .

Положим [image] , [image] . Получим [image] , [image] . Третье решение из фундаментальной системы решений: . Фундаментальная система решений найдена. Общее решение имеет вид

Ответ: Фундаментальная система решений:
, [image] , [image] , общее решение: .

Замечание 15.7 Если решения, составляющие фундаментальную систему, умножить на любые ненулевые числа, то вновь полученные решения снова будут образовывать фундаментальную систему. Поэтому в предыдущем примере фундаментальную систему образуют и такие решения:
, [image] , [image] . Общее решение можно записать так: .

Вперед: Алгебраические структуры Наверх: Системы линейных уравнений Назад: Структура решений неоднородной системы линейных уравнений


Профильный курс. Методические материалы.

§7 РЕШЕНИЕ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ

1. Введение

В период перехода к информационному обществу особенно актуально использование информационных технологий для решения задач оптимизации.
Решение этих задач может быть получено с помощью методов оптимального проектирования. Широкое применение на практике находят функции и режимы Excel, предназначенные для поиска решений задачи оптимизации.


Профильный курс. Методические материалы.

2. Основные методы решения задач оптимизации

  • линейное и динамическое программирование (задачи распределения ресурсов);
  • теория массового обслуживания (задачи со случайным характером поступления и обслуживания заявок в системе);
  • имитационное моделирование (задачи, где реальный эксперимент заменяется имитационной моделью);
  • статистическое моделирование (задачи, в которых результат находится методами математической статистики из большого числа расчетов с различными факторами);
  • теория управляемых марковских процессов (задачи со случайными неконтролируемыми факторами);
  • теория игр (состязательные задачи в условиях неопределенности);
  • теория расписаний (задачи календарного упорядочения работ);
  • сетевое планирование и управление (задачи с неопределенной оценкой времени выполнения различных видов работ);
  • векторная оптимизация (многокритериальные задачи);
  • теория распознавания образов (задачи поиска) и другие методы.

С дальнейшим развитием производства вопросы оптимального распределения (решения) остаются, становятся более острыми. Например: допустим, что при интуитивном распределении людей на работы, возможность их использования по сравнению с оптимальным вариантом, который получает компьютер, ухудшается всего на 3%. Это небольшая ошибка, которую и заметить можно далеко не всегда. Такая ошибка, скажем, в суконном цехе XV века с 40 работающими, привела бы к недоиспользованию 1 человека.
В наши дни, если принять, что в производстве занято примерно 50 млн. человек, такая ошибка аналогична снижению трудовых ресурсов на 1.5 млн. человек. Как избежать таких ошибок, поможет знание основных методов решения задач оптимизации.


Профильный курс. Методические материалы.

3. Математическая постановка задачи оптимизации

Математическое моделирование

  • дает быстрый ответ на поставленный вопрос (в реальной обстановке решение требует годы);
  • предоставляет возможность широкого экспериментирования (осуществление на реальном объекте часто невозможно).

Правила для успешного математического моделирования:

  1. Учитывать главные свойства моделируемого объекта.
  2. Пренебрегать его второстепенными свойствами.
  3. Уметь отделить главные свойства от второстепенных.

Пример математической модели

Задача. Спроектировать бак, имеющий форму прямоугольного параллелепипеда, объемом V= 2000 м3, так чтобы на его изготовление пошло как можно меньше материала.
Решение.
Объем бака можно вычислить по формуле: V=abh, (7.1)
площадь S=2ab+2ah+2bh (7.2), где a,b,h- стороны бака.
Такую постановку можно записать:
(7.3),
что читается: минимизировать величину S при условии, что V=2000. Подставив в (7.3) значения V (7.1) и S (7.2), получим:
(7.4),
Добавим очевидное, что a, b, h>0, получим математическую модель:
(7.5),
где: ЦФ - целевая функция, ОГР - ограничения, ГРУ - граничные условия

Общий случай задачи оптимизации

Обозначим х1=а, x2=b, x3=h, тогда запишем:
(7.6),
Очевидно, что (7.6) можно записать:
(7.7),
Тогда в общем случае можно записать так:
(7.8),
Систему (7.8) принято записывать более компактно:

(7.9)
Запись (7.9) является общей формой записи задач оптимизации. В эту систему входят три составляющие:

  1. ЦФ - целевая функция или критерий оптимизации, показывает, в каком смысле решение должно быть оптимальным, т.е. наилучшим. При этом возможны 3 вида назначения целевой функции:
    • Максимизация.
    • Минимизация.
    • Назначение заданного значения.
  2. ОГР - ограничение, устанавливают зависимости между переменными. Они могут быть односторонними: gi(xj)≤bi, или двухсторонними: ai≤gi(xj)≤bi. Причем любое двусторонне ограничение можно записать в виде двух односторонних: gi(xj)≥ai, gi(xj)≤bi .
  3. ГРУ - граничные условия. Показывают, в каких пределах могут быть значения искомых переменных в оптимальном решении.

Решения задачи, удовлетворяющие всем ограничениям и граничным условиям, называются допустимыми. Если математическая модель составлена правильно, то мы будем иметь целый ряд допустимых решений.
Важной характеристикой задачи оптимизации является ее размерность, определяемая числом переменных n и числом ограничений m. Соотношение этих величин является определяющим при постановке задачи оптимизации. Возможны три соотношения n<m, n=m, n>m.

  1. n<m
    например:
    Здесь n=1, m=2. Очевидно, что такие задачи решения не имеют, за исключением случая линейно зависимой системы уравнений:
    (то же что случай 2, при n=m=1)
  2. n=m

    Здесь n=m=2. Существует единственное решение, за исключением случая линейно зависимой системы уравнений:
    (то же, что случай 3, при n=2, m=1)
  3. n>m
    x1+x2=5
    Здесь n=2, m=1. Существует бесконечное множество решений.

Так как большинство ограничений записываются в виде неравенств, то рассмотрим, например, следующее неравенство: х1≤5. Введем дополнительную переменную y1≥0 и перейдем от заданного неравенства к уравнению: x1+y1=5 Для этого уравнения n=2, m=1, и следовательно оно имеет бесконечное множество решений.

В общем случае ОГР имеют вид: gi(xj)≤bi i=1..m; j=1..n;
то их можно записать в виде: gi(xj)+yi=bi yi≥0; i=1..m; j=1..n.
В этом случае общее число переменных xj и yi , равное N будет: N=n+m, а число уравнений останется прежним равным m.
Очевидно, что N=n+m>m, и система имеет бесчисленное множество решений. Значит, если ограничениями являются неравенства, то система всегда имеет бесчисленное множество решений.
Т.о. условие n>m - это непременное требование задач оптимизации.

Оптимальное решение - (optimus от лат. наилучший) это наилучшее решение, но наилучшего решения во всех смыслах быть не может. Может быть лучшим только в одном, строго установленном смысле.

Принимающий решение должен абсолютно точно представлять, в чем заключается оптимальность решения, т.е. по какому критерию (kriterio - мерило, оценка) принимаемое решение должно быть оптимальным.

Критерий называют целевой функцией (ЦФ). С помощью критерия можно оценивать качества как желательные (например прибыль, производительность, надежность), так и нежелательные (затраты, расходы, простои и т.д.). Тогда в первом случае стремятся к максимизации критерия, во втором - к минимизации.

Итак, задача имеет оптимальное решение, если она удовлетворяет двум требованиям:

  • есть реальная возможность иметь более одного решения, т.е. существуют допустимые решения;
  • имеется критерий, показывающий, в каком смысле принимаемое решение должно быть оптимальным, т.е. наилучшим из допустимых.

Задачи оптимизации, алгоритмы которых могут быть реализованы с помощью электронных таблиц

Различные по содержанию задачи оптимизации можно решать с помощью MS EXCEL. Рассмотрим классификацию по виду математических моделей, которые включают в себя следующие элементы:

  1. исходные данные;
  2. искомые переменные;
  3. зависимости.

См. рис. 7.1
Исходными данными для математической модели являются:

  • ЦФ - F(xj);
  • левые части ограничений - gi(xj);
  • их правые части - bi

Исходные данные - могут быть детерминированными или случайными.

Детерминированные данные - такие исходные данные, когда при составлении модели их значения известны. Случайные данные - такие исходные данные, если точное их значение заранее неизвестно.
Искомые переменные - могут быть непрерывными и дискретными.

Непрерывными называются такие величины, которые в заданных ГРУ могут принимать любые значения. Дискретными называются такие переменные, которые могут принимать только заданные значения. Целочисленными называются такие дискретные переменные, которые могут принимать только целые значения.

Зависимости между переменными (как целевые функции, так и ограничения) могут быть линейными и нелинейными. Линейными называются такие зависимости, в которые переменные входят в первой степени и с ними выполняются только действия сложения и вычитания. Иначе, если переменные входят не в первой степени или над ними выполняются другие (кроме сложения и вычитания) операции, то зависимости называются нелинейными.

Сочетание различных элементов модели образуют различные классы задач оптимизации:

Исходные данные | Искомые переменные | Зависимости | Классы задач
Детерминированные | Непрерывные | Линейные | Линейного программирования
Детерминированные | Целочисленные | Линейные | Целочисленного программирования
Детерминированные | Непрерывные, целочисленные | Нелинейные | Нелинейного программирования
Случайные | Непрерывные | Линейные | Стохастического программирования

Основные этапы работ при решении задачи оптимизации

  1. Выбор модели - важнейший вопрос, требующий много времени. Если модель выбрана неудачно, то это потерянное время и разочарование в методах оптимизации. Основные требования, которым должна удовлетворять модель:
    • должно существовать, как минимум, два варианта значений параметров, удовлетворяющих ОГР и ГРУ, ведь если вариантов решения нет, значит, и выбирать не из чего;
    • надо четко знать, в каком смысле искомое решение должно быть наилучшим, иначе не помогут ни математические методы, ни ПК.
      Выбор модели завершается ее содержательной постановкой.
  2. Содержательная постановка. Должны быть четко сформулированы элементы математической модели:
    • исходные данные (детерминированные и случайные);
    • искомые переменные (непрерывные и дискретные);
    • пределы, в которых могут находиться значения искомых величин в оптимальном решении;
    • зависимости между переменными (линейные или нелинейные);
    • критерии, по которым следует находить оптимальное решение.
  3. Составление математической модели.
  4. Сбор исходных данных - необходимый этап работы при поиске оптимального решения. Решение задач большой размерности целесообразно начать с контрольного примера. Это потребует собрать на начальном этапе работы небольшое количество исходных данных для быстрой оценки правильности составленной модели. Никакая хорошая сходимость алгоритма, быстродействие и оперативная память ПК не заменят достоверности исходных данных (никакие комбайны не заменят качественных семян).
  5. Решение задачи. Компьютер с помощью прикладных программ (программного обеспечения) реализует алгоритм поиска оптимального решения.
  6. Анализ решения - важнейший инструмент принятия оптимальных решений.
  7. Принятие оптимального решения - конечный этап работы. Решения принимает не компьютер, а человек, который и должен отвечать за результаты принятого решения.
  8. Графическое представление результата решения и анализа - мощный фактор наглядности информации, необходимой для принятия решения.


Профильный курс. Методические материалы.

4. Задачи линейного программирования.

Методы решения задач.

Задача линейного программирования, которая является частным случаем задачи оптимизации записывается следующим образом:
(7.10)

Дана система из n линейных неравенств с n неизвестными и линейная функция F. Требуется найти решение системы x1, x2, x3…xn, удовлетворяющей ГРУ, при котором функция F принимает max значение.

Задачи линейного программирования можно решить аналитическим путем и графическим методом. Второй метод - наглядный, но пригоден лишь для n=2 ( т.е. где число переменных = 2).

Пример

Известно, что уравнение прямой имеет вид: a1x1+a2x2=b. Построим прямую 2x1+x2=2. Перепишем это уравнение в виде:

При такой форме записи в знаменателе показаны отрезки, которые отсекает прямая на осях координат (Рис. 7.2). Если от исходного уравнения перейти к неравенству 2x1+x2≤2, то графически решение этого неравенства показано на рис. 7.3, т.е. решением линейного неравенства с двумя переменными является полуплоскость. На рис. 7.3 часть плоскости, которая не удовлетворяет неравенству расположена выше прямой, заштрихована. Координаты всех точек, принадлежащих не заштрихованной части плоскости, имеют такие значения х1 и х2, которые удовлетворяют заданному неравенству. Эта полуплоскость является областью допустимых решений (ОДР).

Рассмотрим систему неравенств:

Для удобства запишем ее в следующем виде:

Графическое решение этой системы показано на рис. 7.4
Решением этой системы являются координаты всех точек, принадлежащих ОДР, т.е. многоугольнику ABCDO.
Т.к. в ОДР бесчисленное множество точек, значит, рассматриваемая система имеет бесчисленное множество допустимых решений.
Если мы хотим найти оптимальное решение, то мы должны принять целевую функцию. Пусть мы хотим, чтобы решение было оптимальным в смысле максимизации целевой функции F=x1+x2→max

Эта зависимость на рис. 7.5 представлена в форме уравнения прямой с угловым коэффициентом x2=F-x1, из которого видно, что tga= -1. При этом угол a=135°, а величина F равна отрезку, отсекаемому прямой на оси ординат. Если прямую перемещать параллельно самой себе в направлении, указанном стрелками, то величина F будет возрастать. Совместим теперь ОДР, изображенную на рис. 7.4, с линией целевой функции F, построенной на рис. 7.5, получим рис. 7.6.

Поскольку требуется найти оптимальное решение, при котором целевая функция F=x1+x2→max, т.е. стремится к максимуму, будем перемещать график целевой функции в направлении увеличения F. Очевидно, что оптимальным решением будут координаты точки С, равные х1* и х2*. При этом F=F*.

На основании рассмотренного можно сделать вывод: оптимальным решением являются координаты вершин ОДР.

На этом базируется аналитический метод решения задач линейного программирования, который заключается в следующем:

  • Найти вершины ОРД, как точки пересечения ограничений.
  • Определить последовательно значения целевой функции в вершинах.
  • Вершина, в которой ЦФ приобретает оптимальное (максимальное или минимальное) значение, является оптимальной вершиной.
  • Координаты этой вершины и являются искомыми оптимальными значениями переменных.

Основные положения симплекс-метода

Для аналитического решения задач линейного программирования разработан специальный алгоритм направленного перебора вершин ОРД (области допустимых решений). Этот алгоритм обеспечивает переход от одной вершины к другой в таком направлении, при котором значение целевой функции от вершины к вершине улучшается. В геометрии есть такое понятие, как "симплекс". Симплексом тел в К-мерном пространстве называется совокупность (К+1) его вершин. Так, для плоскости при К=2 симплексом будут 3 вершины треугольника. При К=3 - 4 вершины четырехгранника и т.д. С учетом этого понятия аналитический метод решения задач линейного программирования называется симплекс-метод. Вычисления, обеспечивающие определение значения ЦФ и переменных в одной вершине называются итерацией.


Вариационные ряды

Вариационнные ряды и их характеритики

Сведения из курса математической статистики:

Пусть для изучения количественного признака X из генеральной совокупности извлечена выборка x1, x2, ..., xn объема n. Наблюдавшиеся значения xi называют вариантами, а их последовательность, записанная в возрастающем порядке - вариационным рядом.

Вариационные ряды бывают дискретными и интервальными (непрерывными).

Для изображения дискретного вариационного ряда служит полигон - ломаная, соединяющая точки плоскости с координатами (xi, ni).

Для представления интервальных вариационных рядов служит гистограмма - ступенчатая фигура из прямоугольников, основаниями которых служат длины интервалов h, а высоты равны отношению ni/h.

Для построения интервального вариационного ряда множество значений вариант разибают на интервалы, т.е производят их группировку. Рекомендуется количество групп выбирать по формуле Стерджеcса.

k=1+1,4 lnn , тогда длина интервала равна h=(xmax-xmin) /k.

Точечные оценки параметров распределения:

Несмещенной оценкой генеральной средней (математического ожидания) служит выборочная средняя

, xi варианта выборки, ni частота варианты, n- объем выборки

выборочная дисперсия – смещенная оценка генеральной дисперсии.
исправленная выборочная дисперсия - несмещенная оценка генеральной дисперсии.

- выборочное среднее квадратическое отклонение

исправленное среднее квадратическое отклонение.

Особенности построения вариационных рядов и вычисления точечных оценок параметров в MS Excel:

Для построения вариационного ряда по выборочным данным в MS Excel есть функция частота(массив_данных;массив_интервалов).

Массив_данных | Массив_интервалов
массив или ссылка на множество данных, для которых вычисляются частоты | массив или ссылка на множество интервалов, в которые группируются значения аргумента массив_данных

частота вводится как формула массива:
1. выделяем диапазон результата B2:B11

2. вводим формулу

3. Нажимаем Ctrl+Shift+Enter

Вычислять приведенные выше статистические параметры можно и без построения вариационного ряда с помощью следующих функций MS Excel (группа Статитистические)

xср= | срзнач()
D= | диспр()
сигма= | стандотклонп()
s2= | дисп()
s= | стандотклон()

Примечание: при вычислениях точечных оценок для вариационных рядов удобно использовать функцию суммпроизв()

Задание:

1. Имеется выборка случайных значений величины X - оценки на экзамене по философии Стат.xls.
Файл Стат.xls сохранить на свой сетевой диск под именем вида Фамилия-стат.xls. На новом листе Вариац-з1 построить дискретный вариационный ряд, полигон, найти выборочное среднее, дисперсию (выборочную и исправленную), среднее квадратическое отклонение (выборочное и исправленное) . Набрать математические формулы с помощью редактора формул (Вставка - Объект - Microsoft Equation)

2. Дана выборка - измерений роста 500 мужчин (ai, bi, ni).

На новом листе Вариац-з2 построить интервальный вариационный ряд , гистограмму, найти выборочное среднее, дисперсию (выборочную и исправленную), среднее квадратическое отклонение (выборочное и исправленное) . Набрать математические формулы с помощью редактора формул (Вставка - Объект - Microsoft Equation).

Примечание: В кач-ве xi для расчетов берутся середины интервалов ai,bi. Высота столбцов гистограммы ni/h.


Интервальные оценки параметров

Сведения из курса математической статистики:

Доверительный интервал для генерального среднего представляет интервал значений вокруг выборочной оценки среднего [image], где с данным уровнем надежности (доверительной вероянтостью) [image], находится истинное" (неизвестное) генеральное среднее .
, где [image] - предельная ошибка выборки (наибольшее отклонение выборочного параметра от его истинного значения)

Например, если среднее выборки равно 23, а нижняя и верхняя границы доверительного интервала с уровнем надежности
=0,95 равны 19 и 27 соответственно, то можно заключить, что с вероятностью 95% интервал с границами 19 и 27 накрывает генеральное среднее, при этом [image] =4.

Предельная ошибка выборки [image] для генерального среднего

Повторная выборка |  | Бесповторная выборка
1 | 2 | 3 | 4
n>30 | n<=30 | n>30 | n<=30

n- объем выборки, N- объем генеральной совокупности, при [image] расчеты ведутся по формулам повторной выборки.
В случае, когда n>30 t- значение аргумента функции Лапласа ищется по таблицам функции Лапласа, в Excel через функцию НОРМСТОБР(( [image] +1)/2)

В случае, когда n<=30 [image] находится по таблицам распределения Стьюдента (n-1 степень свободы), в Excel через функцию =СТЬЮДРАСПОБР( [image];n-1).

- уровень значимости [image] =1-

В Excel для больших выборок предельную ошибку выборки [image] можно получить с помощью функции [image] =ДОВЕРИТ( [image];s;n)

Если установить больший уровень доверия, то интервал станет шире, поэтому возрастает вероятность, с которой он "накрывает" неизвестное среднее, и наоборот. Заметим, что ширина доверительного интервала зависит от объема или размера выборки, а также от разброса (изменчивости) данных. Увеличение размера выборки делает оценку среднего более надежной. Увеличение разброса наблюдаемых значений уменьшает надежность оценки . Вычисление доверительных интервалов основывается на предположении нормальности наблюдаемых величин. Если это предположение не выполнено, то оценка может оказаться плохой, особенно для малых выборок. При увеличении объема выборки, скажем, до 100 или более, качество оценки улучшается и без предположения нормальности выборки.

Точечные оценки параметров распределения:

Несмещенной оценкой генеральной средней (математического ожидания) служит выборочная средняя

, xi варианта выборки, ni частота варианты, n- объем выборки

выборочная дисперсия – смещенная оценка генеральной дисперсии.
исправленная выборочная дисперсия - несмещенная оценка генеральной дисперсии.

- выборочное среднее квадратическое отклонение

исправленное среднее квадратическое отклонение.

Вычислять приведенные выше статистические
  параметры можно и без построения вариационного ряда с помощью следующих функций
  MS Excel (группа Статитистические)
xср= срзнач()
D= диспр()
сигма= стандотклонп()
s2= дисп()
s= стандотклон()

Примечание: при вычислениях точечных оценок для вариационных рядов удобно использовать функцию суммпроизв()

Задание:

1) В результате выборочного обследования жилищных условий, получен следующий ряд распределения. Требуется с уровнем надежности 95% определить границы интервала, в который попадает средний размер общей площади. Предельную ошибку выборки [image] вычислить двумя способами по формуле (1) и через доверит().

2) Вычислить доверительный интервал, при условии, что проводится ислледование жилищных условий для села с числом жителей N=5000 и взята выборка из n=20 жителей.
Указание: т.к. ряд на рис. не вариационный, вычисления следует проводить с помощью функций срзнач(), стандотклон(). Вычисления [image] проводить по формуле (4) - бесповторная выборка, n<=30.


Гипотеза о нормальном распределении

Сведения из курса математической статистики:

Пусть для изучения количественного признака X из генеральной совокупности извлечена выборка x1, x2, ..., xn объема n. Наблюдавшиеся значения xi называют вариантами, а их последовательность, записанная в возрастающем порядке - вариационным рядом.

Вариационные ряды бывают дискретными и интервальными (непрерывными).

Для изображения дискретного вариационного ряда служит полигон - ломаная, соединяющая точки плоскости с координатами (xi, ni).

Для представления интервальных вариационных рядов служит гистограмма - ступенчатая фигура из прямоугольников, основаниями которых служат длины интервалов h, а высоты равны отношению ni/h.

Для построения интервального вариационного ряда множество значений вариант разибают на интервалы, т.е производят их группировку. Рекомендуется количество групп выбирать по формуле Стерджеcса.

k=1+1,4 lnn , тогда длина интервала равна h=(xmax-xmin) /k.

Особенности построения вариационных рядов и вычисления точечных оценок параметров в MS Excel:

Для построения вариационного ряда по выборочным данным в MS Excel есть функция частота(массив_данных;массив_интервалов).

Массив_данных | Массив_интервалов
массив или ссылка на множество данных, для которых вычисляются частоты | массив или ссылка на множество интервалов, в которые группируются значения аргумента массив_данных

частота вводится как формула массива:
1. выделяем диапазон результата B2:B11

2. вводим формулу

3. Нажимаем Ctrl+Shift+Enter

Вычислять приведенные выше статистические параметры можно и без построения вариационного ряда с помощью следующих функций MS Excel (группа Статитистические)

xср= | срзнач()
D= | диспр()
сигма= | стандотклонп()
s2= | дисп()
s= | стандотклон()

Примечание: при вычислениях точечных оценок для вариационных рядов удобно использовать функцию суммпроизв()

Проверка гипотезы о нормальном распределении генеральной совокупности

Для того, чтобы при уровне значимости альфа проверить гипотезу о нормальном распределении генеральной совокупности, надо:

  1. Вычислить выборочную среднюю и выборочное среднее квадратическое отклонение
  2. Вычислить значение функции плотности распределения f(xi,xcp,сигма) c помощью функции нормрасп(xi;xcp;сигма;0)
  3. Вычислить теоретические частоты ni'=n*h*f (xi,xcp,сигма)
  4. Вычислить наблюдаемое значение критерия Пирсона
  5. Сравнить наблюдаемое значение критерия Пирсона с критическим хи2обр(альфа;s-3 ), где s -число объединенных интервалов (Интервалы с частотами объединяются если ni<5. Например, если n1=2, n2=3, n3=4, в результате объединения получим один интервал с частотой 2+3+4=9). Если [image], принимаем гипотезу о нормальном распределении генеральной совокупности. В противном случае гипотезу о нормальном распределении генеральной совокупности отвергают.

Задание:

1.Проверить гипотезу о нормальном распределении генеральной совокупности роста мужчин при уровне значимости. Построить график функции плотности распределения.

альфа=0,05.

Результаты оформить на листе Норм1 в файле под именем вида Фамилия-распределение.xls

2. Проверить гипотезу о нормальном распределении коэффициента IQ.

альфа=0,05.

Результаты оформить на листе Норм2, Норм3 в файле под именем вида Фамилия-распределение.xls


Гипотеза о нормальном распределении

Проверка гипотезы о нормальном распределении генеральной совокупности

Задание:

1. Проверить гипотезу о нормальном распределении коэффициента IQ.

альфа=0,05.

Результаты оформить на листе Норм2, Норм3 в файле под именем вида Фамилия-распределение.xls

2. Проверить гипотезу о нормальном распределении (альфа=0,5) концентрации внимания (сек), полученного по таблице Шульте. Построить гистограмму и график эмпирических и теоретических частот.


Корреляционный анализ

Линейны коэффициент корреляции характеризует степень тесноты линейной зависимости. Линейная вероятностная зависимость величин заключается в том, что при возрастании одной случайной величины, другая имеет тенденцию возрастать (или убывать) по линейному закону. Эта тенденция к линейной зависимости может быть более или менее ярко выраженной, т.е. более или менее приближаться к функциональной. В общем случае, когда величины X и Y связаны произвольно вероятностной зависимостью, линейный коэффициент корреляции принимает значение в пределах -1<rxy<1. Если случайные величины связаны точной линейной функциональной зависимостью, то rxy=+1 или rxy= -1. Если знак коэффициента линейной корреляции "+", то большей величине одного признака соответствует большая величина другого признака (прямая пропорциональная зависимость). Если знак коэффициента линейной корреляции "-", то большей величине одного признака соответствует меньшая величина другого признака (обратная пропорциональная зависимость).
Формула для подсчета коэффициента корреляции.

В Excel коэффициент корреляции Пирсона можно вычислитьс помощью функции коррел() или Пирсон().

Проверка гипотезы о значимости выборочного коэффициента корреляции Пирсона

Для того, чтобы при уровне значимость альфа проверить нулевую гипотезу о равенстве нулю генерального коэффициента корреляции нормальной двумерной случайной величины H0: rxy=0 при конкурирующей гипотезе H1: rxy<>0, надо вычислить наблюдаемое значение критерия T,

найти tкр=стьюдраспобр(альфа; n-2).
Если |T|<tкр принимаем H0, в противном случае принимаем H1.

Нахождение доверительного интервала для коэффициента корреляции

  1. Найти [image] =нормстобр(( [image] +1)/2)
  2. Найти z’=Фишер(rxy)
  3. Найти доверит интервал для величины z

  4. На основе обратного преобразования Фишера найти доверительный интервал для коэффициента корреляции
    rлев=фишеробр(zлев)
    rпр=фишеробр(zпр)

Коэффициент корреляции рангов Спирмена

, где D - разность между рангами по двум переменным X и Y.

При наличии одинаковых рангов в формулу для вычисления коэффициента корреляции Спирмена добавляются поправки на oдинаковые ранги.

D1=(k3-k)/12, где k - количество одинаковых рангов в первом столбце.
D2=(l3-l)/12, где l - количество одинаковых рангов во втором столбце.
Если в столбце имеется две группы одинаковых рангов, то формула поправки несколько усложняется.
D2=((l3-l)+ (k3-k))/12 , где k-количество одинаковых рангов в первой группе ранжируемого столбца, l - количество одинаковых раногов во второй группе ранжируемого столбца.

Проверка гипотезы о значимости выборочного коэффициента корреляции Спирмена

Для того, чтобы при уровне значимость альфа проверить нулевую гипотезу о равенстве нулю генерального коэффициента ранговой корреляции Спирмен двумерной случайной величины H0: =0 при конкурирующей гипотезе H1: <>0, надо вычислить наблюдаемое значение критерия T,

найти tкр=стьюдраспобр(альфа; n-2).
Если | [image] |<Tкр принимаем H0, в противном случае принимаем H1.

Задание:

  1. 20 школьникам были даны тесты на наглядно-образное и вербальное мышление.
    Измерялось среднее время решения заданий теста в секундах. Психолога интересует вопрос: существует ли взаимосвязь между временем решения этих задач? (Проверить гипотезу о равенстве 0 коэффициента корреляции Пирсона, найти доверительный интервал для коэффициента корреляции)

  2. Психолог выясняет, как связаны между собой индивидуальные показатели готовности к школе, полученные у первоклассников до начала обучения в школе и их средняя успеваемость в конце учебного года (нет одинаковых рангов)

  3. Психолог, используя тест умственного развития (ШТУР) проводит исследование интеллекта у 12 учащихся 9 класса. одновременно с этим он просит учителей литературы провести ранжирование этих же учащихся по показателям умственного развития. Задача заключается в том, чтобы определить, как связаны между собой объективные показатели умственного развития и экспертные оценки учителей(случай одинаковых (равных ) рангов, альфа=0,01).
  4. По выборочным данным, представленным в таблице требуется установить взаимосвязи между указанными показателями. Для вычисления коэффициентов корреляции использовать Пакет анализа (Сервис-Анализ данных-Корреляция)


Регрессионный анализ

В классической математической статистике предполагается известным вид закона распределения и производится оценка значений его параметров по результатам наблюдений. Но обычно заранее вид закона распределения неизвестен, а теоретические предположения не позволяют его однозначно установить. Обработка ЭД также не позволит точно вычислить истинный закон распределения показателя. В таком случае следует говорить только об аппроксимации (приближенном описании) реального закона некоторым другим, который не противоречит ЭД и в каком-то смысле похож на этот неизвестный истинный закон.

В соответствии с этими положениями постановка задачи аппроксимации закона распределения ЭД формулируется следующим образом.

Имеется выборка наблюдений (x1, x2, …, xn) за случайной величиной Х . Объем выборки п фиксирован.

Необходимо подобрать закон распределения (вид и параметры), который бы в статистическом смысле соответствовал имеющимся наблюдениям.

Регрессионный анализ

Регрессионный анализ заключается в определении аналитического выражения связи зависимой слвчайной величины Y (называемой также результативным признаком) с независимыми случайными величинами X1, X2, ...,Xm (называемыми также факторами).

Форма связи результативного признака Y с факторами X1, X2, ...,Xm получила название уравнения регрессии. В зависимости от типа выбранного уравнения различают линейную и нелинейную регрессию. Нелинейная в свою очередь может быть квадратичной, экспоненциальной, логарифмической и т.д.

В зависимости от числа взаимосвязанных признаков различаю парную (если исследуется связь между двумя признаками - результативными и факторным) и множественную (между тремя и более признаками) регрессию.

Уравнение парной линейной регрессии Y на X имеет вид
y=a1x+a0, где a1=rxySy/Sx

Уравнение парной линейной регрессии X на Y имеет вид
y=b1x+b0, где b1=ryxSx/Se

В MS Excel коэффициенты a1, b1 можно вычислить с помощью функции НАКЛОН(),
коэффициенты a0, b0 можно вычислить с помощью функции ОТРЕЗОК(),

Более полные статистические данные для анализа уравнения регрессии можно получить с помощью функции ЛИНЕЙН(), которая вводится как формула массива (Ctrl+Shift+Enter) и служит для расчета данных, описывающих линейной множественной или парной регрессии на основе метода наименьших квадратов.

y=a1x+a0 (парная линейная регрессия)
или
y=a2x2 +a1x1 + a0(множественная линейная регрессия)

ЛИНЕЙН(известные_значения_y;известные_значения_x;конст;статистика)

Известные_значения_x — необязательное множество значений факторных признаков X1, X2, ...,Xm (один или несколько столбцов)

Конст — логическое значение, которое указывает, требуется ли, чтобы a0=0. Если конст имеет значение ИСТИНА или опущено, то a0 вычисляется обычным образом.

Статистика — логическое значение, которое указывает, требуется ли вернуть дополнительную статистику по регрессии.

Если аргумент статистика имеет значение ИСТИНА, то функция ЛИНЕЙН возвращает дополнительную регрессионную статистику. Если аргумент статистика имеет значение ЛОЖЬ или опущен, то функция ЛИНЕЙН возвращает только коэффициенты ai.

Дополнительная регрессионная статистика:

am, ...,a1,a0
sem,...,se1,se0 Стандартные значения ошибок для коэффициентов am, ...,a1,a0. Коэффициенты am, ...,a1,a0, которые окажутся меньше своих стандартных ошибок должны быть исключены из уравнения регрессии.
R2 Коэффициент детерминации. Сравниваются фактические значения y и значения, получаемые из уравнения прямой; по результатам сравнения вычисляется коэффициент детерминированности, нормированный от 0 до 1. Если он равен 1, то имеет место полная корреляция с моделью, т. е. нет различия между фактическим и оценочным значениями y. В противоположном случае, если коэффициент детерминированности равен 0, то уравнение регрессии неудачно для предсказания значений y.
sey Стандартная ошибка для оценки y.
F F-статистика, или F-наблюдаемое значение. F-статистика используется для определения того, является ли наблюдаемая взаимосвязь между зависимой и независимой переменными случайной или нет.
df Степени свободы. Степени свободы полезны для нахождения F-критических значений в статистической таблице. Для определения уровня надежности модели нужно сравнить значения в таблице с F-статистикой, возвращаемой функцией ЛИНЕЙН.
SSф Регрессионная сумма квадратов.
SSо Остаточная сумма квадратов.

Определение значимости уравнения регрессии

H0: уравнение незначимо.

H1: уравнение значимо при уровне значимости альфа.

Для определения значимости уравнения регрессии после вычисления дополнительной регрессионной статистики необходимо сравнить полученное значение F с Fкр=Fраспобр(альфа;m,n-(m+1)), m-количество факторов, n - число наблюдений.
Если F <Fкр принимаем H0. В противном случае принимаем H1

При изучении регрессии следует придерживаться определенных этапов:

Задание аналитической формы уравнения регрессии

Проверка общего качества уравнения регрессии

Проверка статистической значимости каждого коэффициента уравнения регрессии

Множественная линейная регрессия реализована в режиме Регрессия Пакета анализа MS Excel.

Линии тренда

Линии тренда позволяют графически отображать тенденции данных и прогнозировать их дальнейшие изменения. Подобный анализ называется также регрессионным анализом (Регрессионный анализ. Форма статистического анализа, используемого для прогнозов. Регрессионный анализ позволяет оценить степень связи между переменными, предлагая механизм вычисления предполагаемого значения переменной из нескольких уже известных значений.). Используя регрессионный анализ, можно продлить линию тренда в диаграмме за пределы реальных данных для предсказания будущих значений.
Скользящее среднее. Можно вычислить скользящее среднее (Скользящее среднее. Последовательность средних значений, вычисленных по частям рядов данных. На диаграмме линия, построенная по точкам скользящего среднего, позволяет построить сглаженную кривую, более ясно показывающую закономерность в развитии данных.), которое сглаживает отклонения в данных и более четко показывает форму линии тренда.
Типы линий тренда: выбор наиболее подходящего типа аппроксимации данных
Существует шесть различных видов линий тренда (аппроксимация и сглаживание), которые могут быть добавлены на диаграмму Microsoft Excel. Способ следует выбирать в зависимости от типа данных.
Точность аппроксимации . Линия тренда в наибольшей степени приближается к представленной на диаграмме зависимости, если значение R-квадрат (Значение R в квадрате. Число от 0 до 1, которое отражает близость значений линии тренда к фактическим данным. Линия тренда наиболее соответствует действительности, когда значение R в квадрате близко к 1. Оно также называется квадратом смешанной корреляции.) равно или близко к 1. При аппроксимации данных с помощью линии тренда значение R-квадрат рассчитывается автоматически. Полученный результат можно вывести на диаграмме.
Линейная
Линейная аппроксимация — это прямая линия, наилучшим образом описывающая набор данных. Она применяется в самых простых случаях, когда точки данных расположены близко к прямой. Говоря другими словами, линейная аппроксимация хороша для величины, которая увеличивается или убывает с постоянной скоростью.
Шаг за шагом
1.Выделите диаграмму.
2.Выберите оманду Chart (Диаграмма)>Add
Trendline (Добавить линию тренда).Раскройте
вкладку Type (Тип)от рывшегося окна диалога Add
Trendline (Линия тренда).
3.Укажите ряд данных,на основе которых нужно
создать линию тренда.
4.Из шести вариантов:linear (линейный),logarithmic
(логарифмический),power (степенной),exponential
(экспоненциальный),polynomial
(полиномиальный)и moving average (скользящее
среднее)- выберите требуемый..
5.Щелкните на вкладке Options (Параметры),чтобы
указать параметры линии тренда:название линии
тренда (либо она ставится автоматически,в
зависимости от варианта линии),параметры
прогнозирования и т.д.Щелкните на кнопке ОК.

Задание:
  1. Установить форму взаимосвязи между показателем невербального интеллекта X и успешностью обучения по математике. Получить уравнение регрессии Y на X и проверить его значимость. Расчеты провести с помощью функции ЛИНЕЙН (). Построить графическую модель, используя точечную диаграмму и линию тренда.
    На вкладке Параметры диалогового окна Формат линии тренда установить флажки:
    Показывать уравнение на диграмме.
    Поместить на диаграмму величину достоверности аппроксимации (R^2)

    Построение линии тренда

  2. 10 менеджеров оценивались по методике экспертных оценок психологических характеристик личности руководителя. Психолога интересует связь с тактичности Y с требовательностью X1 и критичностью X2. Получить коэффициенты уравнения регрессии с помощью функции ЛИНЕЙН() и с помощью Сервис- Анализ данных - Регрессия.